Jump to content
LaunchBox Community Forums

Weird issue - double mapped button in BB


usuallee76
 Share

Recommended Posts

Hey guys, hoping there might be some suggestions for a strange issue in BB  I encountered last night. All of a sudden, the A button (or X button, as I'm using a PS 4 controller with Input mapper) is acting like it's double mapped. Meaning, it was mapped with A as back and the B is select, Nintendo-style. But then I tried to remap the button to be A as select and B as back (Xbox style). While I did this, the A button was briefly mapped as both select and back, in BB. I of course changed this. But it seems to have retained both the back AND select functions. I.e., it will go into let's say PS2 games, but then back right out. It's acting like it's doing Select, then immediately doing the Back on one button press.

The settings look like everything is fine. I checked the LB settings config file, and everything looks fine there too. I tried remapping numerous times in various ways. That one button just won't cooperate. Button works as it's supposed to, in game. I tried my 8Bitdo N30 controller (sans input mapper) and it does not have this issue. At that point I gave up and went to bed.

Would appreciate any suggestions. I think when I get home I'll delete the controller in Windows, then plug it back in and hopefully it will reinstall, and try to incorporate Input Mapper. Anything else I should try? Thanks in advance!

Edited by usuallee76
Link to comment
Share on other sites

Thanks for your interest but I'm not sure where you got Steam from based on what I said above. Not trying to be a jerk or an ingrate, maybe you know something I don't (this is quite probable, in fact) & I appreciate the input.  But while I do have Steam, it's been a month or two since I've fired it up, and the controller was working fine in BB as of Saturday. Also, I don't use the same controller setup for Steam. Did get everything working, albeit I don't know precisely how. The button was still acting like it was mapped as both Select and Back in BB. I even remapped Select to another button and the issue migrated to that button, it was still doing select, then back on one button press.

Was kinda pulling my hair out, so I rolled LB back to the 10.7 stable version as well as started deleting every remotely relevant thing I could find in Device Manager so it could reinstall. Should've been a little more systematic so I'd know what the cause was. But while I enjoy tinkering and troubleshooting to a point, I lost patience with spending a second evening on this when all I wanted to do was play a little Ratchet & Klank. So I just started rapidly doing whatever I could think of. It worked.

Not totally sure LB is to blame though, as suddenly my controller couldn't be mapped correctly in PCSX2 either. Might have been a weird Windows issue. Got that fixed as well though finally. But now suddenly PCSX2 can't load saved games at all, even though the files are still there in the memcard folder, so I still have that to try and deal with ? It's been a cascading series of failures, when everything was working absolutely perfectly on Saturday.

Has anybody else experienced that where everything seems great then all of a sudden it's issue after issue seemingly out of thin air? It's been quite frustrating. But I keep telling myself "troubleshooting is part of the fun", "be grateful for what you have", etc.

Cheers & thanks for the input

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...