Jump to content
LaunchBox Community Forums

Help Mapping Controls for NES in LaunchBox/RetroArch


Recommended Posts

Hi Everyone, 

I have read a number of forums, and tried a number of approaches to map my arcade cab joystick/buttons to a NES the original control buttons to no avail.  

Bottom-line - I am wanting to emulate the NES (classic) with RetroArch. I don't want to use a controller, I want to use the joystick/buttons on my arcade cab. It appears that out-of-the-box, buttons A, B, Start and directional pad is all mapped, but I can't seem to get the "select" button mapped.

I have tried editing the retroarch.cfg file (there appears to be up to 15 player repeated configurations.  I tried mapping to xxx_select,  xxx_select_btn on player 1 and player 2 in the config file - and it never recognizes the "select".  As a test, I've used a few games (e.g. Zelda to complete the player registration, where "select" moves the heart).  

I have also tried going to the RGUI (F1) while I have a game launched with Retroarch, and setting the "select" to coin 1 in the Retroarch "input" settings unsuccessfully.

This seems like something over completed and should be easy to do.  What am I missing?  

Edited by X3R0X
Link to comment
Share on other sites

Using Arcade stick and buttons here on the NES through Mesen via RetroArch through LaunchBox

Load RetroArch outside of Launchbox

Settings -WITHOUT loading a core


Port 1 controls

Highlight "Select Button"

Press Enter

Press actual Arcade button you want

The button you have pressed should get registered as Select and in theory that carries across into Mesen or at least it does here.

Repeat for as many players as you want.

oh and if you want to do it via config file in text editor

input_player1_select_btn = "Put the Number of your button here"

Don't know how to get your button number

Press the Windows button on your keyboard

Type Joy.cpl in search


Properties on the joystick you are using

Press the button you want to use and a number lights up - That ISN'T the number to use

Subtract ONE from this number and that is the number you want to use - Why subtract ONE - not a damn clue, except Windows recognises 1st button as number ONE and RetroArch recognises 1st button as Number ZERO. Maybe someone with some intelligence can explain this.

Now when I load up a Core the select button is already the correct button for me.

Link to comment
Share on other sites

First thing we need to know if whether your arcade controls are mapped to key strokes or joysticks? 

If its keyboard, (like iPac in default mode), using any input_player1_btn lines won't work. Those are for devices in joystick mode.

If you arcade controls encoder is in keyboard mode, you use the lines without btn in them.

Here is the settings I use for my arcade controls using an iPac in keyboard mode:


input_player1_a = "z"
input_player1_b = "v"
input_player1_l = "ctrl"
input_player1_l2 = "space"
input_player1_l3 = "t"
input_player1_left = "left"
input_player1_r = "h"
input_player1_r2 = "x"
input_player1_r3 = "b"
input_player1_right = "right"
input_player1_start = "num1"
input_player1_up = "up"
input_player1_x = "shift"
input_player1_y = "c"

input_player1_select = "num5"


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...