Jump to content
LaunchBox Community Forums
maabus

Retroarch change allowed core extensions

Recommended Posts

I would like to switch some of my roms over to the mame software list. One of the systems I'm trying to use is WonderSwan Color. The mame software list roms are zipped in .bin format. When I try to run retroarch it does not suggest the (beetle cygin) core. If i extract the .bin file and change the extension to .wsc, and run retroarch it will suggest the core. 

Is there any way to tell the core to allow .bin files? 

Share this post


Link to post
Share on other sites
54 minutes ago, maabus said:

I would like to switch some of my roms over to the mame software list. One of the systems I'm trying to use is WonderSwan Color. The mame software list roms are zipped in .bin format. When I try to run retroarch it does not suggest the (beetle cygin) core. If i extract the .bin file and change the extension to .wsc, and run retroarch it will suggest the core. 

Is there any way to tell the core to allow .bin files? 

You can force load BIN files via LB it is just through the RA frontend that you won't see non-WS extensions.  Just drag and drop the BIN file in LB and then associate with the WonderSwan platform and have Retroarch setup as the emulator.  LB will launch as a command line and it will load a BIN file even though the core via the RA front end will not see it since looking for different extensions.  

You can also load the MAME zip files the same way but you would need to make sure to check the extract rom box. Then LB will extract first and send to RA as BIN.  If this causes issues with your other RA setups then either setup another RA emulator instance or use the first method by extracting first and setting to point BIN versus ZIP.

Capture.thumb.JPG.86a14a799ac4b5b5cc4ab39f35ab6a33.JPGOtherwise, no, you cannot force the core in the RA content loader view to see anything that is not a core valid extension.  However, via command line (i.e., LB method above), RA will try and load whatever you tell it to since the content view restricting extensions is not applicable. Of course you have to be sure the file you are trying to send is valid or obviously won't work regardless. 

Edited by sundogak

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...