Jump to content
LaunchBox Community Forums

Can't get MAME to run


Recommended Posts

I moved to Launchbox from Maximus Arcade (which worked fine but I got tired of constantly updating the titles every time I wanted to alter anything) and purchased the full Launchbox package. Running a decent core i3 with 4 GB RAM, onboard Intel graphics and Windows 10. I have not opted to go fullset as I have a specific set of 177 ROMs I want to import for my cabinet. so I attempted to upload the MAME ROMs using the same method you would SNES, SEGA, N64 etc... Those seem to have worked for those systems, but MAME and NES do not. I used Retroarch at first but when that didn't work, I moved to just regular MAME emulator (.161). Troubleshooted after much time on several forums, and ended up just doing a clean install. I started with MAME, and while it seems to import the ROMs and download all the files from EmuMovies, Launchbox just will not run MAME ROMs. I can run them just fine from MAME64, and even from Retroarch with the first MAME core option. But Launchbox just won't do it. I made sure my MAME.ini file points to the same directory as the Launchbox files for the ROMpath. I made sure the emulator file for Launchbox's MAME points to the same directory as the emulator with said .ini file. Not sure what I am doing wrong and would appreciate any help. 

mame help 1.PNG

Link to comment
Share on other sites

Remove the keyboard input provider dinput part of the commandline, its not compatible with such a old version of mame that you are using. As for NES have you specified the correct core to use in the associated platform tab for your Retroarch emulator entry.

Link to comment
Share on other sites

True story: The cabinet is in a third garage bay in my house which was added on by the previous owners so I had no use for it other than a game room. Built the cabinet from spare parts left behind. When 2020 hit, nobody came around to hangout and the arcade room went to disrepair, eventually being used for storage. I have been unmotivated to do anything about it, and realized the reason was because I had started the reconstruction of the frontend in 2019 and never finished it. I realized the other day I needed to fix Launchbox first before doing any other cleaning could occur, and so it has sat filthy. Until now. It's time to get the arcade back up and lit. Thanks man.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...