Jump to content
LaunchBox Community Forums

Issue Using External AHK Script with BigBox


Recommended Posts

I may just be dumb, but I've been fighting with this all day trying to fix this so I figure it's worth the ask. I use my computer as a smart tv/gaming console and I control it with a little 'Wechip W1" airmouse/remote control. I use AHK scripts to make the buttons on it contextual and behave differently based on the application that is focused. This has worked quite well with many applications (including BigBox at some point in the past). However, some recent update has broken this interaction. It's important to note that this isn't broken for all keys, just the very specific one my remote uses.

The key in question is the "Browser_Home" key (Yes, that is the actual key name that AHK understands, apparently just as valid as "Space"). The default functionality of this key is to open your default web browser to the home page. I use it typically to close the current application and return to Kodi (which serves as my root menu and main UI). The Problem here is that whenever BigBox is focused, whatever functionality I have mapped to the "Browser_Home" key is completely ignored. Even if the script is as simple as unconditionally do nothing when "Browser_Home" key is pressed, it still just opens the web browser.

This more or less breaks the perfect integration I had with Big Box previously. I don't really have any alternatives except maybe switch to just LaunchBox which lacks the clean UI of BigBox. Any suggestions here would be helpful.

Thanks in advance.

Link to comment
Share on other sites

First off, I never knew about "Browser_Home" before.  That's pretty cool!  Not practical for my use, but cool to know none-the-less. :) 

I ran a simple test using Browser_Home::MsgBox hello and I'll be daw-gone, it worked.  lol  Thanks!  The 'problem' is that it worked when in BigBox as well.  (Latest beta)  I tested using my Logitech keyboard which requires the function (FN) key.  So my "Home" is FN+F1.  (not sure that matters)


8 hours ago, my_lego_router said:

this isn't broken for all keys, just the very specific one my remote uses.

To clarify, are any of the buttons/keys on the remote still working when BB is focused?  Like Select (Enter ["OK"? image.png.8c7788b3eeff6e5562fc39bfda2817c4.png]) and Back (Esc ["Back"? image.png.944432642cd7dfb2959b3928fdf16a67.png])?  Vol +/-?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...