Jump to content
LaunchBox Community Forums

Playstation was working and now isn't


Recommended Posts

Hi all.  I'm so sorry to be a pain :(


So - I always input a couple of roms to test first before importing and downloading a load more.

I tested with castlevania Symphony of the Night and a couple of others first.

I imported the Roms into Launchbox, following the instructions and importing as files rather than a folder.  I imported the .cue files.

tested (through retroarch), pointed to the BIOS and everything.  All worked.

So I downloaded the rest of the roms, deleted the platform out of launchbox and started again.  The games all show up, the metadata has downloaded and everything.  They just won't play - not even the games that worked before :(

I manually went into the retroarch system folder to make sure the BIOS was still there.  It was.  I even uploaded other region BIOS to make sure there was a match whatever region my ROMS came from.

I looked at the screenshot below and wondered if there was a clue there?  It's pointing towards one folder within the sub directory.


For context each ROM is stored in its own subfolder in a Playstation folder on my D drive.  They are.cue and .bin files.

Any help would be appreciated.


Thanks in advance.




Edited by norwichred
Link to comment
Share on other sites

Not sure if this is your issue, but try to hit CTRL+E (or right-click -> Edit Metadata) when you have one of your psx games selected, and then click "Launching" on the left side. Under ROM File, make sure it has the .cue file in the box and not the .bin file. I had this issue with a different platform so I thought it was worth suggesting.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...