Jump to content
LaunchBox Community Forums

Acorn Atom and Archimedes command line


Recommended Posts


The atom_cass softlist tapes are currently not supported. The atom_flop softlist floppies do work.

LaunchBox Associated Platforms Default Parameters
atom -flop1

Launching a game opens the Atom screen
*DOS and press Return
next type
and add the usage string (including the double quotes) as listed below and press Return

Usage strings
for the 3 games Hard Hat Harry, Hyper Viper, Jet Set Miner

Atomic Chuckie Egg
"CCHUCK" (for colour version)
"MCHUCK" (for mono version)

Atomic Joe Blade

Egghead in Space

F14 Tomcat

"CGALA" (for colour version)
"MGALA" (for mono version)


Jet Set Willy

Jet Set Willy 2

Jungle Journey

Manic Miner


If you wish you can set per-game custom parameters to automate things.
atom -ab *DOS\n*RUN"XXX"\n -autoboot_delay 1 -flop1
where "XXX" is the game's usage string as listed above.

Link to comment
Share on other sites

Thank you I tried on 2 games and it works perfectly you were very kind to dedicate your time to me, do you have any advice for Aamber pegasus and Acorn Archimedes?

So some site where you can find the command lines of the various systems? Thank you again I wish you a good day

Link to comment
Share on other sites

I never tried MAME for the Archimedes, but I believe that it currently may not work.

For the Aamber Pegasus pegasus_cart softlist.
LaunchBox Default Command Line Parameters
pegasus -rom1

Launching a game gives you the option of playing the game (or accessing the monitor via key M).
To play the game press the key corresponding to the first letter of the game title.
to play Invaders, press I.

For help on command line parameters try Arcade Italia or Progetto Emma's Project MESS.
There may be other help online or here on the forums.

Link to comment
Share on other sites

F14 starts ok for me without any error.
However, the game freezes after a few seconds of gameplay.
The time until it locks up varies between levels.
I've heard that it plays ok on Atomulator, although I've not used that emulator

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...