Jump to content
LaunchBox Community Forums

OpenGL screen tearing


We1Dont7Die
 Share

Recommended Posts

So basically i get screen tearing when using OpenGL in Retroarch. Using d3d12 all of my emulators work fine, even my gsync works. Retroarch cores which require OpenGL have been eliminated from my system due to there being d3d compatible alternatives. The only reason this is an issue is because there arent any alternate cores for Dreamcast which don't use OpenGL, so I'm stuck with the tearing for that core. 

Has anyone experienced this?  

 

 

 

Windows 10 64

gtx980

i7-6700k

Link to comment
Share on other sites

Thanks for the reply :)

 

I just did some testing and enabled the G-Sync overlay in the Nvidia Control panel.

With d3d12 selected as Video Driver I see the familiar G-sync overlay as shown here in Retroarch

IMG_0456.thumb.jpg.5e5f915e26db6f42bfa0f3fb9b8c4326.jpgand here in gameIMG_0457.thumb.jpg.8a84ea08016031583944fafc4663f75f.jpg

When i use gl as the Video driver, there is a different looking overlay

IMG_0455.thumb.jpg.41fad65e72edb66c0fb90652c8d8e582.jpgand here in game

IMG_0454.thumb.jpg.59e9710ad164142baf7aaf3057cd4928.jpgAnd I can assure you that even though it shows G sync is on with gl mode, I am getting an incredible amount of tearing while d3d12 looks amazing. 

 

Do I need to do something with my drivers? 

Is there anything I should look for settings wise? Nothing weird about my setup...just a very clean win 10 install. I don't really fiddle with graphics settings.  LaunchBox is set to use gl by default and I had to change that almost immediately because of the tearing.

Link to comment
Share on other sites

Where you do enable that overlay in the control panel ? I can't seem to find it and I don't ever see that overlay. Is this something that is a part of the GeForce Experience software ? If it is I have never seen it in there and I don't even have it installed currently because it was causing other issues recently.

In Retroarch I make some settings adjustments and set my monitor to 144 Hz.

Make sure Audio Sync is On in the audio settings.
In the retroarch.cfg file look for 2 settings:
audio_rate_control = "true" and set it to "false"
video_refresh_rate = "59.xxx" and set this to match the Hz that your monitor runs at, for me this was "144"

 

2018-03-19 18_45_43-NVIDIA Control Panel.png

Link to comment
Share on other sites

You must select Set up G-sync (like I see you have there) then go to the top menu and select "Display" then you will see "g sync indicator"

It's hidden pretty well

 

I thought that retroarch's frequency settings could be a culprit but i didn't mess with the setting in the frontend because it just seemed odd having to adjust by such small increments. But you're saying do it in the cfg instead....I'll give that a try. I run 144hz as well

Edited by We1Dont7Die
Link to comment
Share on other sites

Fixed! Just changed the frequency setting in the cfg to 140 (ive read for gsync its best to cap 4-5 frames down so it doesn't go out of range) Thanks!

Now that I think about it, I had to disable Gsync  and set to fixed refresh in Nvidia Control panel for Starcraft 2 because that game is capped at 60fps and it wreaks havok with gsync

I also had to disable Gsync and set fixed refresh for BigBox mode because of the weird stuttering transitions.

Seems to be down to the way gsync enables and disables when fluttering around the 60fps range. My monitor has gsync range of 30-144hz so why there are problems around the 60 fps range is a battle for another day

 

Gsync is great but it isnt perfect

Edited by We1Dont7Die
Link to comment
Share on other sites

I'm no expert on G-Sync and trying to find information especially when it comes emulation can be more than a bit tricky.

I don't think setting it to 140 for emulation is going to matter since emulation is generally around 60 fps.

You can set profiles on a per game basis to disable it for the games that have troubles with it.

In BigBox you can set your refresh to match your display so that should help that out.

I really don't see any issues when running around 60 fps at all.

Link to comment
Share on other sites

there are some topics about fps needing to be capped a few below your refresh rate due to how  Gsync works

https://www.reddit.com/r/GlobalOffensive/comments/5iv35q/how_to_use_gsync_properly_in_csgo/

 

https://forums.geforce.com/default/topic/1016291/g-sync-refresh-rate/

Basically when youre getting 300 fps for example, which is easy to achieve in CS, if you set your cap to 144 it may sometimes fluctuate above 144 turning off gsync for a split second. capping below ensures gsync is always on.

 

I'll look for the big box setting

Edited by We1Dont7Die
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...