Jump to content
LaunchBox Community Forums

RetroArch Black Screen in OpenGL since latest release


Recommended Posts

Hi there,

I just upgraded my RetroArch install from 1.7.1 to 1.7.3 by decompressing redist.7z and _RetroArch.7z onto my existing folder. My config file was therefore untouched. 

Since then and while it worked fine just before the update, and even running RetroArch from the .exe directly, will only provide me with a black screen. If I open an actual ROM, emulation is running as I can hear the sound including menu sounds on input, only the video is missing.

My retroarch.cfg contains the following (hopefully relevant) info:


video_driver = "gl"

video_shader_enable = "true"

video_shader = "nul"


If I switch the video_driver to d3d, it works. If I leave it to gl, but set video_shader_enable to false, it works as well. So I do have workarounds as I never really played with shaders so far.

The interesting bit of info I believe is if I run the debug exe with --menu --verbose, I find this error in the log:


[INFO] [GL]: Using resolution 2560x1080
[INFO] [GL]: Default shader backend found: glsl.
[ERROR] [GL]: Not loading any shader, or couldn't find valid shader backend. Continuing without shaders.

Looks like something is wrong or corrupted with the default glsl shader? Or simply, a bug?

When it works if I set video_shader_enable to false, here is what I get at the same location:

[INFO] [GL]: Using resolution 2560x1080
[INFO] [GL]: Default shader backend found: glsl.
[INFO] [Shader driver]: Using GLSL shader backend.


Anybody has a clue what is happening? 

For reference I am on Windows 10 64bits, running RA 64bits, NVidia GTX 980 Ti with latest drivers 398.36.


Edit: added full log. No other error in there..






Edited by boohyaka
log added
Link to comment
Share on other sites

Thanks for the answer - I wish I could, I created a new account but apparently I'm not allowed to post. I followed the bot 'new user tutorial' but still no obvious 'create topic' button. Nothing in the FAQ. By searching I found a topic where someone mentioned you need 5 posts to be allowed to create your own, is that correct? Thank you for confirming if you can otherwise I'll just look around some more. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...