Jump to content
LaunchBox Community Forums

Mame or MAMEUI not working. Need help!


Recommended Posts

Ok. I have a good fullset of roms.  I launch mameui. Everything is great so far.  I pointed to the rom directory and audited that folder. Most everything is green and available.  When I double click to play..... nothing.   I ran sfc /snannow and everything was great.  I did receive the "Unable to create Direct3d device (8876086C)" and "Unable to initialize Direct3d 9". 

Fatal error: Unable to complete windows creation.

On my Windows 10 machine, all graphic drivers are up to date for my Zotac 980ti Amp! Extreme.  No updates are needed for my Windows 10 also.  

This is stopping me from creating my arcade system. 

Mame64.  I created .ini file by creating shortcut.  I set rompath to the desired location.  NOTHING.  When I double click mame64.exe, isn't there supposed to a GUI that shows?  When I double click it, a window pops up for a second and closes.....nothing else.


Please help!

Link to comment
Share on other sites

  • 11 months later...

sad to see no resolution on this, even a year later...

i'm running into the same wall thought i'm on an amd setup using a Ryzen 3 3200g (APU)

However, like @kalimah, I have ran the dxwebsetup and allegedly am up to date.

I had found that using this command line does open mame :   mame64 -window   but trying fullscreen (nowindow) would fail with the direct3d errors described in prior posts

so,  while writing this i tried a couple of things and apparently now have it working, or at least working better:

1.  open command line, windows start button, then CMD, and use type "CD" + "your directory path to mame"  to change directory  (sorry i'm typing all this out but some newbies are unfamiliar)

2. in the command line, once your in the mame directory (ie c:\users\you\launchbox\emulators\mame or whatever yours is) then enter "mame64 -window"   and hopefully that at least starts up mame for you.

3. Use your mouse to open up "Configure Options" then "Video Options" and change your Video mode from Auto to "opengl"  - i didnt play around with any other settings but of course you can. Hit Return to previous menu and Save Configuration. then you can Esc to exit.

4. In launchbox try it again. After doing the above, i've at least got Mame coming up and loading a game.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...