Jump to content
LaunchBox Community Forums

LaunchBox/Retorarch launching Mega CD game


Recommended Posts


first off, sorry for my bad english, I'm not English speaker.

Ok, I'm trying to mount some game station for my own personal purposes, with emus, scummvm, dosbox... and I'm playing a bit with Launchbox.

I'm mounting Retroarch as console emulator (for a bunch of consoles) under Launchbox. I'm using Retroarch v1.7.5 and Launchbox v8.9.

I've configured Atari Jaguar on Launchbox (and Retroarch) and can launch the game perfectly. Hidding console, having art, etc... All flawlessly.

But I'm traying also to launch Robo Aleste for Mega CD (yes Mega CD, not the SEGA CD version, but it should not matter, I think). I have it uncompressed, with one .cue, one .bin and some .wav files. Launching it from Retroarch it works perfect. But I configured it in Launchbox and the console (activating Register option in Retrolaunch), opens and closes very fast. So, I assumed that the problem has something to do with the core in Retroarch or how Launchbox is calling the core.

Using deafult options it has not worked for me. BUT I can run it if I add this to the command line in the Edit menu OF THE GAME. I used this parameter on the Emulator/Core section (if not I will need to edit each game), and I can not make it work. Is it normal?


Edited by L@Zar0
Link to comment
Share on other sites

Your command line is wrong it should be:

-L "cores\genesis_plus_gx_libretro.dll"

You are missing the quotes around the core.

Is there a reason you are using a custom command line for this specific game instead of that core for the platform in the associated platforms of your Retroarch emulator entry in LB ?

Link to comment
Share on other sites

I know that I have not explained well.

First, it works as it is, without quotes. Why? Because there are no spaces.

As I tried to explain, If I use this parameter [-L cores\genesis_plus_gx_libretto.dll] specifically for this game, IT WORKS. If I use this parameter in the options for the core Genesis Plus GX of Retroarch (and delete the parameter for this game specifically) IT DOES NOT WORK (with and without quotes, I tested both). But I don't understand why. I thought that I did not need any parameters, or if I used this parameter, it should work. The Atari launcher works well without parameters.

Using DOS command line works perfect using

.\retroarch.exe -L cores\genesis_plus_gx_libretro.dll "..\Roms\Robo Aleste.cue"


Edited by L@Zar0
Link to comment
Share on other sites

Let's make it simple:





THIS DOES NOT WORK (If I use quotes the line is deleted after launching game, accepting and opening again Emulator Edit):



I know that this is very odd, but it's what is happening to me... :(

Thanks for the help you're giving me. I think that Launchbox is awesome!

Link to comment
Share on other sites

The one THAT DOES NOT WORK you do not need the commandline there, that is what the core column is already doing, you are loading the core twice.

Just change it so it looks like the screen i posted and it will work. Also your platform name and the name in the associated platform do not match.

Platform = Sega Mega CD, Associated Platform = Sega CD they HAVE to match.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...