Jump to content
LaunchBox Community Forums

Retroarch P2 always Ipac and not xbox pad


Recommended Posts

Hi All - I am a little up against it to fix this problem so wondering if anyone would be so kind to have a look.

On N64, with 2 xbox pads plugged in, Player 1 pad works fine... Player 2 for some reason is controlled by my arcade control panels player 2 side.

I start a game, open up retro arch, go into the main settings > Input > and down to User 2 Binds. Within here the problem is as shown in my attached pics, set to Ipac. I change this to say "Xbox ONE controller (User 2)" then resume the game and pad 2 works perfect.

Problem is when i quit and go back in, its back to the ipac being player 2 again so i need to repeat above each time. This happens on both N64 and Playstation 1, exact same thing.

I noticed that if i go into Quick Manu > Controller  - All User 1 is set to Xbox ONE controller user 1 - however if i scroll down the list of inputs and get to User 2 it shows Ipac.. I cannot change this. hope my pics make sense.

As mentioned if anyone has any help fairly quickly that would be much appreciated as i have until tuesday evening to fix this :(. I'll paypal someone a beer if they can help!!

Thanks

---

These 3 pics shows me going into INPUT > and changing user 2 binds from IPAC to XBOX pad user 2

InkedIMG_20210222_121558_resized_20210222_122040851_LI.thumb.jpg.cbbdcfe3a966307eae572d93fd1e2753.jpgInkedIMG_20210222_121610_resized_20210222_122040551_LI.thumb.jpg.c12b1b19a9a09300a0ed0f16a7cfafee.jpgInkedIMG_20210222_121618_resized_20210222_122040246_LI.thumb.jpg.30ead7e07ea15a9fa72d2c917c3badbc.jpg

These 2 pics show when i am in the quick menu > Controls > Scroll down to where User 1 ends and User 2 begins - Note it goes from Xbox controller, to Ipac!

IMG_20210222_121310_resized_20210222_122041489_LI.thumb.jpg.6b1e93dd63fa27b252fdc9559c6306af.jpgIMG_20210222_121315_resized_20210222_122041164_LI.thumb.jpg.b5bf57de4bc48f083003c515764b157d.jpg

Thanks again

Link to post
Share on other sites

Try this and see if it helps.

After you go into Main Settings>Input and change it to your second Xbox controller, go to Main Menu>Configuration File and click Save Current Configuration.

quit out of RA, open it up again and see if it's kept the controller as Xbox

Link to post
Share on other sites

How do i view it the way you do? Mine looks like a Playstation 3/4 home screen with a wavey ribbon... i say that because when i "save current config" nothing pops up to say i have.. I always make myself hit the buttons hard so i know ive defo hit it

Edited by floodie
Link to post
Share on other sites
1 minute ago, floodie said:

How do i view it the way you do? Mine looks like a Playstation 3/4 home screen with a wavey ribbon...

Then you are using a old version of Retroarch as the view above is now the default. You can change it in Settings/Drivers/Menu, it's called ozone.

Link to post
Share on other sites

I change it to ozone, come out, go back in and it xmb view appears again. Just like how Ipac stays as default upon restart. How do i view the Ozone view?

Its as if a configuration file is read only or something

Link to post
Share on other sites

So - it didnt give me a pop up when saving. Found notifications and switched them to ON, but how do i apply that setting? i quit, and went back in but notifications were again set to off.  I am assuming it saves config to my Retroarch.cfg Iain

Edited by floodie
Link to post
Share on other sites

I would always recommend leaving that option off, so that you dont mess something up and it automatically saves. Simply go to Configuration, in the first menu and "save current configuration" whenever you want to save.

Link to post
Share on other sites
Just now, neil9000 said:

I would always recommend lkeaving that option off, so that you dont mess something up and it automatically saves

Good point, didn't think of that lol

Link to post
Share on other sites

Just checked and it was OFF.. funnily i tried to change it to ON but i dont know how to apply that setting. Whenever i went back in it stayed OFF. Found it in the RA.CFG forced it to ON, tried to change from IPAC > XBOX user 2... Restarted and it was back to Ipac again for Player 2.

Looking through this vast RA.cfg file surely its in there somewhere as that is the only place i can get things to stick

Link to post
Share on other sites
6 minutes ago, floodie said:

Config folder is read only

Yeah, thats why changes aren't being saved, uncheck the read only and apply.

As Neil says it's best to leave the auto save option off, so whenever you want to save any changes you've made go to Main Menu>Configurations and save current configuration before quiting out of Retroarch.

Edited by IainSA
Link to post
Share on other sites

I will do that in a sec, just having a bite to eat.

I think last year i thought i was being clever making it read only so no one, even if they accidently got into the RA menu they couldnt mess it up. Funny if thats what happened and its caused all this! :)

So, to make things clear, when i change something in retro arch i always "save config" - thats the way to apply and save settings before exiting? (When save on exit if set to OFF)

Link to post
Share on other sites

unchecked read only - it did its thing.. Tried and it wouldnt work. I checked to see if the config folder was now not read only and it still was read only. In fact my entire system is read only, every single folder on the c : drive?!... Looks like i have a bigger windows 10 problem here. Damn it

Link to post
Share on other sites

Yeah, sounds like you don't have full Administrative control.

go to C:/Users and right click the folder with your name and then the security tab at the top and see if it has Full Control ticked.

 

23411673_fullaccess.thumb.jpg.1e214a4139abebdc0108a0bcd0b4d849.jpg

Edited by IainSA
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...