Jump to content
LaunchBox Community Forums

Exit button doesn't exit in pause menu


G22
 Share

Recommended Posts

Hi, I've only tried with Mame games but when I go in the BigBox pause menu where I can resume, view artwork, etc. When I press Exit game, I get the game over screen but it goes back to the Mame game and it can't be exited unless I press the button I've map in Mame.

Any ideas? Thanks!

Link to comment
Share on other sites

Just now, G22 said:

Hi, I've only tried with Mame games but when I go in the BigBox pause menu where I can resume, view artwork, etc. When I press Exit game, I get the game over screen but it goes back to the Mame game and it can't be exited unless I press the button I've map in Mame.

Any ideas? Thanks!

If you have changed what the exit is in mame then you need to also change it in Launchbox. Launchbox will be sending the default of Escape, so if you changed it to something else that is your issue.

Link to comment
Share on other sites

21 minutes ago, neil9000 said:

If you have changed what the exit is in mame then you need to also change it in Launchbox. Launchbox will be sending the default of Escape, so if you changed it to something else that is your issue.

Oh that makes sense! Any idea where in BigBox I change that key?

Link to comment
Share on other sites

2 minutes ago, G22 said:

Oh that makes sense! Any idea where in BigBox I change that key?

You need to add a script in Launchbox, Manage Emultors/Mame/Exit Autohotkey Script tab. As for the actual script i dont know, but it should be easily enough to google.

image.thumb.png.4cbeeb86dad8d3fb66ef633f84dadb46.png

Link to comment
Share on other sites

15 hours ago, Koroth said:

Try the following:

Go to LaunchBox > Tools > Manage Emulators > MAME > Exit AutoHotKey Script tab and enter:


WinClose, ahk_exe mame64.exe

 

Thanks you this is working directly!

Link to comment
Share on other sites

  • 1 year later...
On 5/4/2021 at 5:11 AM, Your Friendly A.I Overlord said:

Try the following:

Go to LaunchBox > Tools > Manage Emulators > MAME > Exit AutoHotKey Script tab and enter:

WinClose, ahk_exe mame64.exe

 

how can i do this with a windows game? to be exact it's Haunted Museum 2, it's a windows arcade game that doesn't have the EXIT option. I am aware that I can use a script that sends ALTF4 input but as I made a nice pause screen with the commands and it works, it makes me visualize the gun controls, I would like to use the EXIT pause option from launchbox pause screen. How to do? Single games do not have the lb EXIT section, I could insert some scripts in the lb PAUSE section of the game but which script should activate when pressing the last EXIT GAME option of launchbox?

Edited by Sbaby
Link to comment
Share on other sites

11 hours ago, Sbaby said:

I would like to use the EXIT pause option from launchbox pause screen. How to do? Single games do not have the lb EXIT section, I could insert some scripts in the lb PAUSE section of the game but which script should activate when pressing the last EXIT GAME option of launchbox?

If you just want to close the game with your controller or Escape you could add a script as an additional app to your game. But if you absolutely want close the game via the LaunchBox pause menu I can only come up with sort of a work around. Right click your game > Startup/Pause > tick "Override Default Pause Screen Settings" > Click "Customize" > Tick "Enable Game Pause Screen". As you said, there is no "Exit Game" section. But you can put an exit script under the "Reset Game" tab. So, this is more of a work around because for exiting your game you have to select "Reset Game" from the pause menu. NOT "Exit Game".

1781625066_Schermopname(114).thumb.jpg.296cd660a86833bd9cd356e522a56b34.jpg

911127803_Schermopname(115).thumb.jpg.2d3108db36a1ef204f0c63700983733b.jpg

Edited by Your Friendly A.I Overlord
Link to comment
Share on other sites

thanks but if in a year I play that game again how do I remember that the reset corresponds to the exit? I don't understand why this feature is not enabled for windows games. I understand that 90% of them have the option to exit within the game but there should be the choice of being able to enter it

Link to comment
Share on other sites

1 hour ago, Your Friendly A.I Overlord said:

Yes, but why do you insist in closing the game via the pause menu. It's much faster (and easier) to close the game with Escape. (Or a controller button combination.)

Because I make children play and things must be simple and above all they must not be hidden

Furthermore, children often make key combinations without realizing it and press the exit, while in this way there would be an extra step and it would be better

I already have the key combination set up but I'd like that too because it's there for all the other games and I'm used to it now and every time the kids ask me "why doesn't it work?" "Why does the other game work instead?" 😁

And then too many things have to be remembered

Link to comment
Share on other sites

I could configure a fake emulator with autohotkey but then how can I tell the exit to close all those ahk windows arcade games that I add to that emulator?

maybe Send !{f4} would be enough ???

I have to try

 

EDIT :

I tried ! works ! I solved 🥳

Edited by Sbaby
Link to comment
Share on other sites

21 minutes ago, Sbaby said:

I could configure a fake emulator with autohotkey but then how can I tell the exit to close all those ahk windows arcade games that I add to that emulator?

I do this for all my Windows game. In LaunchBox I have added AutoHotKey.exe as the emulator. I start all my Windows games from autohotkey scripts. So I added those scripts as the roms to my Windows platform. But for you there might be a simpler solution. You could add the game itself as the emulator. I tested this with Quake II RTX.

1460858420_Schermopname(116).thumb.jpg.89590cab2c1652946275870f499acc80.jpg

Create an emulator and add the path to the games' executable. Check "Remove File Extension and Folder Path".

1814093834_Schermopname(120).thumb.jpg.78f815c2ece9d305021207a03c175f1e.jpg

In the "Pause Screen" tab I checked all 3 options. This seems to work for Quake II RTX as the Pause Menu shows up.

252403532_Schermopname(117).thumb.jpg.5a2c74e030b7e3ed4a2b51cd0c20302f.jpg

In the "Exit Script" tab add an exit script for your game so you can exit the game from the pause menu. In my case I used:

WinClose, ahk_exe q2rtx.exe

1903954102_Schermopname(118).thumb.jpg.9785b8f46411b7550fca9378cf18c382.jpg

Right click your game and go to the "Emulation" tab. Tick "Use an emulator to play this game" and select the emulator you just created. In my case Quake II.

313175499_Schermopname(119).thumb.jpg.ac552bf26db08f5ab6530c3af1ba55ae.jpg

Go to the "Launching" tab. I have enter a random letter here because you do not really want to launch a rom. This will only launch the chosen emulator as the emulator = the game.

I tested this briefly but it seems to work.

Link to comment
Share on other sites

1 hour ago, Your Friendly A.I Overlord said:

I do this for all my Windows game. In LaunchBox I have added AutoHotKey.exe as the emulator. I start all my Windows games from autohotkey scripts. So I added those scripts as the roms to my Windows platform. But for you there might be a simpler solution. You could add the game itself as the emulator. I tested this with Quake II RTX.

1460858420_Schermopname(116).thumb.jpg.89590cab2c1652946275870f499acc80.jpg

Create an emulator and add the path to the games' executable. Check "Remove File Extension and Folder Path".

1814093834_Schermopname(120).thumb.jpg.78f815c2ece9d305021207a03c175f1e.jpg

In the "Pause Screen" tab I checked all 3 options. This seems to work for Quake II RTX as the Pause Menu shows up.

252403532_Schermopname(117).thumb.jpg.5a2c74e030b7e3ed4a2b51cd0c20302f.jpg

In the "Exit Script" tab add an exit script for your game so you can exit the game from the pause menu. In my case I used:

WinClose, ahk_exe q2rtx.exe

1903954102_Schermopname(118).thumb.jpg.9785b8f46411b7550fca9378cf18c382.jpg

Right click your game and go to the "Emulation" tab. Tick "Use an emulator to play this game" and select the emulator you just created. In my case Quake II.

313175499_Schermopname(119).thumb.jpg.ac552bf26db08f5ab6530c3af1ba55ae.jpg

Go to the "Launching" tab. I have enter a random letter here because you do not really want to launch a rom. This will only launch the chosen emulator as the emulator = the game.

I tested this briefly but it seems to work.

Good idea ! 

I will keep both choices in mind every time I add arcade pc games
👍

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...