Jump to content
LaunchBox Community Forums

Updated RetroArch, no games launching anymore.


Recommended Posts

Hey. I tried updating RetroArch, but now none of the games work anymore. I copied over my saves, states, system files and config to make sure it was the same. All cores has been downloaded, no missing cores. I experienced 2 different behaviors when trying to launch games:


1) It just opened RetroArch, but didn't load core / game. 
2) It just closed right away, nothing launched. 

I updated from RetroArch 1.9.0 to 1.9.5. I had similar behavior when trying to update to 1.9.3, which was last time I tried to update. All previous updates of RA has previously worked fine until this point. 

Link to comment
Share on other sites

Just now, OdinsPlayground said:

Hey. I tried updating RetroArch, but now none of the games work anymore. I copied over my saves, states, system files and config to make sure it was the same. All cores has been downloaded, no missing cores. I experienced 2 different behaviors when trying to launch games:


1) It just opened RetroArch, but didn't load core / game. 
2) It just closed right away, nothing launched. 

I updated from RetroArch 1.9.0 to 1.9.5. I had similar behavior when trying to update to 1.9.3, which was last time I tried to update. All previous updates of RA has previously worked fine until this point. 

Did you point Launchbox to the new emulator .exe location?

Link to comment
Share on other sites

2 minutes ago, OdinsPlayground said:

Yep. I used same folder name (renamed previous folder to "RetroArch OLD" as a backup). 

Yeah im just looking myself, i updated to 1.9.5 and it opens by itself, but not from Launchbox. Retroarch have changed things that looks like it has broken it's use with frontends. There is info in there update blog, the stuff relating to API and fullpath is my guess as to whats changed.

Blog – Libretro

 

Link to comment
Share on other sites

Posted (edited)
5 minutes ago, neil9000 said:

We are investigating though, but this is a Retroarch change so it may or may not be easy.

Thats good. So I did try downgrading to 1.9.4, and initially had the same behavior. Then I noticed the "No space before ROM" box was ticked off. Turning this off made 1.9.4 work fine! This box has clearly been ticked off for several years for me and worked fine in RA 1.9.0 and below. Now I didn't get the chance to check if this would change anything for 1.9.5. But I'm gonna assume there is some other faulty thing going on there if you couldn't get this to run while having that unchecked. 

Edited by OdinsPlayground
Link to comment
Share on other sites

Retroarch is not getting the rompath any more, this is why no games are loading, this below is the error Retroarch gives.

[INFO] RetroArch 1.9.5 (Git 6738fa5)
[INFO] === Build =======================================
[INFO] CPU Model Name: AMD Ryzen 7 3700X 8-Core Processor             
[INFO] Capabilities:  MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4 SSE4.2 AES AVX AVX2
[INFO] Built: Jun 13 2021
[INFO] Version: 1.9.5
[INFO] Git: 6738fa5
[INFO] =================================================
[INFO] [Input]: Found input driver: "dinput".
[ERROR] [Core]: Frontend is built for dynamic libretro cores, but path is not set. Cannot continue.
[ERROR] Fatal error received in: "init_libretro_symbols()"
[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] [Core]: Unloading core symbols..
[INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

This is the important part "[ERROR] [Core]: Frontend is built for dynamic libretro cores, but path is not set. Cannot continue."

As i say we are looking into it though.

  • Like 1
Link to comment
Share on other sites

OK i did the same as you, i copied the new .exe to the old folder, and nothing works. However i pointed Launchbox to the 1.9.5 in my downloads folder which was completely clean and copied one core from my normal instal, and the game loaded right up. So it actually looks like the act of updating a older version is actually the issue as a completely clean 1.9.5 works as expected.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...