Jump to content
LaunchBox Community Forums

Problem Installing Launchbox on my new PC


Recommended Posts


So I'm having an issue trying to Install Launchbox on my new Gaming PC. I've downloaded the full copy before on my old PC years ago, and it worked pretty well for the most part. I'm trying to install it on my new PC (Windows 11) and every time I try and run the start up program, I get a pop up that says "Search for App in the Store? You need to install an app for this task. Would you like to search for one in the store?".  When I click yes, it sends me to a blank page on the app store that fails to load.
Is there anything I can do, to fix this?

Link to comment
Share on other sites

33 minutes ago, Depress_Mode said:

I redid the process: Went to the website, made sure it was windows, put in my email, downloaded the installer. Tried opening it and I got a "windows dialog (Not Responding)...

It sounds like maybe the browser that you're using to download (or the email client) isn't downloading the file correctly, and giving it the wrong extension. Can you try using a different browser to download it? What email client or browser are you using to download the file?

Link to comment
Share on other sites

Just now, Depress_Mode said:

I'm using Gmail on google chrome. 

That's about the most standard way of doing it, so I don't understand what could be going wrong. We get hundreds of people downloading it every day, so it's really strange that you're running into issues.

What is the name of the file that you downloaded? Do you know how to check the file size?

Link to comment
Share on other sites

1 minute ago, Depress_Mode said:

File name: LaunchBox-12.12-setup 
Type of File: Application (.exe)
Description: LaunchBox setup
File size: 266MB

Okay, all of those things look correct. So it does appear to be downloading properly. If double-clicking the setup file isn't working, then there's something really strange going on with the Windows installation. Is your computer perhaps managed by a company or organization, or is it your personal computer?

Link to comment
Share on other sites

I'll be honest ,I'm not even sure. I just right clicked it and went down the line until something worked. I switched my firewall off to make sure, and ran the program as an administrator I think.  That wasn't working, so I clicked something and it had it pop open in a Windows 8 compatibility mode, and somehow that worked? 

I'm just thankful it works, and can't wait to try out some games with the new hardware spec.

  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...