Jump to content
LaunchBox Community Forums
BuckoA51

Help me get ePSXe working please?

Recommended Posts

Hi everyone, I'm having a little trouble with ePSXe in Launchbox. First of all, the default configuration doesn't work for me. ePSXe.exe -nogui -slowboot "File" uses ePSXe's in-built disc image handling which is kinda flaky, and results in a black screen or a game with CD audio not working. Instead, I've reconfigured the emulator to use Daemon tools to mount the image thus:- DTAgent.exe -mount scsi, 0, "File" and added the actual ePSXe as a additional app that runs after the main emulator. This works well and all my games boot and they have CD audio. what I can't figure out for the life of me is how to add this additional app in bulk. It's very tedious to have to go into every single PS1 game and add it manually, is there a better way? Thanks!

Share this post


Link to post
Share on other sites
Which version of ePSXe are you using ? On my laptop I use the 2.0 version and the "Default Command-Line Parameters" just has -nogui -slooboot -loadbin I notice in your post you don't have the -loadbin, no idea if that is causing your issue. I don't think I had to change anything within ePSXe itself. Edit: Are you loading the bin or cue ? Mine is setup to load the cue.

Share this post


Link to post
Share on other sites
My games are in bin/cue format. I'm using 1.90 at the moment. I'm not having any difficulties getting ePSXe itself to work as long as I use it with Daemon tools, I just need to know how to add the additional app to all my games as per my original post.

Share this post


Link to post
Share on other sites
I don't think there is a way to add the additional app to all the games in one go around unfortunately :( I had to do that for my Saturn games. Have you tried the new version of ePSXe ? It really is a huge improvement over the 1.x versions. It seems to handle loading and unloading much cleaner as well as running better.

Share this post


Link to post
Share on other sites
Ah shame :( Maybe something like Rocket Launcher can do this then.. though it's very confusing to set up. I'll try 2.0 too, thanks.

Share this post


Link to post
Share on other sites
Version 2 really is nice and was a huge improvement in every way. 1.9 ran like crap on my laptop to the point I couldn't use it. Version 2 runs faster, I can actually use shaders with it and it handles loading and closing out through a front end better. I remember kicking out of 1.9 with a front end being an awkward mess. V2 was a huge improvement in emulation quality as well, it put it slightly ahead of Retroarchs Mednafen core ever so slightly.

Share this post


Link to post
Share on other sites
Yea that's strange, it should be working just fine. Default command lines loading cue sheets in the latest build. I don't use it normally but I tested it when the new version came out. I would also suggest trying RetroArch as well, I covered PS1 in RetroArch on our tutorials which you can get to from the link in my signature below all my posts. It is an alternative though. ePSXe from my experience isn't flaky, if all you get is a black screen either the BIOS could be bad or the image could be corrupted.

Share this post


Link to post
Share on other sites
The latest version definitely works, with both cue and ccd files. I have all my images 7zipped, so even in that form, the games load normally. By the way, does LaunchBox, after extracting the 7zip, chooses cue/ccd files over bin/iso files? I was worried at first the emulators would open the iso file, instead of the cue or ccd ones, but that never has been the case.

Share this post


Link to post
Share on other sites
Yea cue sheets are preferred, I don't know if he set it for ccd's but there was a bug where cue sheets would sometimes not get loaded.

Share this post


Link to post
Share on other sites
Good to know. I would worry and try other means to see which file was loaded, until I checked a handful of games and it was cue for all, so I just imagined LB loves us and takes care of us. It was ccd too when I used a specific image of a game I ripped and I could not make it work when ripped it in cue-bin format (probably because it has a sub). Although I only tested that one game, so I do not know in general.

Share this post


Link to post
Share on other sites
Can confirm my images are not bad (can't be, they work when I use Daemon tools) and BIOS I'm using the same each time. Switching to latest build... ah, that works! Now I have music in Wipe3out without having to mount the image in Daemon Tools :) Still, I think bulk editing of additional apps would be welcome, so I've requested it as a feature. Thanks everyone.

Share this post


Link to post
Share on other sites
It could be, but very basic. Generally Additional Apps doesn't always go that easily for some systems, sometimes it needs to be very specific in which case Additional Apps wont work, which is why I believe it hasn't been done yet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...