Jump to content
LaunchBox Community Forums

Added first platform ok but now stuck


Recommended Posts

Hi everyone,

I'm new here and have downloaded launchbox and installed RetroArch, I went ahead and added Atari 2600 as my first platform 

I added my roms and it went off and got the box art etc and it all worked fine , every game I tried played brilliantly :) 

I then went ahead and added the Atari 5200 as my next platform, again I added the roms but I cannot get the games to play , I click on the game and nothing happens, I then tried the 7800 and that does the same 

I will say although I cannot remember which system it was but either the 5200 or 7800 when a game was clicked I think I could here the game start ( I could here game music ) 

can anyone tell me what I might be doing wrong ? 



Link to comment
Share on other sites

Atari 5200 is much trickier, and the MESS core in RetroArch is outdated and much more confusing. MESS was integrated in to MAME, and even then picking the MESS stuff in RetroArch takes more steps than it needs. Regular MAME is best, but you'll also need BIOS, which will require finding them online or to just grab a MAME split or non-merged rom pack. So with that said, it was most likely the 7800 you had working, because the 5200 takes many more steps and RetroArch is not the recommended emulator when it comes to anything MESS related. It does work, but much more complicated.

That said, can you launch the games just fine outside of LaunchBox? Are your 7800 games launching normally otherwise.

Link to comment
Share on other sites

Hi , thank you so much for your reply

I have just been looking at some videos about MESS , and yes as you say it does look quite tricky to set up

My 7800 games run via Retroarch outside of Launchbox no problem , its when I try to play them through Launchbox I get the problem of I can her the game but not see it , I just get the normal screen showing all the games including the one I have selected 

Link to comment
Share on other sites

That seems very... odd. I don't know if it's a setting or an error with RetroArch. If you can show a screenshot of your RetroArch emulator screen in LaunchBox, the first page and the associated platforms page where Atari 7800 is, I would appreciate it.

Also, MESS (MAME), isn't too bad. It's very similar to RetroArch actually, but combined it's more confusing than it should be. I did a ton of tutorials on MESS for our channel as well. I switched over to regular MAME (near the end of my MESS tutorials) than a standalone version of MESS because it reduced the amount of steps, but they are still good if you need more help.



Link to comment
Share on other sites

Not quite sure what you mean , I thought I have added the platform and games to Launchbox ?

if its too much trouble I wont bother with them and just add the ones that do work without much bother


Is there a list of all the platforms that do work with no problems with Launchbox ?

Link to comment
Share on other sites

Ok will do that , thank you 

in the mean time I have added the Sega Master System , and that is doing exactly the same as the 7800 , I click on a game and I can hear the game start but the screen does not change , I can hear the game running but cannot see it 

Link to comment
Share on other sites

Master System should work out the box I believe it will be setup to use the genesis gx plus core by default have you downloaded that core from the online updater in RA

Glad you got that working 5200 is setup on my system but I use the stand alone MAME version to run it not Retroarch

Edited by DOS76
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...