Jump to content
LaunchBox Community Forums

Cannot d/l box front image if it is the only image found


Recommended Posts

I've been trying to get images for all my games.  Some games, like Frogwares' "80 Days" for example, only lists Box front art on the Launchbox Games Database/Wikipedia/Steam tab, and nothing on EmuMovies.  When I attempt to download this one image, nothing happens.  The dialogue box closes as if it were successful, but the image is not downloaded.  So,

1) is there a setting I may be overlooking that would cause this?

2) is there an alternate way of downloading the image and populating the field manually?

3) is this a bug?

I'm running 7.10-beta-7, but this has been the case before this release.  I tried the "Download Metadata and Media" tool, and the "Refresh All images" tool with the same results.

Link to comment
Share on other sites


That's it exactly.  I've gone through all my PC games that don't have art, and have found the following culprits (below).  All of them have a database entry and exactly one media hit, for box front.  I hadn't checked the folder itself until now, but interestingly, there ARE box arts for all of these, but they are NOT visible in Launchbox! HOWEVER, I've discovered that I have TWO Launchbox folders, one on D where it is actually installed, and one on C, which contains only the Images, Manuals, and Music folders.  By the dates of the folders, the C folders seem to be more current, but the "missing" box arts are not there; they are only on D (but not downloaded recently).  I don't want any Launchbox cache on C (my SSD), and am not certain why they are going there, but it seems to be maybe a configuration issue?  I've checked LaunchBox.xml (in D:\LaunchBox) and it does not have the C path in it.  Is there another location this xml file could be stored, that is overriding the "correct" one?

80 Days


Command & Conquer: Tiberian Sun

Disciples: Sacred Lands

J.U.L.I.A.: Among the Stars

King's Quest I: Quest for the Crown (AGD Interactive)

Konung: Legends of the North

The Labyrinth of Time

Legend of Grimrock II

Lords of Xulima

Might & Magic Heroes VII

Quest for Glory II: Trial by Fire

Realms of Arkania: Star Trail

Sherlock Holmes Versus Jack the Ripper

Star Wars: Rebellion

Swords of Xeen

Link to comment
Share on other sites

The LaunchBox.xml doesn't exist anymore. If you still have that file, then it means your LaunchBox has just been around through all the updates. All of the XML information is held in the Data folder now. You can delete the LaunchBox.xml. That said, I'm gonna go ahead and tag in @Vlansix, as he may be able to shed some light on this or be able to check on it from the Database side. If a change needs to be made in LaunchBox, that's still @Jason Carr's job, but this way we might be able to solve it faster if it's just the Database.

Link to comment
Share on other sites

Hi @WTutwiler,

I'm looking through the database for game entries that match the names of the games you've put up, but I'm getting either a ton of returns or nothing for the PC platform. Can you be a bit more specific? Links to the specific games (or just a platform for each) would be awesome :).

Link to comment
Share on other sites

I just re-read your post, and I would like you to check something as well. Open up your LaunchBox install, then go to Tools -> Manage Platforms. Double check the specific platforms you're having issues with. Check the folder paths, and see where they lead. If it's a drive letter, then it will tell you exactly. If it's "../../", then it's a relative path, meaning it's using the drive from which you're launching LB from. If it's going back to your C drive, then that's fine, but unless you set it up that way I am very confused why it's going to your C drive at all.

Also, putting LaunchBox on an SSD doesn't give a real performance boost as is anyways, but not including all aspects would hurt any benefit an SSD gave.

Link to comment
Share on other sites

Ok, it looks like nearly ALL of my links in the settings are not only absolute paths, but also pointing to C!  The drive that LaunchBox is on is D, which used to be C, before I added the SSD (I don't want LaunchBox on the SSD).  So I manually changed the paths for PC platform, and moved the files that were on C to D.  I then Refreshed the Images.  Strangely, I gained some (particularly the ones I was having trouble with), and lost some (I can't see a pattern for these though).

To check the problem, however, I chose one of the problem titles listed above (Konung: Legends of the North), deleted the images, then tried to download a new one.  It still failed.  So it looks like I need to clean up my install first before anything else.

How best to proceed?  Is there a way/file I can bulk-edit to make the paths relative, or should I just reinstall?



Windows import did not detect these games, even though most of them ARE windows games, so I manually added them the only way I could figure out how: via MS-DOS import, then clearing the DOSBox check, and changing the platform to PC.  I also changed all the successful Windows imports to PC.  So, the games could be MS-DOS (Tiberian Sun, Star Wars: Rebellion), PC, or Windows.  The Metadata is there for all of these titles, but each only has one associated image, Box Front.  Hope this helps.

Link to comment
Share on other sites

I would walk you through on how to fix it, but there's no telling how bad it could be. It would probably be best to cut it off now, and just do a new install. You can carry over your media if you want, just place it in the same location. This way, not everything needs to be downloaded again and imports will go faster.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...