Jump to content
LaunchBox Community Forums
atomicknight

Launchbox will not initialize after Windows upgrade from 7 to 8.1

Recommended Posts

I have, and had, Launchbox 10.1, updated since 7.0 and registered.  It worked fine in the first installed OS of Windows 7.  Since Microsoft will be eliminating Win7 in 2020, I thought I'd upgrade to 8.1.  After upgrade, and reinstalling Launchbox, (since apps in 7 would not automatically upgrade to the 8.1 environment), the "Launchbox is initializing..." errors out after a few minutes.  It gives no error details other than it has stopped working and it will close.  After searching the forums and trying all the suggestions, it still will not initialize and simply errors out.

 

(things tried)
-uninstall Launchbox, delete any remaining remnants, reinstalling 10.1 from fresh downloaded file

-fresh installing previous (9.10) version

- Allowing install of launchbox in the default locations recommended by installation.

- Deleting CefSharp Folder

-fresh installs from microsoft downloads of Net Framework 2.0, 3.0, 3.5, 4.0, 4.5, 4.7

-fresh installs from microsoft downloads of Visual C++ 2015.  Also uninstalled and tried again.

-Turned off all UAC

-No instance of Riva Tuner or MSI Afterburner running or installed.

- No virus scanners or acceleration software running

-All drivers updated.  Windows, Nvidia, etc.

-all emulators working outside of Launchbox (not that I can even start Launchbox to configure anything right now...)

-Reinstalling windows 8.1

-Tried compatibility modes and Admin permissions

-Tried box regular Launchbox and BigBox start up (BigBox doesn't even initialize, or even error out.  It just doesn't activate anything)

- 16 GB ram and dual core proccessor with over 290GB storage free.

 

...Is there anything else i'm missing and that could be suggested?

 

Share this post


Link to post
Share on other sites

I think LB now uses .net 4.8 I didn't see that mentioned in what you installed for .Net.

Share this post


Link to post
Share on other sites

LaunchBox does use .NET 4.8, so that could be the issue here. You'll definitely need to make sure that 4.8 is installed properly in order to use the latest versions. That said, version 9.10 still uses .NET 4.7.2, so if 9.10 doesn't work, then that's probably not the issue. It could be that somehow Windows got corrupted during the update. I would make sure that all Windows updates are installed. It might be worth trying to install a fresh copy of Windows 8.1 (or better yet Windows 10), if that is a possibility.

I honestly have not done any testing on 8.1 in a very long time, as very few people are running it, but I see no reason why it wouldn't work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...