Jump to content
LaunchBox Community Forums

Launch Box crashes after exiting Big Box & switching back to Launch Box. It says the Sega Master System.xml is being used by another process. (Version 10.3)

Recommended Posts

Not sure if this is related to the 10.3 update or not, but it only started today. I can replicate the bug on 10.3 (decent chance for it to crash, but it's not 100%), but on a 10.1 backup that I have, I've yet to have the same issue.



(Inner Exception)

The process cannot access the file 'C:\Users\usernamegoeshere\LaunchBox\Data\Platforms\Sega Master System.xml' because it is being used by another process.

App:     LaunchBox
Version: 10.3
Type:    System.IO.IOException
Site:    Void WinIOError(Int32, System.String)
Source:  mscorlib

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode)
   at (DataManager , String )
   at Unbroken.LaunchBox.Windows.Data.DataManager.LoadGames(String filePath)
   at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1()
   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)
   at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object <p0>)

(Outer Exception)

One or more errors occurred.

App:     LaunchBox
Version: 10.3
Type:    System.AggregateException
Site:    Void ThrowIfExceptional(Boolean)
Source:  mscorlib

   at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
   at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
   at System.Threading.Tasks.Parallel.ForWorker[TLocal](Int32 fromInclusive, Int32 toExclusive, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Func`4 bodyWithLocal, Func`1 localInit, Action`1 localFinally)
   at System.Threading.Tasks.Parallel.ForEachWorker[TSource,TLocal](IEnumerable`1 source, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Action`3 bodyWithStateAndIndex, Func`4 bodyWithStateAndLocal, Func`5 bodyWithEverything, Func`1 localInit, Action`1 localFinally)
   at System.Threading.Tasks.Parallel.ForEach[TSource](IEnumerable`1 source, Action`1 body)
   at (DataManager , Boolean , Boolean )
   at Unbroken.LaunchBox.Windows.Data.DataManager.Load(Boolean settingsOnly, Boolean forceReloadAll)
   at Unbroken.LaunchBox.Windows.Data.DataManager..ctor(Boolean bare, Boolean settingsOnly)
   at Unbroken.LaunchBox.Windows.Desktop.App..ctor()
   at (String[] )
   at Unbroken.LaunchBox.Windows.Desktop.Program.Main(String[] args)

Recent Log:

   6:01:15 PM Exception


I haven't worked on Sega Master System stuff in a long time, but I do feel like I should mention that I spent a decent amount of time on trying to organize my Neo-Geo collection by moving some games from the Neo-Geo platform into the Arcade platform (this was for games that were released for MVS, but not the home AES system). I did this by editing the Platform from Neo Geo to Arcade. I assume there's no issue in doing that to organizing games, but it's the first time I've done it, and this is the first time I've had a crash of this nature, so I figured I'd mention it for context.

Share this post

Link to post
Share on other sites

I tried the 10.5 update today (on a back up copy I made), and after starting & exiting Big Box a few times, I thought the problem was resolved. Unfortunately, after enough attempts, I got the crash again (same issue). I'm going to avoid upgrading until whatever is causing this is fixed, or, if it's somehow a problem on my end, that I can fix it. The platform that is always causing a conflict is the Sega Master Series platform, so even though I'm not having the problem on 10.1, I'm still wondering why it's always the Sega Master System.


I'm gonna try exiting Big Box a few more times on the 10.1 version, just to rule it out. I'll update this in a few... EDIT: Tried it a bunch of times, never crashed once in 10.1, so I have to assume it was the 10.3 update that introduced the issue for me (I never used the 10.2 update, just fyi).

Edited by PurpleTentacle

Share this post

Link to post
Share on other sites

Awesome. So I am not the only one with this issue. Been happening for at least a month but i thought it was just something up with my install.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...