Jump to content
LaunchBox Community Forums

Launchbox 10.9 crash at Launch after fresh install


Recommended Posts


I had an issue with my previous HDD so I had to re-install everything from scratch. But whenever I try to launch Launchbox, it crash without ending the boot sequence with the following log:

(Inner Exception)

Impossible de charger le fichier ou l'assembly 'System.Reflection, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' ou une de ses dépendances. La définition trouvée du manifeste de l'assembly ne correspond pas à la référence de l'assembly. (Exception de HRESULT : 0x80131040)

App:     LaunchBox
Version: 10.9
Type:    System.IO.FileLoadException
Site:    Void Initialize()
Source:  Caliburn.Micro.Platform

   at Caliburn.Micro.BootstrapperBase.Initialize()
   at Unbroken.LaunchBox.Windows.Desktop.Bootstrapper..ctor()

(Outer Exception)

'L'invocation du constructeur sur le type 'Unbroken.LaunchBox.Windows.Desktop.Bootstrapper' qui correspond aux contraintes de liaison spécifiées a levé une exception.' numéro de ligne '10' et position de ligne '22'.

App:     LaunchBox
Version: 10.9
Type:    System.Windows.Markup.XamlParseException
Site:    Void RewrapException(System.Exception, System.Xaml.IXamlLineInfo, System.Uri)
Source:  PresentationFramework

   at System.Windows.Markup.XamlReader.RewrapException(Exception e, IXamlLineInfo lineInfo, Uri baseUri)
   at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
   at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
   at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
   at (App )
   at Unbroken.LaunchBox.Windows.Desktop.App.InitializeComponent()
   at (String[] )
   at Unbroken.LaunchBox.Windows.Desktop.Program.Main(String[] args)

Recent Log:

   13:28:56 Exception


I've checked .NET but everything seems to be OK.

Thank you in advance for any help you could provide me with.

Link to comment
Share on other sites

2 hours ago, Jason Carr said:

@Sebariton Sorry to hear about the trouble. This appears to be being caused by a corrupted .NET Framework install. What version of Windows are you using?


First of all thenk you for the quick reply. Then I'm running a Windows 10 64bits OS updated freshly by Microsoft patches.

I'm seeing to version of.net present on my computer:dotnet.thumb.jpg.1251e22d510a3c8c1a2a49c61d6dd062.jpg

1 hour ago, DOS76 said:


Try running this and see if it fixes it. Its the official repair tool from MS.

I've run the tool and here is what it says:


both action were taken and here is the result:

1617440046_repairtool2.thumb.png.92e556fc6ca9788dd4511068e8fdd350.pngIn the end it is still not working.

Link to comment
Share on other sites


Even admin level wasn't doing anything either, to my own knowledge you can't completely uninstall .net 4 in windows 10 but I might be wrong.

But before resigning myself to reinstall the OS I switched to windows insider program to get a newer version of the OS (slow ring) and this time it worked, I'm now fully back in Launchbox.

Anyway, thank you very much to the two of you for your help.


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...