Jump to content
LaunchBox Community Forums
Drakkorcia

Running Multiple Versions of MAME

Recommended Posts

Current versions of MAME for whatever reason have the fire sound in Centipede at a slightly higher pitch than the original cabinet and as a purist this is driving me nuts. Older versions of MAME did not have this issue so I wanted to know if anyone has used two different versions of MAME to run certain games that may have run better in an older version? I would think this would work in Launchbox if we could point a specific rom to a seperate exe, and if MAME allows for different versions to be installed at the same time.

Share this post


Link to post
Share on other sites

MAME is portable so you can have as many versions on your system as you like. Also Launchbox lets you add any emulator you like, you just cant give it the same name in Launchbox as a existing emulator entry.

Share this post


Link to post
Share on other sites

@Drakkorcia What revisions are you hearing the pitch differences in?  As recent as between 0.221 and  0.222?   If they changed something in centiped.cpp that changed the pitch (which seems odd they would), instead of having 2 completely different MAME installs, you could just have multiple copies of the compiled exe in a single MAME setup.image.png.b7165ddf0c5fc8666f26a3fa3d5f15e2.pngLike Neil said, you'll still need to setup a 'new' emulator in LB pointing to the respective exe.

However if doing it this way doesn't work to fix the pitch, may want to look inside mame.ini.  It's possible something changed in the Core Sound Options or the PortAudio Options or somewhere else.  

If it is something in the ini, create a 'centiped.ini' file with the known good settings, put it in the ini folder and use the current .exe revision.

Share this post


Link to post
Share on other sites

At least from 0.216 but I'm not sure. All I know is my A1Up 12-in-1 which is around 0.139 had the correct sound. The only bummer is the newer versions are all no nag compiled here in the 3rd party section of the forum so I'd lose that if I rolled back. Hopefully it is a sound sound setting I can tweak; that would be ideal. Thank you for the advice.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...