Jump to content
LaunchBox Community Forums

Having trouble with Retroarch


Coop1960
 Share

Recommended Posts

I have followed every video I can find and read several posts on line and I am still having trouble loading roms with the emulators I am using through retroarch. When I double click a game in launchbox, the emulator loads, music plays but the screen goes blank. Nothing I have tried will get a rom to load. I have loaded stella2014_libretro for Atari 2600, snex9x_libretro for SNES and genesis_plus_gx_libretro for Sega Genesis. None of the roms I have imported will play on those platforms. I directly loaded project64 2.3 into launchbox and my Nintendo 64 roms play just fine.

What am I missing? My OS is Windows 10 64 bit.

Any help would be appreciated.

Thanks,

Coop

Link to comment
Share on other sites

4 minutes ago, Coop1960 said:

I have followed every video I can find and read several posts on line and I am still having trouble loading roms with the emulators I am using through retroarch. When I double click a game in launchbox, the emulator loads, music plays but the screen goes blank. Nothing I have tried will get a rom to load. I have loaded stella2014_libretro for Atari 2600, snex9x_libretro for SNES and genesis_plus_gx_libretro for Sega Genesis. None of the roms I have imported will play on those platforms. I directly loaded project64 2.3 into launchbox and my Nintendo 64 roms play just fine.

What am I missing? My OS is Windows 10 64 bit.

Any help would be appreciated.

Thanks,

Coop

Black screen and sound means the games are working, you just have no video output. What GPU do you have in your system and what video driver is set to be used in Retroarch?

Link to comment
Share on other sites

1 minute ago, Coop1960 said:

I am quite the noob so it will take a little time to locate this info. I'm pretty sure my video driver in Retroarch is gl. (can that be right)? I'm looking for my graphics info now.

Yeah gl is the default and should just work out of the box most of the time, unless you have a very old system.

Do these games load if you just load them from within retroarch?

Link to comment
Share on other sites

1 hour ago, Coop1960 said:

 

 

1 hour ago, neil9000 said:

Yeah gl is the default and should just work out of the box most of the time, unless you have a very old system.

Do these games load if you just load them from within retroarch?

I have tried to load games directly using all three platforms I have cores loaded for and I am still getting nothing but a black screen. They start to load but then nothing.

As I stated above, I'm using my Dell laptop that isn't that old. This really has me bamboozled.

Link to comment
Share on other sites

5 hours ago, neil9000 said:

Yeah gl is the default and should just work out of the box most of the time, unless you have a very old system.

Do these games load if you just load them from within retroarch?

UPDATE!!!!! I reinstalled Retroarch, loaded cores and roms and games load and play from Retroarch. I am still not able to load them through Launchbox. I am not skilled enough to know which settings may be needed to be changed.

Link to comment
Share on other sites

2 minutes ago, Coop1960 said:

UPDATE!!!!! I reinstalled Retroarch, loaded cores and roms and games load and play from Retroarch. I am still not able to load them through Launchbox. I am not skilled enough to know which settings may be needed to be changed.

Good to hear.

Setting them up in Launchbox is pretty straight forward.

 

Link to comment
Share on other sites

2 hours ago, neil9000 said:

Good to hear.

Setting them up in Launchbox is pretty straight forward.

 

As we discussed earlier, I have loaded Retroarch in Launchbox but my games won't play. They play directly in Retroarch but not Launchbox. What am I not doing correctly? What am I missing? I have followed every tutorial I can find and no luc

Link to comment
Share on other sites

4 minutes ago, Coop1960 said:

As we discussed earlier, I have loaded Retroarch in Launchbox but my games won't play. They play directly in Retroarch but not Launchbox. What am I not doing correctly? What am I missing? I have followed every tutorial I can find and no luc

In your Retroarch set-up in LB when you go to the Associated Platforms tab did you make sure the following is done:

1: The platform name you entered matches the platform name as it appears in LB. (Example: If you named the platform "SNK Neo Geo MVS" but enter "Neo Geo" in the associated platform that will not work. It must match what you named the platform)

2: The correct core was selected.

3: The status field does not show "Missing Core File"

Link to comment
Share on other sites

14 minutes ago, Retro808 said:

In your Retroarch set-up in LB when you go to the Associated Platforms tab did you make sure the following is done:

1: The platform name you entered matches the platform name as it appears in LB. (Example: If you named the platform "SNK Neo Geo MVS" but enter "Neo Geo" in the associated platform that will not work. It must match what you named the platform)

2: The correct core was selected.

3: The status field does not show "Missing Core File"

I have checked everything and it is as you say it should be but I still only get music and a black screen. You asked me before about my GPU. How can i find that info?

Link to comment
Share on other sites

38 minutes ago, Retro808 said:

In your Retroarch set-up in LB when you go to the Associated Platforms tab did you make sure the following is done:

1: The platform name you entered matches the platform name as it appears in LB. (Example: If you named the platform "SNK Neo Geo MVS" but enter "Neo Geo" in the associated platform that will not work. It must match what you named the platform)

2: The correct core was selected.

3: The status field does not show "Missing Core File"

WOW!!!! Thanks so much for the help. I am now able to get Atari 2600 games and SNES games playing in Launchbox. Sega Genesis is still not playing video even though "Missing Core File" does not show. With the help I have received from the two of you, I feel like I will eventually get them going too.

I hope as I learn more about this, I may be able to contribute to the community also. 

Thanks again for your time and knowledge.

Coop

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...