Jump to content
LaunchBox Community Forums

Launchbox not launching MAME games


FormulaFox
 Share

Recommended Posts

Okay, so I've got a weird issue going on here....

I've recently swapped out the SSD in my arcade PC for a larger one so that I did not have to rely on the slow loading off of a hard drive over USB2 to play my games. Due to some issues with cloning the drive I had to move to a fresh Windows installation and reinstall everything. Everything has worked well aside from Steam refusing to properly acknowledge the joysticks(dealing with that over on Steam's help forums), and the issue at hand here...

Launchbox absolutely WILL NOT launch any MAME or FBA games. I have them set up to launch through Retroarch, and if I load Retroarch and load the ROMs they all work, but Launchbox outright refuses to launch Retroarch, or even MAME, when I tell it to load a game. The icon never appears at the bottom of the screen, nor in my Task Manager. It simply outright ignores the command. It doesn't matter if I double-click, click once and hit enter, or if I right-click and select Play.

I have triple-checked the emulator associations and it all looks fine. What do I need to do here?

(I cannot recall the exact MAME or FBA sets I am using, but they work with MAME 2016 and FB Neo Retroarch cores, so I see no reason why they shouldn't load in Launchbox)

Link to comment
Share on other sites

19 hours ago, FormulaFox said:

(I cannot recall the exact MAME or FBA sets I am using, but they work with MAME 2016 and FB Neo Retroarch cores, so I see no reason why they shouldn't load in Launchbox)

Well the fact that they launch fine in Retroarch by itself means there is some sort of incorrect setup in Launchbox. And i see from your reply to Joe that Retroarch itself will open from Launchbox. So that leaves the associated platform tab as the error i think. Can we see a image of that screen?

Link to comment
Share on other sites

11 minutes ago, neil9000 said:

Well the fact that they launch fine in Retroarch by itself means there is some sort of incorrect setup in Launchbox. And i see from your reply to Joe that Retroarch itself will open from Launchbox. So that leaves the associated platform tab as the error i think. Can we see a image of that screen?

Could you be a little more specific about exactly what screen you need me to provide?

Link to comment
Share on other sites

3 minutes ago, neil9000 said:

Options/Manage Emulators/Retroarch/Associated Platforms tab, making sure that your Arcade/MAME/FBA platforms are visible, like this.

image.thumb.png.30ad9e9645879539716c15b9ace84ac0.png

And with that, the mystery is solved and the problem is, seemingly, fixed. As soon as I got to that window I noticed there was no Libretro core listed for MAME. Set the mame2016 core and tried a game, loaded right up.

Sometimes it's just a matter of not knowing what to look at. I'll be re-importing my original set(which I had trimmed down to only games I wanted to play) and hopefully it will also work.

  • Game On 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...