Jump to content
LaunchBox Community Forums

--fullboot not allowing pcsx2 to boot from BIOS through launchbox (Issue resolved, see first post)


AncientCarthage
 Share

Recommended Posts

Certain games require that Pcsx2 go though the BIOS sequence to function properly (particularly where saved data is concerned).  I found a couple threads on the Launchbox forums that indicated the problem could be solved by putting --fullboot in command line parameters.  Problem is, it isn't doing anything.  No command line I enter into launchbox does anything (at least in relation to pcsx2).  Anybody have any idea what is going on and how to fix it?

EDIT: Issue is resolved, it was related to the custom command line parameters instituted by the plugin PCSX2 Configurator.  Issue resolution makes PCSX2 configurator perfectly functional, I highly recommend it.  The issue is caused by games using individual command line parameters after installing config files with the plugin (necessary to save individual graphics settings).  You can alleviate the issue by erasing the config file or altering the individual parameter to include a desired command.  PCSX2 Configurator will keep your platform commands when creating individual command line parameters, so as long as you create/download the configuration file after editing the parameter under emulators everything will work as expected.

For example, if you have --fullscreen and --fullboot in your emulators command line parameters, as shown here:

01.thumb.PNG.a103fb9307d60a106d478e9491da0d35.PNG

Then they will be included when you create/download a config file with configurator, as shown here:

02.thumb.PNG.7aba53a9b93e7f154cad2db3cf4be1ad.PNG

You can find PCSX2 configurator here: 

 

Edited by AncientCarthage
Link to comment
Share on other sites

17 minutes ago, AncientCarthage said:

Certain games require that Pcsx2 go though the BIOS sequence to function properly (particularly where saved data is concerned).  I found a couple threads on the Launchbox forums that indicated the problem could be solved by putting --fullboot in command line parameters.  Problem is, it isn't doing anything.  No command line I enter into launchbox does anything (at least in relation to pcsx2).  Anybody have any idea what is going on and how to fix it?

Its working just fine here, but i have it on for all PS2 games, where are you putting the command?

Link to comment
Share on other sites

11 minutes ago, Koroth said:

It does work for me too. Did you add --fullboot as a per game custom command-line?

2144957423_Schermopname(65).thumb.jpg.58d6bcb978d6c0d5a34932ed3bdb4b19.jpg

Actually i'm just testing here and i'm seeing a issue. It works the first time you launch the game, but if you go back into the edit again after exiting the game the command has gone.

Link to comment
Share on other sites

5 minutes ago, neil9000 said:

Actually i'm just testing here and i'm seeing a issue. It works the first time you launch the game, but if you go back into the edit again after exiting the game the command has gone.

In the past I had the same problem when using the PCSX2 configurator plugin, so I don't use that plugin anymore. With the plugin removed from LaunchBox the custom command-line parameters persist for me.

Link to comment
Share on other sites

I just downloaded pcsx2 configurator plugin.  The issue is that when you save a configuration profile for a game, the downloaded config uses a custom command line parameter.  Should be as simple as editing that to include --fullboot while using the plugin.  Thanks for your help!

EDIT: I also found out that it includes the commands you have saved in emulators, so if you put --fullscreen --fullboot in the command line parameters for pcsx2, the custom parameters will include those settings as well.  Thank god I caught this early on, this saved me a ton of headaches.

Edited by AncientCarthage
Link to comment
Share on other sites

  • AncientCarthage changed the title to --fullboot not allowing pcsx2 to boot from BIOS through launchbox (Issue resolved, see first post)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...