Jump to content
LaunchBox Community Forums

JedExodus

Members
  • Content Count

    41
  • Joined

  • Last visited

Everything posted by JedExodus

  1. This looks ideal for my use case, or indeed any I can think of. If I were to offer feedback it may be a bit involved for some users, but then I guess if someone has gone to the lengths of getting LB and installing the plug in they're probably competent enough to use the proposed setup. If it could hook into LB's playlist, Platform Catergory for example and offer a checkbox for disabling the plugin from there it would probably be a touch more user-friendly I suppose. But really I personally think its a great and powerful implementation and it would suit my needs perfectly
  2. Sorry to leave you hanging. I know Origin definitely has issues with the Steam Overlay in general. I will test on my own rig and get back to you. Haven't had a chance to be on the last while but when I do ill be sure to update.
  3. @LahmaThanks very much for looking in to it. I haven't had a chance to test the new release as yet but have every confidence in it. I curiously enough was able to change the root folder on my LB configuration. But this may be because the. exe was in a subdirectory with the lnk being in the main directory. Will play about with it when I get a chance and report back and raise an issue. Thanks again for all the hard work. The plugin is a real life saver
  4. It refused to launch and SteamLauncher timed out. I suspect this to be a Steam issue introduced in an update as editing the shortcut Steam Launcher make manually to point to to the EXE instead of the lnk and launching from there gave me the same result. It also worked perfectly fine before then stopped working very suddenly. Cant quite remember the option titles, but steam has the launch target and launch in. When either adding the EXE from scratch manually or changing the root folder in LB game options this fixes the issue. As they then both point to the folder with the EXE in it. Its worked fine for me ever since. Using LB normally this doesn't present any issues and the game launches fine, but in tandem with SteamLauncher it seems its necessary to do a bit of tweaking. As I say the issue is present using Steam as well, and I can't speak to it happening on any other titles for me. But there you have it. Just something for folks to keep in mind if launching games through a shortcut and they timeout. EDIT: Just noticed the Alpha thanks very kindly @Lahma will give it a whirl. Thank you very much
  5. Just thought I'd mention an issue I encountered and the fix. When playing Witcher 3 GOG version with SteamLauncher it stopped working after a while. This was because it was launching from a shortcut that pointed to an exe in a subfolder. Going in to edit game and choosing the exe direct to launch from and then changing the root folder to to the exe folder fixed this for me. Just thought would throw it out there in case someone runs in to the same issue. Ps lahma you rock
  6. Not sure if your emulator paths are correct and pointing to the right programs. Do you have another copy of Steam Launcher ANYWHERE in the Launchbox directory? Lahma strongly advises against this. I believe he described the effect of having two of them as "mayhem" Whatever it is its a simple fix I'm sure.
  7. Check the emulator paths. Previously when SteamLauncher was broke due to updates it would change the emulator paths to Steam,. They may just need reset to the original emulator EXE
  8. Yes dude. That sounds perfect thank you so much! Would give myself and others enough options that for any circumstance that I can think of. I keep meaning to post the batch file with the close dolphin with wii remote function up here as someone apart from me will surely find it useful. As a professional it would probably make your toes curl and your eyes bleed, but it works for me anyways! Will get on the batch - exe over the weekend at some point. I've got a fence to paint and a car to service before I get near my computer
  9. On Cemu: Yeah, this happens when I launch Cemu directly through Steam as well. I'm making use of some Vulkan 1.2 features in it that are very useful. The issue seems to have nothing to do with Steamlauncher and moreso Cemu or Vulkan 1.2. Plugin/Steam overlay works flawlessly with other Vulkan emulators I use so can only guess what the issue is here. On the .bat: Cool i'll give that a go. I got it the wrong way around, I kill touchmote on launch with the .bat,. It's other main focus is to scan the Dolphin log for a string that only appears when you try to go into the Wii main menu, at this point it kills Dolphin, deletes the log (otherwise it would become gigantic) restores focus to LB/BB and reactivates Touchmote. The idea being if i turn on my HTPC to play a Wii game I can do everything on the Wii remote and not have to juggle between controllers to navigate menus or close emulators or shut the computer down (It's really neat trust me!) Thank you for considering disabling the launcher by Catergory/Emulator. With the way my LB setup is organised either by Emulator or platform catergory would work, I have different emulators for different case uses (Gamecube - Dolphin, Wii - Dolphin, Mame, Lightgun - Mame) it's one of those things where the best option isn't apparent until someone stumbles across an issue I guess. After a decent bit of testing I can confirm it's working a charm for me so far, Cemu and my .bat were already existing issues for me beforehand. Hopefully there's no more major roadblocks that cause you to have to burn the midnight oil just to get the thing functioning again Cheers Jed
  10. This is a bit cheeky I know. But is there any possibility of adding a setting to enable/disable SteamLauncher by Platform or Platform Category. I have one or two troublesome emulators that don't play nice with it (Cemu in Vulkan mode gives weird graphical artiefacts with it on or my Dolphin setup for Wii which I use a .bat to open so that it launches Touchmote and kills it on exit) It's no biggie like and obviously very thankful that you for all your hard work, that would be on my wishlist to make the add-on perfect for my use case.
  11. Seems to be working a treat. You're a hero . Love the new settings menu
  12. Oh snap, you posted this as I just checked the thread . Will report back. Cheers!
  13. Big thank you for continuing to work on this. I know it's a major time investment for you but it's hands down the best plugin for LB. I and many others remain grateful
  14. Thanks kindly man, Will let you know how I get on. Real-life always always comes first, don't feel any pressure on my end (or anyone else's for that matter) to get the release out. Thanks again, you're a gentleman.
  15. You magnificent son of a gun! Cheers man, as always no rush. Everyone's lucky to have you
  16. Hate to be that guy but it actually works flawlessly for me. Maybe of worth noting that I haven't attempted to use SteamLauncher with the new interface knowing that it doesn't work currently and the games i'm playing currently are all native to Steam. Haven't head any similar reports from my mates who use Steam normally either? Maybe just luck of the draw though.
  17. Ah bummer. Have not upgraded to the beta yet. Hoping it doesn't take too much to figure out what they've changed. This plugin is the cornerstone of my setup, couldn't imsgine being without it anymore😭😭!
  18. Thanks for looking into it @Lahma, I feel the problem is a software/driver issue. I opened a thread in troubleshooting for this as I suspected it may be a more general issue. @HTPCei I'm not running dual monitors, I'm running just on a big cheap 60HZ 4K television. Are you running any programs in the background that could potentially interfere? My suspect for my issue is Touchmote but haven't had time to test thoroughly yet. Do you ever get an issue where the taskbar is showing over windows that should be in exclusive full screen whilst LB is running btw? Started observing this behaviour when the screens began playing up
  19. Heya, thanks for your input. Didn't get testing last night (started work at 6am this morning so was early doors for me) but done some checking today and found that disabling the startup screens fixed the issue for me. It may not be SteamLauncher at all in this case and maybe an issue specifically for my software setup that was introduced in version 9.10. Apologies for the libel and slander Plugin still kicks arse
  20. Disabling startup screens fixed this issue for me. It seemed to only be introduced for me when I updated to 9.10, will keep them off until next release and try again. I know i'm running a whole pile of stuff in that is greedy for focus but if @Jason Carr (not so subtle cry for dev help) gets it fixed in 9.11 that'd be amazing. It's obviously not a show stopper, but as luxury features go it is one I miss
  21. Thank you v much. It could well be a software conflict for me. The programs I suspect are MSI Afterburner and Touchmote. Moreso Touchmote than Afterburner. As the problem is intermittent testing is a slow task but will try some more this evening and get back to you if I learn anything. Thanks for all the hard work!
  22. Thanks for the reply. @DOS76 I did a bit more testing last night. MSI doesn't seem to be the culprit, despite my suspicions. Closing Touchmote or Steam itself seemed to regain focus, in these instances it was the taskbar popping up over videos that it cured.
  23. Hey guys. Have this issue and not exactly sure what's causing it. It seemed to start after the latest update but I installed a buncha stuff around the same time so not sure what the main source of the problem is. On exiting games in BB focus does not return correctly a lot of the time. Furthermore if I have LB desktop mode open and minimised and I go to say watch a YouTube video in full screen, the taskbar will be present, this stops immediately after closing LB. Programs that I have installed that I would suspect of maybe causing issues - MSI Afterburner (RivaTuner minimised and disabled by default) - Touchmote - SteamLauncher Plugin (BB seems to behave better with this disabled but I can't understand why this one would cause my taskbar to stay up when I open a fullscreen browser vid) Has anyone experienced similar. Any help or reports if similar very much appreciated. Cheers!
×
×
  • Create New...