Jump to content
LaunchBox Community Forums
breachless

Exit Demul using Esc key?

Recommended Posts

Hello! Loving Launchbox, and I have it working with everything so far with few problems... Except for one: How on earth do I set up Launchbox to exit Demul with the Esc key? I am sure it's something dumb that I am missing. I have googled and googled and I have tried other scripts with Autohotkey than what it automatically sets and still nothing... Truth be told, I don't understand autohotkey at all. Do I need to enable it somewhere or is it already set up? I thought maybe paying for premium would enable the feature, but that does not seem to have helped either (though I am happy to contribute to such a great piece of software!) I have set all my other emulators to close with the Esc key in the emulators themselves, but Demul does not appear to have such an option. I was hoping to get all of them set to do so so that I could then map the escape key to a button combination on my xbox 360 controller to easily exit games... Maybe I am attacking the problem from a completely wrong angle altogether? Any advice? The PC is running Win 10. Thanks!

Share this post


Link to post
Share on other sites
I believe that in one of the more recent builds of Demul it does work I just tested it on a Dreamcast game and it worked I'll have to test it with my other system that has the Demul arcade games on it when I'm done cooking.

Share this post


Link to post
Share on other sites
I'm on 0.7 Alpha build date sep 23 2015 not sure if that means yours is newer than mine if you click about it shows the build date. Here is the AHK script that Jason has under the AHK tab in the manage emulator section ; This section closes Demul when pressing Escape $Esc:: { Process, Close, {{{StartupEXE}}}

Share this post


Link to post
Share on other sites
Thanks for your help! Unfortunately it still does not appear to be working. I am indeed on a newer build (Build date is 12/22/2015), but I did go back and download the same version as you to test to rule that out and it didn't seem to make a difference. I also tried two other builds just for the sake of being thorough...

Share this post


Link to post
Share on other sites
Do you have that AHK script for Demul? Click tools then manage emulator find Demul in your emulator list then click edit. When the new form opens the third tab is for Auto Hot Key make sure the script is listed there if not paste it there and then try it out. Sorry in advance if you actually know how to navigate through LaunchBox and my step by step directions are unnecessary.

Share this post


Link to post
Share on other sites
DOS76 said Do you have that AHK script for Demul? Click tools then manage emulator find Demul in your emulator list then click edit. When the new form opens the third tab is for Auto Hot Key make sure the script is listed there if not paste it there and then try it out. Sorry in advance if you actually know how to navigate through LaunchBox and my step by step directions are unnecessary.
No apologies needed: I work in tech support, so I know how it goes! To answer your question, yes, the script is indeed listed there, but still no dice. I am starting to wonder if it's not just specifically Demul that is my issue. I wonder if AHK is working at all? Again, I know nothing about it and could very well just simply be mis-using it. Do I have to enable it somewhere? With all of my other emulators, I can't really say if AHK is working or not because I simply went into the user interface for each one and mapped the ESC to be the key that exits the emulator. This all works fine, but Demul of course, unlike the other emulators I am using, does not allow one to go in and change what does what in terms of input.

Share this post


Link to post
Share on other sites
Strangely enough, this issue seems to have worked itself out... I can't explain how, but I had just resorted to mapping Alt+F4 to one of the extra buttons on my logitech mouse and that worked well enough. Then today, I just happened to accidentally hit ESC on the keyboard to exit and it totally worked... I didn't change anything, but it works now. Just figured for the sake of anyone else reading this, I just let it marinate for a few days and it works ;)

Share this post


Link to post
Share on other sites
On 1/9/2016 at 3:53 AM, DOS76 said:

I'm on 0.7 Alpha build date sep 23 2015 not sure if that means yours is newer than mine if you click about it shows the build date. Here is the AHK script that Jason has under the AHK tab in the manage emulator section ; This section closes Demul when pressing Escape $Esc:: { Process, Close, {{{StartupEXE}}}

Is there a curly bracket missing ?

Share this post


Link to post
Share on other sites
2 hours ago, meecob said:

Is there a curly bracket missing ?

Yes. 
 

$Esc::
{
    Process, Close, {{{StartupEXE}}}
} 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...