Jump to content
LaunchBox Community Forums
duerra

Can get individual movies, but not bulk

Recommended Posts

My BB setup is pretty great these days, and most everything has movies.  However, Sega Saturn is largely missing movies.  Using the "Download Metadata and Media" doesn't seem to pull in the movie files from EmuMovies when operating in bulk, even with all the options checked.  I can see in the status bar it seems to be looking for them, but nothing ends up downloading.  If I go into the individual games, the movie files will show up and can be downloaded.  I would prefer not to do this individually for each game.  Am I missing anything, or is there a bug in the system?

Share this post


Link to post
Share on other sites

I can't say for sure but this sounds like it might have been a server type issue you might have to wait out. Never had this problem before. Are your sega saturn games matching the LB database?

Share this post


Link to post
Share on other sites

Yeah quite possibly just some downtime on there end.

Worth trying again, and if the issue persists its worth checking there site to see if it's up at all.

Share this post


Link to post
Share on other sites

Yes, the games have LB IDs.  

I just tried again.  Same story.  I Ctrl+A to select the games on the platform, then select to download Metadata and Media.  Select only movies (all forms), and then select to replace all existing media, just to be sure.

I can see it "Searching for Video_MP4" and "Searching for Video_MP4_HI_QUAL".  But nothing downloads.

Then, if I select a random game, right-click, and edit.  Download meta-data, EmuMovies tab.  I can see "Video - Gameplay (High Quality)" is checked by default among some other things.  I can successfully download, and the game shows the video properly in Big Box.  Most of the games still do not have videos.

This seems to be the only platform that I have this issue with.  I can see that EmuMovies has the video packs listed on the site (in addition to being able to download one-at-a-time).

Share this post


Link to post
Share on other sites

I have an update here.

I kept playing around, and found that small batches were working for me, but not when I was trying to update the whole platform.  I set out to investigate, and what I found was what appears to be an issue in handling duplicates.  This is a little strange, since I have duplicates for other platforms that haven't exhibited any issues.  However, I confirmed through various tests that when I selected batches that had multi-CD games that identified as the same game in LaunchBox, the movie download portion was not working.  Regardless of batch size, when I selected a batch that did not have any duplicate-identified games, the movie downloads would work as expected.

I haven't sniffed the wire to dig deeper yet since I've already resolved my issue, but based on how the UI is behaving, it would seem that the issue is in LB querying EmuMovies with a duplicate title and EmuMovies not liking that very much.

Edited by duerra

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×