Jump to content
LaunchBox Community Forums
daphnefan

Current list of 4:3 compatible themes?

Recommended Posts

Hi everyone! I recently modified an Arcade1up SF2 cab which has a 1280 x 1024 screen and have been prepping a PC with Big Box. I was looking through the downloads for 4:3 compatible themes and there's surprisingly not that many? Some themes support 4:3 game videos but do not appear to support 4:3 as a theme. I am looking for something that lets me use clear logos for games and lets me use game video themes, too, if possible. The only themes i found that out and out support 4:3 are BarTop Theme BETA v.0.9.2 (which is a few years old and, well, a beta), Four-By-Three 1.0.1 (which seems functional, but very basic), and I tried searching everything that was tagged 4:3 but most of the results are just for 4:3 video packs. Any help would be greatly appreciated!

Edited by daphnefan

Share this post


Link to post
Share on other sites

Sadly there aren't very many (or really any) theme makers that have any interest in creating a 4:3 theme it seems. Since almost all the themes (besides the default and Unified Redux) are made by community members its up to those content creators what they create.

  • Thanks 1

Share this post


Link to post
Share on other sites

Try Refaktor. I designed it to work with both 16:9 and 4:3, but you'll need to make a few quick changes which are outlined in the PDF file in the download. I don't have 4:3 so was not able to fully test on 4:3, but it should work. Please let me know if you need help with it. PS. I'll update it pretty soon with a clear logo wheel view.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

@daphnefan: Updated Refaktor to 1.3 -- added a wheel view for platforms and games. It should look good on a 4:3 monitor; please let me know if it works out as I don't have a 4:3 monitor myself for testing. You might need to tweak the config file a little (maybe not); check out the PDF bundled with the download for info.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, eatkinola said:

@daphnefan: Updated Refaktor to 1.3 -- added a wheel view for platforms and games. It should look good on a 4:3 monitor; please let me know if it works out as I don't have a 4:3 monitor myself for testing. You might need to tweak the config file a little (maybe not); check out the PDF bundled with the download for info.

Awesome, I had just been using the standard default theme but I look forward to checking out your updated theme tomorrow! 

Share this post


Link to post
Share on other sites

@eatkinola hey, I think I discovered an issue. It seems the theme locks up Big Box after a while of Attract Mode running. I've had it happen twice today FYI. Otherwise I really like it! 

Share this post


Link to post
Share on other sites
10 hours ago, daphnefan said:

@eatkinola hey, I think I discovered an issue. It seems the theme locks up Big Box after a while of Attract Mode running. I've had it happen twice today FYI. Otherwise I really like it! 

Glad you like it! Thanks for reporting that issue -- I don't typically let attract mode run for awhile, so I've never noticed that. Would you please provide some more info:

What version of Refaktor are you using? The newest version?

What version of LaunchBox are you using?

Is your LB media stored locally on the system, or do you use networked drives?

Were you using WMP or VLC to play videos? If you used the theme out of the box it'll force the use of WMP. To use VLC, you have to edit AOStyles.xaml in the theme's Styles folder; look at the notes int the top section of that file (it's a simple edit). It forces WMP by default because I've found it's generally more stable, but please see how VLC holds up to attract mode on your system.

Share this post


Link to post
Share on other sites
1 hour ago, eatkinola said:

Glad you like it! Thanks for reporting that issue -- I don't typically let attract mode run for awhile, so I've never noticed that. Would you please provide some more info:

What version of Refaktor are you using? The newest version?

What version of LaunchBox are you using?

Is your LB media stored locally on the system, or do you use networked drives?

Were you using WMP or VLC to play videos? If you used the theme out of the box it'll force the use of WMP. To use VLC, you have to edit AOStyles.xaml in the theme's Styles folder; look at the notes int the top section of that file (it's a simple edit). It forces WMP by default because I've found it's generally more stable, but please see how VLC holds up to attract mode on your system.

So I'm using the latest version of LB and your theme. My media is on my c:, which is also where my LB is. 

I'll try VLC to see if it works smoother.

Edit: Unfortunately, it hangs with VLC as well

Edited by daphnefan

Share this post


Link to post
Share on other sites
1 hour ago, daphnefan said:

So I'm using the latest version of LB and your theme. My media is on my c:, which is also where my LB is. 

I'll try VLC to see if it works smoother.

Edit: Unfortunately, it hangs with VLC as well

Thanks for testing VLC as well. Would you send me a log file from LaunchBox\Logs when it hangs? You'll first have to enable logs by changing this line in LaunchBox\Data\Settings.xml:

<DebugLog>true</DebugLog>

Maybe the log file will contain some clues. Please generate the log file using the default WMP if you have time.

P.s. You should backup the LB settings file anytime you hand-edit a change like this, just in case.

Share this post


Link to post
Share on other sites

I too have recently modded an arcade 1up sf2 machine. I am running big box with the default theme which works pretty good. What would be great is if the unified theme could be modified for 4:3 ratio. I spent a lot of time getting everything right in that theme and wish I could use it on my arcade1up machine.

Share this post


Link to post
Share on other sites

I did the layout and @Grila here did the XML for me a while back.

It's working fine on my low res 4:3 arcade machine

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 12/24/2018 at 11:41 AM, eatkinola said:

Thanks for testing VLC as well. Would you send me a log file from LaunchBox\Logs when it hangs? You'll first have to enable logs by changing this line in LaunchBox\Data\Settings.xml:


<DebugLog>true</DebugLog>

Maybe the log file will contain some clues. Please generate the log file using the default WMP if you have time.

P.s. You should backup the LB settings file anytime you hand-edit a change like this, just in case.

I’m sorry for the late reply but I haven’t had a chance to produce the file. However, if it’s any help it happens about 20ish minutes into leaving attract mode running. It doesn’t happen at all when I use the default theme, which I’ve left attract more running for hours without an issue. Not sure if that’s helpful but I thought I would at least give that bit of an update 

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/2/2019 at 6:21 AM, pezley said:

I did the layout and @Grila here did the XML for me a while back.

It's working fine on my low res 4:3 arcade machine

 

 

Hi! I tried your theme but since my screen is 5:4 everything is slightly off. Where could I edit the theme so that the marquees and videos line up correctly? 

Edited by daphnefan

Share this post


Link to post
Share on other sites
On 12/23/2018 at 9:46 PM, daphnefan said:

@eatkinola hey, I think I discovered an issue. It seems the theme locks up Big Box after a while of Attract Mode running. I've had it happen twice today FYI. Otherwise I really like it! 

Well it's been awhile but I found time to dig into this more and am almost positive I found the problem; it was a pretty sneaky memory leak. I should be able to post an update over the weekend. Thanks again for bringing this to my attention; this same bug was affecting another one of my themes.

Share this post


Link to post
Share on other sites
On 2/13/2019 at 11:01 PM, eatkinola said:

Well it's been awhile but I found time to dig into this more and am almost positive I found the problem; it was a pretty sneaky memory leak. I should be able to post an update over the weekend. Thanks again for bringing this to my attention; this same bug was affecting another one of my themes.

Great news! I really look forward to the update. I loved the theme but couldn't keep using it due to the locking up. 

Share this post


Link to post
Share on other sites
On 2/15/2019 at 9:57 AM, daphnefan said:

Great news! I really look forward to the update. I loved the theme but couldn't keep using it due to the locking up. 

Posted the update -- please try it out and let me know how it goes on your system.

 

Share this post


Link to post
Share on other sites

@eatkinola so I've left attract mode running for most of the day and I noticed two things: 

It doesn't lock up big box anymore! However, after some time (maybe an hour or more) it will completely quit bigbox and send me back to windows. But it works much better now!

Share this post


Link to post
Share on other sites
29 minutes ago, daphnefan said:

@eatkinola so I've left attract mode running for most of the day and I noticed two things: 

It doesn't lock up big box anymore! However, after some time (maybe an hour or more) it will completely quit bigbox and send me back to windows. But it works much better now!

Well at least that's progress! Does it show an error message when quitting BigBox, and does that happen with WMP or VLC? Anything in the log file?

Refaktor\Plugins\Ao.Bigbox.Themer.v3_9_2\AssemblyLogger\

Does it look like it's running out of memory? How much RAM in your system?

Edit: P.s. to generate a log file you have to enable logging in LaunchBox

Edited by eatkinola
log file info

Share this post


Link to post
Share on other sites
On 2/17/2019 at 4:12 PM, eatkinola said:

Well at least that's progress! Does it show an error message when quitting BigBox, and does that happen with WMP or VLC? Anything in the log file?


Refaktor\Plugins\Ao.Bigbox.Themer.v3_9_2\AssemblyLogger\

Does it look like it's running out of memory? How much RAM in your system?

Edit: P.s. to generate a log file you have to enable logging in LaunchBox

hey,

no log file appears in that folder but ive attached the log produced by LB

Debug 2019-02-24 08-11-04 AM.log

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...