Jump to content
LaunchBox Community Forums

Emulating Consoles/Computers via MAME inside Launchbox


andreasrocha
 Share

Recommended Posts

I have been trying to find a solution to my problem all over the Internet and I have found tids and bits but I just can't figure out what I am doing wrong. So here is what I am trying to do (nothing fancy as I am complete NOOB):

I want to run ZX Spectrum and SNES emulation via MAME inside LAUNCHBOX. I got the ROMS working via the command prompt in Windows.

ZX SPECTRUM example: D:\RETROGAMING\0LAUNCHBOX\EMULATORS\mame>mame64 spectrum -snapshot d:\retrogaming\0launchbox\emulators\mame\romsspectrum\manicminer.z80
SNES example: D:\RETROGAMING\0LAUNCHBOX\EMULATORS\mame>mame64 snes -cart d:\retrogaming\0launchbox\emulators\mame\romssnes\aladdin.zip

However, I can't get them to work inside LAUNCHBOX.

Here is my setup:

image.thumb.png.55bb6e6f94c9addeca44c497bca62d15.pngimage.thumb.png.a457f0e21328aefe14518ae1c716e23b.pngWhenever I start the roms inside Launchbox the screen goes black and then goes back to Launchbox.

I thought it had something to do with the Default Command Line Parameters but after seeing other videos on YouTube I do not think that is where the problem lies.

Can anybody help me out, please?

Link to comment
Share on other sites

don't know anything about Spectrum but that is the correct syntax for the SNES portion. Are your games compressed by anychance and maybe MAME would want a non-MAME rom like that to be unzipped assuming you aren't using the Software List ROMs

Link to comment
Share on other sites

The SNES rom was compressed (zip). I tried running an uncompressed version (sfc format) inside Launchbox but nothing changed.

I assumed that if I can run the zipped ROM through MAME using command prompt I should also be able to run the same ROM using MAME through Launchbox.

Link to comment
Share on other sites

I'm highly convinced that if you can run a program (any program) from the command prompt (directly or through a batch file), you can run it through LaunchBox. :) 

In your Mame - Edit Emulator - Details tab, is your "Use file name only..."  un-checked?

I'd never tried running SNES through Mame before and got intrigued.  I set it up like you showed with no luck.  So I created a new emulator "Mame-SNES" with the default command line parameters "snes -cart" and it worked.  I looked to see what was different between the 2 and Mame had that box checked whereas Mame-SNES did not.

I un-checked it MAME and it was then able to load.

Link to comment
Share on other sites

Hi @andreasrocha both of these systems emulate fine for me via LaunchBox.

When emulating software systems using direct media calls as you're doing, the LaunchBox tickbox "Use file name only without file extension or folder path" should be left clear.
For software list emulation, it should be ticked.
The arcade games side of things doesn't seem to mind whether it's set or not.

Also, when emulating using direct media via LaunchBox, the location of the games doesn't matter to MAME once LaunchBox points to them. The games can be zipped or not and actual naming is not critical.
What does matter to MAME is that it's ini file must know where the snes.zip and spectrum.zip bios files are.

By the way, have you any other MAME software systems working ok via LaunchBox?

Link to comment
Share on other sites

Thank you very much JoeViking245 and spycat for pointing these things out! One of the Spectrum roms started working but the others didn't. But I must be doing something wrong so I will have to test things out.

Spycat, I don't have any other systems working...I first want to get these 2 working and then I will pass on to the others.

Thanks again for the help!

Link to comment
Share on other sites

As you suggested, I ticked the "Use file name only..."

However, the other problem I was having was with the naming of the roms, or so I believe. Although the roms were showing up on Launchbox, some of them were not running. I simplified the names, removing all spaces and strange characters and that made them work. I believe Mame has some problems with weird named roms. Another strange behaviour inside Launchbox, was that after importing the roms and selecting the option to leave the roms in the original directory, the rom folder listed in the details of the Platform was something like "Games\Sinclair ZX Spectrum"...so I redirected it to where I had imported the roms from originally.

By the way, the reason for running these platforms through MAME is that I can get the amazing look through the HLSL shaders and the ease of customization. I just love the phosphorous trails and never found anything similar in other emulators. It really ends up looking the way I remember...

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...