Jump to content
LaunchBox Community Forums

DOSBox loses focus when using startup screen


SiriusVI
 Share

Recommended Posts

Hey everyone,

when I launch an MS-DOS game while Start-up screens are enabled in Launchbox or BigBox, the DosBox screen exits fullscreen mode and is pushed into the background a few seconds after the game launches. If I disable the start-up screens (which I don't want to do) everything works fine.

Has anyone an idea what to do about it? All other platforms work fine.

PS: I'm using the ExODos version of DOSBox.

EDIT: It seems that this only happens in some games. Whenever the game requires an input before it actually starts, this seems to happen. My example is prince of persia. It requires me to type either 1, 2 or 3 after I launch the game. Other games that don't need inputs like this work fine.

Edited by SiriusVI
Link to comment
Share on other sites

Hi @SiriusVI, unfortunately the eXoDOS collection is not currently compatible with the startup screens. This is due to the batch file scripting that eXoDOS uses, which doesn't allow us to properly monitor the emulator's process. It's something that I've looked into fixing before, but unfortunately I haven't found a solution, and I'm not sure if one actually exists. Unfortunately you'll just have to turn off startup screens for the eXoDOS collection.

Link to comment
Share on other sites

11 hours ago, Jason Carr said:

Hi @SiriusVI, unfortunately the eXoDOS collection is not currently compatible with the startup screens. This is due to the batch file scripting that eXoDOS uses, which doesn't allow us to properly monitor the emulator's process. It's something that I've looked into fixing before, but unfortunately I haven't found a solution, and I'm not sure if one actually exists. Unfortunately you'll just have to turn off startup screens for the eXoDOS collection.

Is there an easy way to turn off start up screens for an entire platform?

I have since found a workaround. As I mentioned before, this "bug" only happens when doa games require an input before the game actually launches. So prince of Persia does not work, but ther games do.

My workaround is to edit the start up screen for prince of Persia and set the duration of the start up screen to zero (I usually have it set to 5 sec).

When I do this, the start up screen will disappear before dosbox launches. That way you will have a (shorter) start up screen even when the game requires an input.

It's not perfect, but it works well. Now if I could bulk edit all dos games in a way that the start up screen duration is set to zero, I would consider this problem solved.

Link to comment
Share on other sites

2 minutes ago, SiriusVI said:

The problem here is that ExoDos games don't use an emulator at all... It uses Dos Box which isn't in the emulator list... I may he mistaken. Will take a look at it later.

Well if thats the case you can try a bulk edit on the games. High-lite all the games in the platform and use CTRL-E to open the bulk edit wizard. There are several options related to startup screens here.

1267216706_Screenshot(278).thumb.png.d93e0a6c547117854fdaa189bdfc6746.png

 

Link to comment
Share on other sites

2 hours ago, neil9000 said:

Well if thats the case you can try a bulk edit on the games. High-lite all the games in the platform and use CTRL-E to open the bulk edit wizard. There are several options related to startup screens here.

1267216706_Screenshot(278).thumb.png.d93e0a6c547117854fdaa189bdfc6746.png

 

Thanks! Start up screen load delay is the setting I need. It needs to be set to zero. That way the start up screen disappears before dos box launches.

 

Problem solved ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...