Jump to content
LaunchBox Community Forums

Fullscreen issue with Demul


CTRL-ALT-DEFEAT
 Share

Recommended Posts

I've had a problem with Demul for a while now and have never found any information for how to correct it and maybe someone here would know.

I have Demul configured to launch in Fullscreen (configured in the emulator's settings) and it will launch Fullscreen and then after about 2 or 3 seconds, it reverts to being Windowed. Turning off Fullscreen and using Alt+Enter to switch to Fullscreen manually doesn't make a difference; it does the same thing.

I have resorted to using a third party application to force borderless windowed fullscreen on it, but it doesn't work very elegantly with Demul like it does with PC games I have to use it with and even then that solution only works sometimes.

How do I get games launched with Demul to launch in and STAY in Fullscreen??

Thanks!

Link to comment
Share on other sites

@lordmonkus @Vlansix Thanks for the info! I did try an older version Demul last night and had the same issue. I'll give the addon a try tonight. I'm curious if it is related to DX 11 though. I have a number of games in Steam that are either built with DX10 or DX11 (or at least have features that can be enabled for either) and if you launch those games in fullscreen, they immediately minimize to the Task Bar, so they have to be run windowed (hence why I used a third party program to force Borderless Windowed Fullscreen for games that don't offer that in their video options). This happened to me when I was on Windows 8 on a completely different PC and now I'm on Windows 10; I'm speculating the same will happen with DX12 games, but I haven't bought any that use it. Different result with Demul, but both of it's backend plugin options are DX11, so maybe.

Either way, I'll try Vlansix's addon, but I'm also curious of what you think is happening. Thanks again!

Link to comment
Share on other sites

Welp, I gave it a go, but it didn't work. If I set it to run the program before the game, it tries to go fullscreen, but then collapses back to a window. If I set it to run after, it doesn't do anything. I also ticked the box to Wait For Close (not exactly sure what this even does) with the program set to run before the game, but it just took significantly longer to launch, attempted to fullscreen and then collapsed to a window. :/

I could just use nullDC, but when it loads the bios boot sequence, you can hear sound, but the DC logo doesn't show up. Tried a couple different versions of nullDC and different bios dumps with the same result.

Dang... well, thanks for the link anyhow!

Link to comment
Share on other sites

Hiya,

So, the issue you're encountering is generally caused by a background application behaving badly. Could be anything from OneNote, to windows error reporting, to Razer applications, to your antivirus, etc. Something is making your OS have to draw *something* to the screen, which causes you to drop out of full screen mode. Have you tried turning off all your unneeded startupd applications and seeing if it still occurs?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...