Jump to content
LaunchBox Community Forums

Archived Roms, Mounting, Using Wrong File


Recommended Posts

Hey guys, so I'm working on a batch script to launch SSF after mounting a rom in Daemon Tools. I currently have all my Saturn games zipped up, setting Launchbox to extract those zips, daemon tools then attempts to mount the wrong filetype.

Instead of mounting the .IMG it is mounting the .CCD file, and as a result SSF is stating no disc is inserted. I'm assuming that my work to this point is correct, but it seems Launchbox automatically decides what the "rom" file is to use when passing roms to emulators. Is this coded in at the back as just the first file that comes out, or does it seek specific file types in priority? I cannot for the life of me work out how to manage all my Saturn games without manually mounting, unmounting, or individually editing every single game to add an additional application (which for some reason has stopped working since moving to a different computer anyway...)

Link to comment
Share on other sites

15 minutes ago, DOS76 said:

have you tried the Retroarch Mednafen Saturn core it is pretty damn good and you don't have to do anything to mount the games.

Last I tried using Retroarch to emulate Saturn I could only get it to work by randomly finding which file should be used within an archive to launch a game... And then sometimes that game wouldn't be able to be launched with Mednafen, but only Yabause for some reason (I think the file type?) - and even then, it closes Retroarch for AGES, then randomly starts up again with the game running. It sits in my process manager for a long time I guess extracting the archive.

These are issues not even starting with getting it to boot through Launchbox :(

I wish CD based games were just easier to deal with, haha

Link to comment
Share on other sites

It seems that in this attempt, trying to launch any file from an archive in Retroarch for the Saturn results in a failure to load (after closing for a short period), and attempting to extract an archive in Launchbox first and have it launch through Retroarch is giving me nothing booting up. The files appear to be extracting to the 7z temp folder, but then just being deleted after Retroarch fails to do anything...

Link to comment
Share on other sites

False alarm, I am in fact a complete spanner. I had it set up with additional apps on my tester games, so it was still mounting them and causing issues... Urgh. This is so much nicer now. Thank you! I'm sure not all games will run, but this is so much easier that I simply do not care at this stage. My life is complete. You're all wonderful.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...