Jump to content
LaunchBox Community Forums
destac

LaunchBox Setup NEO-GEO Using RetroArch

Recommended Posts

My retroarch is 1.5.0 stable.

I'm runing on Windows 10 x64 

I followed this tutorial to setup launchbox trough retroarch to use NeoGeo core: 

I have neogeo.zip bios on my roms folder and my roms are on .zip file format

I also have the -L "cores\fbalpha2012_neogeo_libretro.dll" set up on launchbox.

I also tried with retroarch 1.4.1 stable but still don't play at all.

Any help?

Edited by destac

Share this post


Link to post
Share on other sites

Try downloading and using the fbalpha2012_libretro.dll or fbalpha_libretro.dll core, your specific rom set may change it.

Share this post


Link to post
Share on other sites

Those cores didn't work either, and I wrote on Associated Platforms the following:
NeoGeo and the  -L "cores\fbalpha2012_libretro.dll" or even -L "cores\fbalpha_libretro.dll" set up on launchbox.

I noticed that my system folder is empty. It is suposed to be empty?

Edited by destac

Share this post


Link to post
Share on other sites

If you dont have any bios for the systems that require them yeah.

Is your platform in Launchbox called "NeoGeo" exactly or is it slightly different ?

 

Share this post


Link to post
Share on other sites

So I need to put neogeo.zip bios on system folder and rom folder too right?
Yeah, I wrote all places "NeoGeo" the exact same way with those capital letters.

I tried to have bios on both folders but launchbox doesn't start RA anyway on those three cores.

I know that the neogeo roms work because i open one of them inside retroarch by loading content.

Edited by destac

Share this post


Link to post
Share on other sites

NeoGeo and Mame bios belong in the same folder as the roms, those are 2 of the times that bios don't go in the retroarch system folder.

Can you post a couple of screen shots of your "edit emulator" window and "associated platforms" in Launchbox ?

 

Share this post


Link to post
Share on other sites

Ok, and now I only have my NeoGeo bios on roms folder.

This is my edit emulator:

emulator details.jpg

This is my associated platforms:

associated platforms.jpg

But I think my may be something else missing on my RA.

I only did what ETA PRIME did on his video.

Edited by destac

Share this post


Link to post
Share on other sites

Hmm, i'm sitting here looking at your screenshots and reading over your posts and I don't see anything wrong. I thought maybe you had one of the boxes in the edit emulator window checked or maybe a typo in the command line but it all looks correct.

My only question right now is are you 100% sure you are using that core listed in your command line ? I believe you when you tell me you are but I have made that mistake in the past myself and seen people make it as well so I have to double check it to eliminate it. Personally I use the "fbalpha_libretro.dll" core since it's the most up to date along with my rom set.

I'm gonna tag @SentaiBrad and have him take a look in here, maybe he can see something i'm missing.

Share this post


Link to post
Share on other sites

I have both 3 cores on my core folder: 

fbalpha_libretro.dll

fbalpha2012_libretro.dll

fbalpha2012_neogeo_libretro.dll

There is any other way to double check if I'm using the core that I showed you listed?

This is my NeoGeo Game on emulation tab:

 

3.jpg

Share this post


Link to post
Share on other sites

Are all your games set to use that NeoGeo emulator ?

With a game loaded press F1 on your keyboard to bring up the RA UI and in the bottom left corner it will say the core loaded.

Edit:
bottom left, not bottom right like i had

Share this post


Link to post
Share on other sites

Yes, every single one of them are set to use NeoGeo emulator, and I only have metal slug games.
I launched metalslug withoul launchbox, via retroarch.exe and I did what you asked:

 

4.jpg

Share this post


Link to post
Share on other sites

Damn, i'm really stumped on this one for now.

You seem to have everything done correctly and it should work.

Do you have other games for other systems working in Retroarch ?

Share this post


Link to post
Share on other sites

No, but I tried to setup SNES roms with retroarch once, and I had similar issues.

On Launchbox I have nullDC working for my Dreamcast games and ePSXe for my Playstation games, and everything work just fine.

Share this post


Link to post
Share on other sites

For simplicity it's best to just setup Retroarch as the emulator in LB instead of for each system like you have for NeoGeo and then you can add each platform and command lines in the associated platforms tab.

In theory the way you have it for your NeoGeo setup should work and looking at what you have it should work but you are definitely running into an issue there somewhere.

2017-05-01 16_39_17-Manage Emulators.png

2017-05-01 16_39_24-Edit Emulator.png

2017-05-01 16_39_32-Edit Emulator.png

Share this post


Link to post
Share on other sites

Now I set my launchbox like you have, and I marked NeoGeo on Associated Platforms, but I had to unmark Attempt to hide console window on startup/shutdown, otherwise it came this error:

5.jpg

I have My launchbox on this path: D:\User name\Documents\LaunchBox

I have my emulators folder on this path: D:\User name\Documents\LaunchBox\Emulators\RetroArch_1.5.0_stable

I have my roms on this path: D:\User name\Downloads\Jogos\Roms

Edited by destac

Share this post


Link to post
Share on other sites

Did you select all your games for the platform and then right click and edit to bulk edit the emulator ?

Share this post


Link to post
Share on other sites

No, I just followed the video to import rom files, add files and so on.
I erased emulator and platform and I repeated the process again for testing those diferent cores, and now to set up retroarch like your example.

Edited by destac

Share this post


Link to post
Share on other sites

Yeah you have to edit your games to make sure they are set to the new emulator. You can use the bulk edit tool to change them all quickly though.

Share this post


Link to post
Share on other sites

I have to select all NeoGeo games on launchbox, rigth click, edit, then set field: Emulator and Value: Retroarch?
It didn't solved my problem.

I'm not sure what bulk edit tool is though.

Edited by destac

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...