Jump to content
LaunchBox Community Forums

Fix for Sega CD Stopped Working in Retroarch 1.5.0


Recommended Posts

Sega CD was working fine when I set it up in Retroarch 1.3.6, but then I updated Retroarch to 1.5.0 recently and it stopped working.  I compared the config files and they were the same, so it appears that something changed within RetroArch or LibRetro.  But, here's the fix that worked for me:

If you haven't copied the default config, I'd recommend doing that and telling Retroarch to use that instead (open Retroarch, go down to Configurations, and Load the copied configuration instead of the default).

Find "system_directory".  For me, the line read as follows:  system_directory = "default"

Change that line to this:  system_directory = ":\system"

For whatever reason, Retroarch doesn't seem to like "default" anymore.

Link to comment
Share on other sites

It happens from time to time to me as well. Granted, because I use RL I've been using the same system configs for years. Occasionally after an update one system will just stop working, and replicating the Retroarch.config and replace my old system config is the only way to fix it. I'd guess its as simple as a particular setting is no longer supported, but I've never been able to narrow down exactly why this is. 

Link to comment
Share on other sites

Overrides were made much much better in the last 2 major versions, which makes it much more worthwhile to do now. Custom Configs still have their place, but run in to this issue from time to time. From 1.4.1 to 1.5 (it might have even been 1.4 to 1.4.1 actually), they changed the configs and any old configs no longer worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...