Jump to content
LaunchBox Community Forums

Launchbox, Retroarch and Disc based games


Recommended Posts

Sadly, i can't provide an exact version when this issue started appearing, but Launchbox refuses to start any Disc based games using Retroarch (Sega CD, Turbografx CD, Sega Saturn).
Funnily enough, PSX games launch no matter what, be it the basic bin/cue format or a compressed pbp.

If i start Retroarch seperately, it loads said content without any issues whatsoever.
I had a very similar case with MAME before in that, whenever i launched LaunchBox via Steam (to benefit from its controller mapping funktions), MAME games couldn't be launched from launch box.
MAME on its own, or Launchbox opened without Steam worked.

Any idea what might cause this ? 

Link to comment
Share on other sites

Trust me, i tripple and double checked pretty much everything by now.
The weird thing is, *everything* else works. Every ROM based system works perfectly fine. Its just the Disc based ones that fail to do so (expect for PSX games).
Another weird thing:
Retroarch wont even open, which is usually a sign of what you said: Wrong paths, typo in the load core command etc.
But when i change the games path to point at the bin instead of the cue, Retroarch opens but stays on a black screen. 

All load core commands are correct (-L "cores\XxXx.dll"), all paths are correctly set (Retroarch, cores, bios, bin/cue), the bin/cue is clean (a.e. runs under any other circumstance), Retroarch is up-to-date (1.6.7), cores are brand new (online updater).
Like i said, i cant pinpoint when (a.e. with what Launchbox release) this started, as everything worked perfectly fine the way it was (and is) set up. Nothing changes, nothing moved.
So yeah, im at a loss here. I have no clue what is going wrong. Everything works, apart form the Retroarch Disc systems *except* the PSX...






Link to comment
Share on other sites

3 minutes ago, Einherjar said:

But when i change the games path to point at the bin instead of the cue, Retroarch opens but stays on a black screen.

Yeah, of course that won't work. Retroarch wants the .cue or another compatible file type and the .bin is not compatible for the CD based systems.

5 minutes ago, Einherjar said:

Trust me, i tripple and double checked pretty much everything by now.

Trust me, if it worked before and it suddenly stopped working something changed.

41 minutes ago, Einherjar said:

i can't provide an exact version when this issue started appearing, but Launchbox refuses to start any Disc based games using Retroarch

I have never had my LB just stop working with any version unless I messed something up.

If it was working and now it stopped but some do still work then something got changed. Maybe you didn't copy all the necessary bios over or maybe you didn't download the core or something.

Link to comment
Share on other sites

Of course Retroarch wasn't supposed to work when being pointed at the bin. Than wasn't what i was trying to point out. It was the fact that Retroarch *does* open, even though its bound to fail, something it doesn't do when pointed towards the cue file.

I made a short video about the whole process. 
Launchbox Vs. Standalone Retroarch. Its the same Retroarch instance that LaunchBox uses, same path, same cores, same bios files, same ROM/ISO paths.
You can see the Launchbox setup in the pics above, Retroarch directs to the very same files. (and yes, Retroarch is setup as the emulator for said games, something that sadly got left out above)


So, yeah.
All LaunchBox does is point at the same game and emulator and gives a correct launch command (for example: -L "cores\mednafen_pce_fast_libretro.dll") for an existing core and yet, it refuses to work.

Link to comment
Share on other sites

You mentioned a Mame issue you had before and that Mame would only work as a standalone or if Launchbox was run without Steam. But run Steam and Launchbox would not open the Mame roms. 

Will LB run those cd based games without using steam? Just asking as I did not see it mentioned and from reading your issue with Mame, Steam was the problem back then. 

Link to comment
Share on other sites

@Retro808 Good call, but i tried both scenarios with and without Steam, because i knew that this might have caused issues again. But sadly, it didn't. It wasn't that easy this time around.

@lordmonkus With all due respect, but i'd really appreciate a little less snark. I provided everything i could to show that the setup is correct and i'm just as confused about why it refuses to work.
I can't do more than *show* you that yes, i'm 100% sure that everything is set up correctly, pointing at the right paths, that stuff like cores, bios etc are present.
If i moved something, forgot a file etc, Retroarch itself wouldn't be running, since its the same Emulator LaunchBox is using.


Link to comment
Share on other sites

I figured you did already test but thought to ask so it was mentioned. 

Not sure what it could be. I had a case where MameUI 0.186 and newer would not open any Mame roms from Launchbox but would open fine as standalone. If I used any version before 0.186 LB had no issues. I could never figure it out. It was just MameUI versions. If I used command line version of Mame 0.186 it worked fine. 

Have you tried and older version of Retroarch? You did mention you are on 1.6.7. 

Edited by Retro808
Link to comment
Share on other sites

You can call it snark all you want bu the fact is if it worked before and now it doesn't something changed. And if nothing at all changed then you are literally the first person to come looking for help to have Launchbox stop working with only some emulators and not others for no reason whatsoever.

So no, it is not snark at all rather than I just stated a simple fact.

I have been helping people here on the forums and on Discord now for over a year and invariably every time someone posts or asks about a problem similar to yours where something just stopped working it has always been something changed.

Link to comment
Share on other sites

@Retro808 I actually hadn't, took me long enough to test everything out with one version ^^. Just tried it and older versions actually *do* work, which is weird, since most of the stuff is copied over from one version to the other anyways.
So something withing my Retroarch 167 instance must have an allergic reaction to LaunchBox *sigh*
Ok, needle in a haystack time...

  • Like 1
Link to comment
Share on other sites

The first screenshot shows a path in LB of Spiele\Emulatoren\Clean Retroarch 1.6.7\retroarch.exe but the second screenshot of your Retroarch folder just shows Spiele\Emulatoren\Retroarch 1.6.7\retroarch.exe

Do you have a second instance of RA that is indeed in a folder of "Clean Retroarch 1.6.7" and, if so, does it contain the core .dlls that you're trying to use?

Link to comment
Share on other sites

@Zombeaver Yeah, noticed that as well. My bad. The "Clean" version was the one i used in the vid and that is used in Launchbox. They are carbon copies of each other anyways. The "Clean" one was a completely fresh installation, with old configs etc copied over later and the other one was a carbon copy of a previous versions folder, where i tried the opposite a.e. overwrite an existing install with a new version installer and see if configs stick...they do ^^ 

But i have good and bad news:
The good news, i transplanted a few folders back and forth between several versions (I usually keep older versions intact) and now it works.
The bad news, i still have no clue what caused it in the first case. A busted config file, something broken in the "systems" folder etc. No clue. I'd have to dissect it bit by bit and its already 5 in the morning over here...

So yeah, looks like lordsnark...i mean, @lordmonkus (No hard feelings, im sorry for the outburst, i was just super frustrated before<3 ) was right on the money that i had broken something...i just have no clue how...or what...
My best guess: Probably messed up a Bios file somewhere, somehow, probably renamed it by accident. No clue, but swapping stuff with older versions saved the day.
Will be dissecting this nonsense more once i got some shuteye.

Thanks to everyone 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...