Jump to content
LaunchBox Community Forums
Drodrick

Controller automation volume & Retroarch problem

Recommended Posts

What you are describing sounds like a conflict of controls, either remap your controls in LB or in RA to something that is different.

Share this post


Link to post
Share on other sites
16 minutes ago, Lordmonkus said:

What you are describing sounds like a conflict of controls, either remap your controls in LB or in RA to something that is different.

I've tried that. if I change the controller automation controls through launchbox, I get the same issue with the new combo. 

I've also tried adding "nul" to all instances of slow motion in the retroarch config files. That has no effect. 

Edited by Ba6yhulk

Share this post


Link to post
Share on other sites

Try remapping them in the RA gui.

Also I was not responding aggressively at all, I am just very blunt and to the point and your post didn't make any sense in the context it was posted.

Share this post


Link to post
Share on other sites
2 minutes ago, Lordmonkus said:

Try remapping them in the RA gui.

Also I was not responding aggressively at all, I am just very blunt and to the point and your post didn't make any sense in the context it was posted.

That's the really weird part.. The only slow motion option I see doesn't have a button assigned to it in the GUI. I tried setting retroarch to require a button combination for hot keys. Still didn't fix the issue. 

I hear ya. Didn't mean to get sensitive. It's late, and I'm cranky.

Share this post


Link to post
Share on other sites
1 minute ago, Ba6yhulk said:

I hear ya. Didn't mean to get sensitive. It's late, and I'm cranky.

It's all good.

You can remap the stuff in RA though I have never done it aside from the different systems game controllers. I left the RA shortcuts alone since I never use them and LB stuff doesn't interfere for me since I never use the volume up and down, that's only for LB not the emulators.

Share this post


Link to post
Share on other sites

For me, changing the input driver to raw solved the problem. At first, changing the system volume with a hotkey would eject the disc. Then, one day, it initiated netplay whenever I tried to change the system volume. My input driver was set to dinput and changing it to sdl2 had no effect, but changing it to raw solved it with no apparent side effects whatsoever.

Share this post


Link to post
Share on other sites

I was having this same issue too, only I would get null and then the game would be in slow motion every time I tried to use my automation bindings for changing the volume while playing retroarch. I cleared my bindings for slow motion and all and it still would do this. 

My fix? Pause the game first with the new pause feature under another binding. Then change the volume and unpause. This workaround prevents the issue I was having until I can figure out a better solution

Share this post


Link to post
Share on other sites
1 minute ago, daphnefan said:

I was having this same issue too, only I would get null and then the game would be in slow motion every time I tried to use my automation bindings for changing the volume while playing retroarch. I cleared my bindings for slow motion and all and it still would do this. 

My fix? Pause the game first with the new pause feature under another binding. Then change the volume and unpause. This workaround prevents the issue I was having until I can figure out a better solution

Hi, I used that solution too, nverthless y discovered a better one, you can configure the controls inside retroarch control hotkeys for volume up and down is much more confortable, I set the rigth stick up and down for that work.

Share this post


Link to post
Share on other sites
On 5/22/2018 at 7:29 AM, Elmazz said:

for me, when i use controller automation to increase system volume while using retroarch, retroarch goes to tiny windowed mode... any ideas why? my launchbox hotkey enable key is L3, while retroarch's hotkey enable key is Select, so i dont get it at all..

Just wondering if this was ever fixed?  I'm running the latest 10.6 build BIgBox and have this same issue when controlling volume while in a game with retroarch (i'm using a keyboard not control pad).  Actually having a combination of issues mentioned on this thread.  I get the "nul" notification on bottom left corner, it effects window size toggle and speed of game play... it just goes wonky :(

Share this post


Link to post
Share on other sites
On 5/2/2019 at 11:56 AM, Aimnos said:

For me, changing the input driver to raw solved the problem. At first, changing the system volume with a hotkey would eject the disc. Then, one day, it initiated netplay whenever I tried to change the system volume. My input driver was set to dinput and changing it to sdl2 had no effect, but changing it to raw solved it with no apparent side effects whatsoever.

Thank you so much for this suggestion. I had given up trying to get this working correctly. Changing the input driver to raw fixed all of my problems.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, ElMeroMaquinero said:

Just wondering if this was ever fixed?  I'm running the latest 10.6 build BIgBox and have this same issue when controlling volume while in a game with retroarch (i'm using a keyboard not control pad).  Actually having a combination of issues mentioned on this thread.  I get the "nul" notification on bottom left corner, it effects window size toggle and speed of game play... it just goes wonky :(

As suggested a few posts back, try changing the input driver to RAW. I had given up on this a long time ago. I only read through the last few posts because of you posting today. This fixed everything for me.

  • Like 1

Share this post


Link to post
Share on other sites
On 10/23/2019 at 6:58 PM, Ba6yhulk said:

As suggested a few posts back, try changing the input driver to RAW. I had given up on this a long time ago. I only read through the last few posts because of you posting today. This fixed everything for me.

 

On 11/6/2019 at 1:58 PM, ElMeroMaquinero said:

Thanks for the info, changing retroarch input driver to raw worked!

Well all was good until I shelled windows 10 for BigBox.exe on boot and now the volume does not work.  Tested and works again after loading explorer.exe

does anybody have any suggestions?

 

thx!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...