Jump to content
LaunchBox Community Forums
Drodrick

Controller automation volume & Retroarch problem

Recommended Posts

One of my favorite features and very useful most of time, is the possibility of control the volume level with controller automation, 

The problem is with Retroarch, if I try to use adjust the volume with control automation while I'm playing , Retroarch shows a bottom/left message that says "null", afterward the control does not respond anymore, so I must close the game, this happen both Launch Box & Big Bog.

Do you have the same problem? Is a config problem? thank you guys

 

nullerror.thumb.png.c3c79f9e7d5a9f05a7cf2646bd49e31e.png

Edited by Drodrick

Share this post


Link to post
Share on other sites

My best guess would be that you have those same buttons bound to something in Retrarch causing a conflict.

Share this post


Link to post
Share on other sites

 

47 minutes ago, Lordmonkus said:

My best guess would be that you have those same buttons bound to something in Retrarch causing a conflict.

 

I tried with different control automation configurations but it does not work, I receive the same null message , does it work for you?

Edited by Drodrick

Share this post


Link to post
Share on other sites
32 minutes ago, Lordmonkus said:

Yeah, works fine for me. Did you mess with any of the input hotkey binds in Retroarch at all ?

I thought that so I download Retroarch again and put it on an new folder with the default configurations, but I received the same null message when I tried adjust the volume, could be my controller or my SO? I have an Xbox 360 wireless controller and windows 7 Home premium

Edited by Drodrick

Share this post


Link to post
Share on other sites

I think the volume adjust controller automation in LB is for LB volume, not emulator volume so maybe that is sending some weird command to RA giving you that message.

Share this post


Link to post
Share on other sites
5 minutes ago, Lordmonkus said:

I think the volume adjust controller automation in LB is for LB volume, not emulator volume so maybe that is sending some weird command to RA giving you that message.

In my case the controller automation adjust the volume in general for all the system, I know it must be the S.O

Edited by Drodrick

Share this post


Link to post
Share on other sites

for me, when i use controller automation to increase system volume while using retroarch, retroarch goes to tiny windowed mode... any ideas why? my launchbox hotkey enable key is L3, while retroarch's hotkey enable key is Select, so i dont get it at all..

Edited by Elmazz

Share this post


Link to post
Share on other sites
6 minutes ago, Elmazz said:

for me, when i use controller automation to increase system volume while using retroarch, retroarch goes to tiny windowed mode... any ideas why? my launchbox hotkey enable key is L3, while retroarch's hotkey enable key is Select, so i dont get it at all..

Launchbox will not override what is in Retroarch. You would want to make sure you change the key/button it is mapped to in Retroarch as well. 

Share this post


Link to post
Share on other sites
1 minute ago, Retro808 said:

Launchbox will not override what is in Retroarch. You would want to make sure you change the key/button it is mapped to in Retroarch as well. 

what do i change exactly? i dont have a button mapped on retroarch that minimizes retroarch.

Share this post


Link to post
Share on other sites

If what ever button you are hitting is sending RA from full screen to windowed than something in RA is mapped. Open Retroarch and go to options > Input Hotkey Binds ...see what is mapped to "Fullscreen Toggle".  

Share this post


Link to post
Share on other sites
1 minute ago, Retro808 said:

If what ever button you are hitting is sending RA from full screen to windowed than something in RA is mapped. Open Retroarch and go to options > Input Hotkey Binds ...see what is mapped to "Fullscreen Toggle".  

its nothing (aka ---). i wiped most of the hotkeys in retroarch in fact, so thats why im saying that i dont understand whats going on.

Edited by Elmazz

Share this post


Link to post
Share on other sites

Do you use any custom configs, core overrides, or game overrides in Retroarch?  If so it might be retaining a key you wiped from Retroarch general button maps.

In Launchbox options there is a button map option for Toggle Fullscreen. I am not sure if that is for just LB or for emulators as well as I do not use it. But check that just in case you have it mapped. 

Share this post


Link to post
Share on other sites
11 minutes ago, Retro808 said:

Do you use any custom configs, core overrides, or game overrides in Retroarch?  If so it might be retaining a key you wiped from Retroarch general button maps.

In Launchbox options there is a button map option for Toggle Fullscreen. I am not sure if that is for just LB or for emulators as well as I do not use it. But check that just in case you have it mapped. 

nope, no custom configs in retroarch. even deleted the config folder in retroarch just in case but still, the problem persists. Btw, i meant to say that i am using bigbox, not launchbox. Is there such a button map option as "toggle fullscreen" for bigbox? i dont see one.

retroarch minimizes only when i use bigbox controller automation to change the volume, so i tried switching hotkeys in bigbox but the problem is still there.

checked launchbox button maps just in case, and toggle fullscreen is set to none.

Edited by Elmazz

Share this post


Link to post
Share on other sites

do you use remap files (at least that is what I think they are called they are like overrides but for controller stuff instead)

Share this post


Link to post
Share on other sites
6 minutes ago, DOS76 said:

do you use remap files (at least that is what I think they are called they are like overrides but for controller stuff instead)

nope. btw, just deleted the retroarch.cfg, because somehow increasing volume with bigbox messed the retroarch up to the point of black screen in games. now when i use the bigbox controller automation to change volume in retroarch, at first it says "null", then it says "saved to slot 1" and then it says "slow motion" and its in slow motion. i just wont use bigbox automation in retroarch i suppose, screw this man xD

Edited by Elmazz

Share this post


Link to post
Share on other sites

Has anyone figured this out? It's been driving me crazy for a couple days now. 

BTW, if controller automation is turned off, the key combo does nothing to retroarch. It has to be a signal from launchbox/bigbox causing the issue. For most games, it's not really a big deal. I turn off on screen notifications, so I don't see "null". In PSX games, the volume buttons trigger a disc eject/slow motion. This happens even with a fresh retroarch install.

Edited by Ba6yhulk

Share this post


Link to post
Share on other sites
39 minutes ago, Ba6yhulk said:

Has anyone figured this out? It's been driving me crazy for a couple days now.

Figured what out ?

40 minutes ago, Ba6yhulk said:

BTW, if controller automation is turned off, the key combo does nothing to retroarch.

Of course it doesn't if it's turned off.

40 minutes ago, Ba6yhulk said:

It has to be a signal from launchbox/bigbox causing the issue.

What ?

40 minutes ago, Ba6yhulk said:

it's not really a big deal. I turn off on screen notifications, so I don't see "null".

What does this have to do with anything discussed up until this point ?

41 minutes ago, Ba6yhulk said:

In PSX games, the volume buttons trigger a disc eject/slow motion. This happens even with a fresh retroarch install.

Again, what does this have to do with anything discussed up until this point ?

Share this post


Link to post
Share on other sites
2 hours ago, Lordmonkus said:

Figured what out ?

Of course it doesn't if it's turned off.

What ?

What does this have to do with anything discussed up until this point ?

Again, what does this have to do with anything discussed up until this point ?

I apologise, I could have been more clear. Quoting the OP,

"if I try to use adjust the volume with control automation while  I'm playing , Retroarch shows a bottom/left message that says "null", afterward the control does not respond anymore"

I'm having the exact same issue. However, with the mednafen PSX core rather than saying "null" it either opens the disc drive or toggles slow motion. 

I've tried everything I can think of to get this to stop happening. Any ideas? 

I realize I may have worded my original post a little wonky, but I'm not sure why you seemed to respond so aggressively. I'm essentially having the exact same issue as the OP. I was only wondering if anyone has found a workaround.

Is there any way to turn off controller automation on a per emulator basis?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...