Jump to content
LaunchBox Community Forums
Lahma

Updating the "Download" button file on plugin

Recommended Posts

If anyone could help me with a quick question on my plugin download page, I would greatly appreciate it. I'm the author of the "SteamLauncher" plugin, and I just spent the last hour trying to help a user with an issue he was having with my plugin. I finally figured out what the problem was, and it had nothing to do with my plugin, and was quite unexpected. After the Steam client updated, I had to make some changes to my plugin to maintain compatibility, so I uploaded an updated version (v0.9.0.1). The problem is, the main "Download" button on the plugin page still downloads the old version of the plugin, which for all intents and purposes is totally non-functional now. Although a link to the updated version of the plugin is available at the bottom of the plugin page, most people by default are just going to click the download button and not pay attention to anything else. Am I doing something wrong here, and if so, how do I change the version that the download button points to. If I'm not doing anything wrong, is there some way to fix this? Thanks!

 

Share this post


Link to post
Share on other sites

Under the button „File Actions“ choose „Upload a new version” -> “Upload Your Files” -> “Choose Files…”.

If you want you can also delete there your old version as well so that the people will only be able to download the most recent one.

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, CriticalCid said:

Under the button „File Actions“ choose „Upload a new version” -> “Upload Your Files” -> “Choose Files…”.

 

If you want you can also delete there your old version as well so that the people will only be able to download the most recent one.

 

 

 

Cheers @CriticalCid

Share this post


Link to post
Share on other sites

I've already uploaded a new version, and I removed reference to the old version. That isn't the problem. The problem is, the main "Download" button on the page still downloads the old 0.9.0.0 version. Try it yourself and you will see what I'm talking about. Then browse to the bottom of the page, and you will see the only version available at the bottom of the page is 0.9.0.1.

Share this post


Link to post
Share on other sites

Your problem is that you have uploaded your update only as file attachment to the changelog but not to the download section itself. When I click on"Upload a new version" I only see that v0.9.0.0 is currently uploaded to the download section. Like I've said you have to upload it to "Upload your files" for it to show up on the download button.

image.thumb.png.368ccdc22f18489305cbab4a53121af9.png

Share this post


Link to post
Share on other sites

Thanks for your help. I was able to resolve the issue. I gotta say however that the whole process isn't exactly intuitive... When I initially posted the new version, I followed the correct procedure, except instead of adding the updated version via the "Choose Files" button under the "Upload Your Files" heading, I instead dragged my file into the "Drag files here to attach" box under the "What's New" text box (as you correctly stated above). Now that I understand how the whole process works, and what fields apply to what (specifically to the "Download" button), it clearly won't be a problem moving forward, but I think the process could be made a lot clearer for new users. I'm sure the forum uses an off-the-shelf product, but I also imagine it can be modified fairly easily. It might be worth the time to simply indicate on that page (that you provided a screenshot of) that the file listed under the "Choose Files" button is the default file that will be downloaded when users click on the main "Download" button on the plugin page. Just a friendly suggestion. 

Oh and one more thing that wasn't at all clear to me after initially posting my plugin was that there was a forum thread automatically created for people to comment and ask questions on. I was actually a bit confused after I added the plugin, because my expectation was that the plugin download page would actually be the forum thread itself, with all subsequent posts showing up below the main plugin description. Whenever I saw that there wasn't any "Reply" button or anything (only "Reviews" and "Comments"), I just figured there must not be any forum thread automatically created for the plugin. Only later after receiving notifications and such did I realize that a thread had indeed been automatically created, but I still didn't know how to find that thread independently outside of the link in my notifications. I never would have guessed that the "Get Support" button would be a link to that thread until someone told me, as I guess I just assumed that button would send the author of the plugin a PM or something... Perhaps I'm the only person to ever post a plugin that has been a bit confused by these things, but somehow I doubt that. With just a couple of quick, easy changes, I think things could be greatly clarified.

If I'm just a blind idiot and the only one that feels this way, then by all means, just disregard my long-winded suggestions and move on with your day :D I'm just trying to be helpful! Thanks again CriticalCid!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×