Jump to content
LaunchBox Community Forums
Turnspit

Images missing for some platforms

Recommended Posts

Hopefully bumping this thread is the right approach, but... "NEC TurboGrafx-16" platform media is never populating. I've confirmed in multiple BigBox themes, including the default, and before and after the most recent LB version upgrade.

All games populate with multiple media elements, it is just the Platform itself. I've reset platform and all image cache and confirmed that the directory and Scrape As is the default for this Platform. I'll manually add a logo at this point, but felt the need to share.

It may or may not be relevant, but there are no images here for the platform either:

https://gamesdb.launchbox-app.com/platforms/images/54

Share this post


Link to post
Share on other sites

I confirm the same issue, for these (newly added) platforms under LaunchBox 9.7:

  • ColecoVision
  • Commodore Amiga
  • Mattel Intellivision
  • NEC TurboGrafx-16
  • NEC TurboGrafx-CD

These platforms (sub)folders are created automatically under LaunchBox\Images\Platforms\ but remain empty.  I had to add Banner and Clear Logo images manually and refresh Whell images in BigBox Options.  Other platforms scraped appeared automatically just fine so far.

Glad I found The Image Thread on this forum, it saved me alot of time to find suitable images.

Edited by Bitstorm
fixed typo in platform name and corrected bad statement.
  • Like 1

Share this post


Link to post
Share on other sites
8 minutes ago, Bitstorm said:

I confirm the same issue, for these (newly added) platforms under LaunchBox 9.7:

  • ColecoVision
  • Commodore Amiga
  • Mattel Intellivision
  • NEC TurboGrafx-16
  • NEC-TurboGrafx-CD

These platforms (sub)folders are created automatically under LaunchBox\Images\Platforms\ but remain empty.  I had to add Banner and Clear Logo images manually and refresh Whell images in BigBox Options.  Other platforms scraped automatically just fine so far.

Glad I found The Image Thread on this forum, it saved me alot of time to find suitable images.

Platform clear logos and banners are NOT scraped when importing a platform, they are included in the .exe for launchbox, and are added to the folders when a platform is created. However if your naming does not exactly match what the images are named as then they wont be moved to the respective folders. Also not every single platform has images included in the .exe, the most popular/used are there but its not a exhaustive list of every platform ever made, so you will often have to source images your self from either the specific download section we have just for them, or via google.

  • Thanks 1

Share this post


Link to post
Share on other sites
49 minutes ago, neil9000 said:

Platform clear logos and banners are NOT scraped when importing a platform, they are included in the .exe for launchbox, and are added to the folders when a platform is created. However if your naming does not exactly match what the images are named as then they wont be moved to the respective folders. Also not every single platform has images included in the .exe, the most popular/used are there but its not a exhaustive list of every platform ever made, so you will often have to source images your self from either the specific download section we have just for them, or via google.

Thanks for your (quick!) reply.

I understand not every single system that existed will be supported by default (and I can't contribute to fix it as it's not pulled from the LaunchBox Game Database), but the platforms I mentionned are pretty common, and I paid attention to name them exactly as the default list of platform names (except "NEC-TurboGrafx-CD" which was a typo when creating my previous post).  I was especially expecting "NEC TurboGrafx-16" to work like shown in your August 17, 2018 post on this thread, unless you added these images manually yourself at this time and meant "See, it works with default theme if you configure it properly" instead of "See, these images appeared automatically in Default theme on my setup" like I thought.

I just did a new test: fresh LaunchBox 9.7 reinstall on a clean VM:

I created a platform named "NEC TurboGrafx-16" (default platform name), and scraped some roms.
The "LaunchBox\Images\" folder has no "Platforms" subfolder at all (like you said, these images are not added during scraping).
The first time I switch to Big Box, then the "LaunchBox\Images\Platforms\NEC TurboGrafx-16" and subfolders are created, but empty.

Is there a list of which platform images are included in the .exe (and their exact names) so I could at least figure out if these are not included, or if it's a copy issue that should be reported?

Share this post


Link to post
Share on other sites

Just found this ala google due to the same issue with at least a half a dozen platforms. Plain text and no platform images in bigbox.
 

seems like it should be working but isnt for some people?  Like everyone here, scraped every single one via a default platform from the drop down. 

Share this post


Link to post
Share on other sites
19 minutes ago, klepp0906 said:

Just found this ala google due to the same issue with at least a half a dozen platforms. Plain text and no platform images in bigbox.
 

seems like it should be working but isnt for some people?  Like everyone here, scraped every single one via a default platform from the drop down. 

 

On 5/2/2019 at 7:40 PM, neil9000 said:

Platform clear logos and banners are NOT scraped when importing a platform, they are included in the .exe for launchbox, and are added to the folders when a platform is created. However if your naming does not exactly match what the images are named as then they wont be moved to the respective folders. Also not every single platform has images included in the .exe, the most popular/used are there but its not a exhaustive list of every platform ever made, so you will often have to source images your self from either the specific download section we have just for them, or via google.

 

Share this post


Link to post
Share on other sites

yea, probably wrong terminology.  wrote that from the gym lol.

so what your saying is either, theyre no longer included with launchbox, they never were, or they should be?

I got my launchbox from the source, as thats the only place you can afaik.  Ive updated only via the guis update option.  My playlists arent altered, theyre exactly as launchbox imports them from the dropdown (aka not a naming thing)....

so not sure what to say /shrug  just an observation.

EDIT - looked in the launchbox>images>platforms section and NEC TurboGrafx-16 folder is there, but inside contains no images.  TG16-CD doesnt even exist.  ColecoVision is another one thats barren.

Only thing i can think of if these are "supposed" to be there is that running the media cleanup purges them if you dont have a platform with them set up at the time of running perhaps?

Gonna check on an untouched install on my backup pc.  (its my reference install :P)

EDIT2 - ok, i think im misunderstanding you or something.  If theyre included with launchbox, theyre definitely not present on my untouched install.   None of them are.  Unless theyre obfuscated/compressed/hidden somewhere until a playlist is created.  In that case, it still begs the question why many of us are missing the same images for the same platforms.    At what point they populate/where they come from - im unsure, but if someone were able to upload the full platform set it would be awesome :P

Edited by klepp0906

Share this post


Link to post
Share on other sites
7 minutes ago, klepp0906 said:

so what your saying is either, theyre no longer included with launchbox, they never were, or they should be?

No thats not what im saying. Im saying that some platforms are not and never were included with the program. The main systems are covered but there are a ton of systems that are not, those will need to be sourced and placed in the correct folders. As for the NEC stuff i believe there is a disconnect there. The default name in Launchbox is NEC TurboGrafx 16, but i believe the included images do not have the NEC part in the name, so they dont match.

Share this post


Link to post
Share on other sites

aaaaaah.  didnt think of that potential angle.  So launchbox default platforms are giving the wrong name, or the artwork is named incorrectly to match up with it, either or is up to the person that implemented it i guess.

So would changing the name of the platform cause it to populate, or does this only happen at the time of creation and thus would require a new playlist?

Anywhere we can source the actual list of the way they should be named?  So i can discern what is a case of not being included, vs a case of a naming discrepancy?

Share this post


Link to post
Share on other sites
4 minutes ago, klepp0906 said:

So would changing the name of the platform cause it to populate, or does this only happen at the time of creation and thus would require a new playlist?

I believe if you renamed to remove the "NEC" and refreshed the platform logos it would show, yes.

 

Share this post


Link to post
Share on other sites
1 hour ago, neil9000 said:

you see, that list shows as NEC TurboGrafx......

ill try renaming regardless

my problem entries ftr (typed exactly as they are/all pulled from default platform list)


ColecoVision

GCE Vectrex

Mattel Intellivision

NEC TurboGrafx-16

NEC TurboGrafx-CD

Nintendo Switch

Sega CD 32X

SNK Neo Geo AES

SNK Neo Geo CD

SNK Neo Geo Pocket Color

Sony Playstation (has platform image but logo generic)

Sony PSP Minis


If anyone can confirm which one of these do in fact/should in fact have art "out of the box" and which ones need to be managed by the user (in a perfect world) it would be helpful.

For the ones with more potentially obvious solutions (like with company name preceding, ill try a rename)
if it does turn out to be a naming discrepancy ill submit a bug report at some point today.

1 thing at a time :P Still cant get the ui picking up my desktop wallpaper right lol.

 

Edited by klepp0906

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...