Jump to content
LaunchBox Community Forums

Playstation Games will not launch when i click on the game.


frankyp
 Share

Recommended Posts

So i am new to launchbox / big box and i have some games set up to work just fine.

But for some reason when i launch any of my playstation games instead of launching the game 

it just opens up the emulator... Instead of just loading the game..

I am oviously using PCSX to emulate my playstation games. ( i have tryed like 5 other emulators ( all that i can find) but none work this is the only one) 

All my other emulators ( nes, snes, sega etc work fine) and this emulator does work and i can play games off it etc. but it simply will not 

directly launch the game instead just opens the PCSX  somone suggested i need a command line maybe?   

I checked through all the options i have not seen anything that would cause any problems. 

Please help thanks! 

Capture.thumb.PNG.c701ad766b01440fea9ca8f7f39acb88.PNG

Edited by frankyp
Link to comment
Share on other sites

In Launchbox go to Tools > Manage Emulators and edit the PSX emulator you have listed. 

I would recommend an emulator not so old. I think the last time this emulator was touched was 2003-2004. Eventually PCSX-R came from it. I would recommend ePSXe or the mednafen Retroarch core. 

Link to comment
Share on other sites

19 minutes ago, Retro808 said:

In Launchbox go to Tools > Manage Emulators and edit the PSX emulator you have listed. 

I would recommend an emulator not so old. I think the last time this emulator was touched was 2003-2004. Eventually PCSX-R came from it. I would recommend ePSXe or the mednafen Retroarch core. 

Yep, and as i said in the thread you seem to of deleted you will need a Playstation bios file, it looks like the emu you are using has some sort of built in bios if the games load from the program itself, but that is likely not very good and i would imagine it to have a lot of compatability issues. As i stated in your other thread track down the bios file needed and then use either epcsxe or the mednafen core in retroarch.

Link to comment
Share on other sites

Just now, Retro808 said:

That’s likely your issue why you could not get these to work in epsxe. .ecm is a compression format. You need to un-ecm the file and get it to a true .bin and .cue file. If you google epsxe .ecm file you should get hits on how to do so. 

lol, i have just woke up and read this and was about to say the same. :) Also even the games you have there that are nor ecm'd only have the .bin file, they will also need the matching .cue file to go with them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...