Jump to content
LaunchBox Community Forums
Columbo

Everything working except Arcade games

Recommended Posts

I imported a number of games such as Atari 7800, Atari Lynx, snes , etc. and all seem to work with no problems but after importing a number of Arcade games I can’t get a single arcade game to run.  Using Retroarch Core Updater I downloaded Arcade (FBAlpha) and Arcade (Mame 2003) and they don’t seem to run the games.  I then tried Mame stand alone and it doesn’t run them either.  When I try to run them with Mame stand alone the screen goes black for 3 or 4 seconds and then just returns to the menu again.  Can anyone steer me in the right direction to get these running?

 

Thanks

Share this post


Link to post
Share on other sites

What version of the ROMs do you have? If you don't know your best bet would be to get a new set and then also get the corresponding emulator version. Then you should try getting the games running in MAME itself before you try getting it to run through LaunchBox.

Share this post


Link to post
Share on other sites
1 hour ago, DOS76 said:

What version of the ROMs do you have? If you don't know your best bet would be to get a new set and then also get the corresponding emulator version. Then you should try getting the games running in MAME itself before you try getting it to run through LaunchBox.

All of this emulation stuff is new to me.  How do you tell what version roms are?  If I'm looking to download another set of roms, how do I tell what version they are?  Trying to run the games in Mame itself first makes sense though. 

Is there a way to delete all of the Arcade games from Launchbox including all of the images etc.?

Thanks for your help.

Edited by Columbo

Share this post


Link to post
Share on other sites
3 minutes ago, Columbo said:

All of this emulation stuff is new to me.  How do you tell what version roms are?  If I'm looking to download another set of roms, how do I tell what version they are?

Trying to run the games in Mame itself first makes sense though.  Thanks for your help.

MAME romsets should have the version in the name, like MAME Split 0.202 for example, and you should match the version with the same version of the emulator otherwise its likely games wont work.

Share this post


Link to post
Share on other sites
7 minutes ago, neil9000 said:

MAME romsets should have the version in the name, like MAME Split 0.202 for example, and you should match the version with the same version of the emulator otherwise its likely games wont work.

Thanks.  I just checked the rom set and apparently it is 0.201, (MAME.Roms.0.201.Split.Set).  So how would I run the roms in Mame first without Retroarch or Launchbox?  Thanks.

Share this post


Link to post
Share on other sites
10 minutes ago, Columbo said:

Thanks.  I just checked the rom set and apparently it is 0.201, (MAME.Roms.0.201.Split.Set).  So how would I run the roms in Mame first without Retroarch or Launchbox?  Thanks.

So you want version 0.201 of the MAME emulator to go with it. The easiest way is to put all the roms in the roms folder inside the MAME emu folder, but they can be anywhere, you just need to point MAME to the folder. Then you just need to double click a game in the MAME UI.

 

Share this post


Link to post
Share on other sites
9 minutes ago, neil9000 said:

So you want version 0.201 of the MAME emulator to go with it. The easiest way is to put all the roms in the roms folder inside the MAME emu folder, but they can be anywhere, you just need to point MAME to the folder. Then you just need to double click a game in the MAME UI.

 

Ok, I'll try that.  Before reading your previous message, I downloaded Mame0.201, removed the previous version (0.202), from Launchbox and added the 0.201 version.  Since the roms were already in Launchbox, and I didn’t know, prior to your previous post, how to test them with Mame0.201 by itself,  I tried again to run them in Launchbox after adding the Mame0.201 but I still get the same thing.  The screen goes black for 3 or 4 seconds and then returns to the menu.  Now I'll try to run them in Mame itself.  Thank you for you help and patience.  Very much appreciated.

Share this post


Link to post
Share on other sites

by default MAME will be looking for them in a folder ROMs inside of the MAME folder. They can be anywhere you want but you will have to set the location inside of MAME if they aren't inside of the MAME folder

 

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

by default MAME will be looking for them in a folder ROMs inside of the MAME folder. They can be anywhere you want but you will have to set the location inside of MAME if they aren't inside of the MAME folder

 

lol,

40 minutes ago, neil9000 said:

The easiest way is to put all the roms in the roms folder inside the MAME emu folder, but they can be anywhere, you just need to point MAME to the folder. Then you just need to double click a game in the MAME UI.

 

Share this post


Link to post
Share on other sites
5 minutes ago, neil9000 said:
47 minutes ago, neil9000 said:

 

 

The easiest way is to put all the roms in the roms folder inside the MAME emu folder, but they can be anywhere, you just need to point MAME to the folder. Then you just need to double click a game in the MAME UI.

Stupid question but,... how do you point MameUI to the folder?

Share this post


Link to post
Share on other sites

Open MAME,

1496879026_Screenshot(152).thumb.png.66724a34c74057560046fdb6d7e39639.pngDouble click "Configure options"

188495138_Screenshot(153).thumb.png.685e9f1233fc7af22d2ef6eebdddea4c.pngDouble click "configure directories"

714123116_Screenshot(154).thumb.png.3f1e6ffe698b3ea965432f204e11e2bd.pngDouble click "Roms"


852045675_Screenshot(155).thumb.png.1768cc628f87cbb1ddb745abe778883d.pngDouble click "Add folder" and navigate to your roms folder,when inside it press tab to set.

297944130_Screenshot(156).thumb.png.35bebff127ec9428daec8088cfd762dc.pngThen backup to this screen and double click "Save Configuration".1951548247_Screenshot(157).thumb.png.b3071d1571f4c8e3279263100b5077ce.png

Share this post


Link to post
Share on other sites
1 minute ago, DOS76 said:

In the MAME.ini file pretty much right at the top

Or that way if you are happy editing the .ini file. :) 

 

Share this post


Link to post
Share on other sites

yeah either way works you might be better off doing it through the UI for now though.

Share this post


Link to post
Share on other sites

In your example screenshots you are using Mame0.202 where as I am using MameUI0.201.  I have attached screenshots of what I see in 0,201.

I also looked at the mame.ini file to try to point it from there but I don't see where to do that.  I have attached the mame.ini file as well.

MAMEUI.ini

 

This is the main screen

 

scr1.thumb.jpg.c00f8178868777492931d72054687bd6.jpg

This is the options menu

scr2.thumb.jpg.0b83dd28ee5b88f5f03309f81efd1c4a.jpg

This is the directories window

scr3.jpg.d066e14e5a17063476894fd78500325d.jpgIf I browse to and select the roms folder and click ok,, when I double click on a game rom it just wants to extract it from the .zip.

 

Share this post


Link to post
Share on other sites

OK, you are using MAMEUI not MAME like me, thats why it looks different to mine. You will need to audit first in MAMEUI i think. Its under options if i recall, that will check all your roms.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...