Jump to content
LaunchBox Community Forums
Columbo

Everything working except Arcade games

Recommended Posts

When you right click a game and choose launch with does it show other options besides MameUI? It sounds like you have both Mame and MameUI set up and Launchbox is confused on which one you want it to start as default. If you have Mame set up in your manage emulators list as well as MameUI see which on you have the tick box checked for "default emulator". 

You also mention it works if you move to MameUI64\rom folder and it does not if you run from original location. The roms can be in any folder you want you just need to make sure both Launchbox and MameUI are pointed to the same folder. 

Share this post


Link to post
Share on other sites
14 hours ago, Retro808 said:

When you right click a game and choose launch with does it show other options besides MameUI? It sounds like you have both Mame and MameUI set up and Launchbox is confused on which one you want it to start as default. If you have Mame set up in your manage emulators list as well as MameUI see which on you have the tick box checked for "default emulator". 

You also mention it works if you move to MameUI64\rom folder and it does not if you run from original location. The roms can be in any folder you want you just need to make sure both Launchbox and MameUI are pointed to the same folder. 

I did have Mame as well as MameUI but I deleted the Mame.  I also have Retroarch installed as well.

 

Share this post


Link to post
Share on other sites
4 minutes ago, Columbo said:

I did have Mame as well as MameUI but I deleted the Mame.  I also have Retroarch installed as well.

 

Then you need to change the emulator in Launchbox like i said yesterday as it's pointing to the MAME you deleted not the MAMEUI you actually want to use. Go to tools/manage emulators, double click MAME and browse to the path of the exe you are using, so in your case mameui64.exe. Currently in the image you posted yesterday its pointing to mame64.exe which is the standard MAME that you say above you deleted.

Share this post


Link to post
Share on other sites
1 hour ago, neil9000 said:

Then you need to change the emulator in Launchbox like i said yesterday as it's pointing to the MAME you deleted not the MAMEUI you actually want to use. Go to tools/manage emulators, double click MAME and browse to the path of the exe you are using, so in your case mameui64.exe. Currently in the image you posted yesterday its pointing to mame64.exe which is the standard MAME that you say above you deleted. 

I did not delete MameUI64, I deleted Mame (standalone).  I have tried setting MameUI64 as the default for the Arcade platform but same issue.  I added Mame_2014 to Retroarch and tried that.  A couple of games seemed to run ok by double clicking the game image or pressing the Play button but only about 2 out of 10 or 12 games that I tried worked.  The notable difference in the games that did run is that they are running from the original location and did not have to be moved.  With MameUI64, the games have to be moved to MameUI64\Roms folder and run using the Launch with... option.  I'm wondering if I should just delete everything, reinstall launchbox and start over from scratch

Edited by Columbo

Share this post


Link to post
Share on other sites
11 minutes ago, Columbo said:

I did not delete MameUI64, I deleted Mame (standalone).

This is actually what i said,

1 hour ago, neil9000 said:

like i said yesterday as it's pointing to the MAME you deleted not the MAMEUI you actually want to use

So yes i know you deleted MAME and still have MAMEUI, this is exactly what i am saying, in Launchbox for your MAME emulator entry its still pointing at the standalone MAME exe, not at the MAMEUI one like it should be.

14 minutes ago, Columbo said:

I'm wondering if I should just delete everything, reinstall launchbox and start over from scratch

You dont need to delete Launchbox, but i would suggest at this point deleting all your MAME emulator entrys in Launchbox and deleting the Arcade platform and setting it up from scratch, by using the MAME importer and when it asks for your emulator path point it to your MAMEUI64.exe.

Share this post


Link to post
Share on other sites
6 hours ago, neil9000 said:

This is actually what i said,

So yes i know you deleted MAME and still have MAMEUI, this is exactly what i am saying, in Launchbox for your MAME emulator entry its still pointing at the standalone MAME exe, not at the MAMEUI one like it should be.

You dont need to delete Launchbox, but i would suggest at this point deleting all your MAME emulator entrys in Launchbox and deleting the Arcade platform and setting it up from scratch, by using the MAME importer and when it asks for your emulator path point it to your MAMEUI64.exe.

I deleted the arcade platform, and deleted MameUI64 as well. I unzipped MameUI64 to get a fresh emulator, placed it into my Emulators folder and then added it in Launchbox.  Then I imported the roms again selecting to run them from their current location and selected MameUI64 as the emulator.  When the roms were finish importing I tried to run a couple of games and I get the same issue.  The screen goes black and then I get the error window listing so-called missing files.  If files were actually missing it wouldn't run when moved into the MameUI64\Rom folder either.   I'm totally baffled!  I don't know what else I can do.

Edited by Columbo

Share this post


Link to post
Share on other sites

Can you answer the following and provide the pics requested. This helps to see where the disconnect is. In your last set up your were moving roms, adding and removing emulators and it makes it hard to troubleshoot when changes are constantly made. I recommend leaving everything as is right now and provide the below info:

1. As you have it set-up right now if you open MameUI and choose a game to run does the game run?

2. Right click any game in Launchbox and share pics of the Launcher Tab and the Emulation Tab

3. Go to tools>manage emulators in Launchbox. Edit the MameUI platform and share pics of the Emulator Details tab and the Associated Platforms tab. 

4. Open MameUI and go to the directories option, choose roms and share a pic of the screen showing your rom path. 

5. Since you loaded a fresh install of MameUI, in the folder where you have MameUI64.exe located do you also see a file in that same folder called Mame.ini?

I know you have shared pics before but I want to see it as you have it right now. 

Share this post


Link to post
Share on other sites
1 hour ago, Retro808 said:

Can you answer the following and provide the pics requested. This helps to see where the disconnect is. In your last set up your were moving roms, adding and removing emulators and it makes it hard to troubleshoot when changes are constantly made. I recommend leaving everything as is right now and provide the below info:

1. As you have it set-up right now if you open MameUI and choose a game to run does the game run? 

2. Right click any game in Launchbox and share pics of the Launcher Tab and the Emulation Tab

3. Go to tools>manage emulators in Launchbox. Edit the MameUI platform and share pics of the Emulator Details tab and the Associated Platforms tab. 

4. Open MameUI and go to the directories option, choose roms and share a pic of the screen showing your rom path. 

5. Since you loaded a fresh install of MameUI, in the folder where you have MameUI64.exe located do you also see a file in that same folder called Mame.ini?

I know you have shared pics before but I want to see it as you have it right now. 

1- No.  I get a window that lists a number of missing files.

In the MameUI64 folder I see a MAMEUI.ini file.

 

Launcher.jpg

Emulation.jpg

emulator_details.jpg

Associated_Platforms.jpg

Directories.jpg

Edited by Columbo

Share this post


Link to post
Share on other sites

OK a couple things wrong here  

1. Go to you mameui64 folder and look for a sub folder called “Ini”. In there find a file called mame.ini and copy it then paste it in the main folder where the mameui64.exe is.

2. Mameui64 is not pointed to the folder where you are teliing Launhcbox the roms are. Open mameui64 and go to the directories option. In the directories for roms click browse and navigate to the arcade folder where your roms are and then save. The paths in the 1st and last pics you posted should match. Then repost the last pic so I can see if the paths changed. 

3. Test a game in both MameUI64 directly and test the same game in Launchbox and let me know what happened. 

Share this post


Link to post
Share on other sites

Ok,  A number of the games that I tried are now working in Launchbox, although there are some that still will not run but that may be a problem with the rom itself. Unfortunately, Galaga, which is my favourite game of all, is one of the ones not working.  I get that error window listing missing files, which I get for some of the other games as well.

I'll have to go through each game and see which ones run and which do not.  I have attached the last screen as you requested and also the screen that I get when I try to run Galaga.

Thank you so very much for your patience and help.  I REALLY appreciate it.   And a BIG thank you to all of the others that offered help for this frustrating issue.

To delete a game and it's image from Launchbox do I just highlight it and press <DEL> ?

 

Directoies.jpg

galaga.jpg

Edited by Columbo

Share this post


Link to post
Share on other sites

Those bottom two are bios files, so search your roms folder for namco51.zip and namco54.zip, as bios are needed. Also open up your galaga.zip and look what files are in it, mine has the files yours says you are missing.

image.thumb.png.4dc43654d16a7722e220050daa7390e5.png

Share this post


Link to post
Share on other sites
31 minutes ago, neil9000 said:

Those bottom two are bios files, so search your roms folder for namco51.zip and namco54.zip, as bios are needed. Also open up your galaga.zip and look what files are in it, mine has the files yours says you are missing.

image.thumb.png.4dc43654d16a7722e220050daa7390e5.png

I can't find 51xx.bin or 54xx.bin files.  I'm finding about 50% of the games run and 50% do not run but come up with that error window.  Maybe because they also need those 2 files?  Not sure where to get those 51xx.bin and 54xx.bin files but I'll search the internet.  I have attached an image of what I get when unzipping Galaga, (just 2 files).

 

Galaga_unzip.jpg

Edited by Columbo

Share this post


Link to post
Share on other sites
6 minutes ago, DOS76 said:

uh that is the software list version of Galaga for Atari 7800 not the arcade rom

Oh,...  It was in the Arcade rom zip that I downloaded.  Maybe I should fine a good Arcade rom set.  I know that you cannot say where one can be downloaded but can you mention the name of a good set and I can search for it?  Seems that may be the problem for some of the other games that won't run and also throw up that missing file window.

Thanks DOS76

By the way,... how do I delete these games that don't run along with their images and any other stuff that may be related?
 

Edited by Columbo

Share this post


Link to post
Share on other sites

image.thumb.png.fc0c8322b85556e6cf34b56bf704a6f9.pngThis is what an arcade version of Galaga should look like. I checked in my Software List folder for MAME and that isn't even a MAME rom at all.

Share this post


Link to post
Share on other sites

There are a few different options if you only want to do Arcade you only need to get the one of these three options. Some games also require CHD files which is a separate download but there weren't an additions to it this month so it isn't on the 1st page some users opt to get that also some don't as its very large and a majority of the games don't even work yet in MAME CHD only comes in a merged variety there are no options on what to get

image.thumb.png.372ab52a25dce37bb7a23c1368537c93.png

Share this post


Link to post
Share on other sites

Here  is some documentation about MAME that explains how many of its facets work while it isn't hard to get working it has a depth of nuance to it. Also included a little visual aid to help explain the differences in the types of sets.

https://docs.mamedev.org/

 

Mame_Split_vs_Merged_vs_Non-Merged.png

Share this post


Link to post
Share on other sites

If I get a new rom set I need to know how to delete the games, images and related files that I currently have imported into Launchbox.  The emulator that I am using is for 0.201 roms.  I guess I could delete that MameUI64 and download one for 0.202.  Which emulator works best in Launchbox, Mame64 or MameUI64 or is there a difference?

Thanks

 

 

 

Edited by Columbo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...