Jump to content
LaunchBox Community Forums

RetroArch NES/SNES Light gun games


Recommended Posts


I'm having issues getting Zapper and Super Scope games to work in RetroArch. I can enable them and move the mouse cursor around no problem, but can't find any way to fire or reload. Anyone had problems with this? or got it working even, so I know it's most likely something on my end ?
I'm using the very latest RA and cores.

Any help would be great, cheers! :)

Link to comment
Share on other sites

Oh so it happens on Mega Drive as well!? Definitely sounds like a RA issue then, I can't see what else I could be doing wrong :/  but then again I've missed obvious stuff in the past so hopefully ? haha
Bummer, was going to move onto setting up light gun games for Mega Drive next as well :/ Oh well.. might have to use a standalone emulator for now then, but a shame since it's aaalmost there.

If I find a solution I'll let you know, now at least there is a couple of us having the issue :) 

Link to comment
Share on other sites

Hmmm, been doing some testing. In mesen i have no crosshair but the mouse buttons work, so i can shoot but i dont know where. In nestopia i have a crosshair but the mouse buttons dont work so i cant shoot. Was testing Duck Hunt (WORLD) for these.

Also for nestopia you need this NstDatabase file, just drop it in Retroarch/System if you dont already have it.



Link to comment
Share on other sites

Just now, polygonslayer said:

Hmm interesting. Cheers for checking out. Still probably not gonna work on Genesis and SNES though then? If this is only Mesen core?

Surely this must be an issue within RA at this point? Does anyone remember if it did work at some point?

While googling around i did see mention to it being broken in later versions of retroarch. I did see someone say that 1.6.9 was the last working one, so you could grab that and test, then if it works use that for Lightgun games. 

Name me some megadrive and snes lightgun games and ill take a look.


  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, polygonslayer said:

Cheers for doing some investigation :) I'll do some when I get home from work as well.

My gut feeling now is that this is a RA issue though, surely it's not meant to be this tricky to get working and it's buggered :/ 

Yeah, i think it is broken in recent releases, as i say mesen running Duck Hunt "just worked" in Retroarch 1.6.9.

Link to comment
Share on other sites

  • 2 months later...
  • 11 months later...

I just spent a lot of time setting this up as well. Originally I had Mesen as a separate standalone emulator but after some searching I also found that Mesen seems to work fine for Nes in retroarch.  So then what you do is create another emulator in launchBox with mesen as the default core and set your game to launch with that if it's not your normal emulator.  


SNES was a little trickier. I couldn't find a way to have my light gun automatically detected and usable with the cores I tried.  So then I tried to stand alone snes9x emulator which seem to work fine but the exit button couldn't be set to escape which is a problem.  I went back to retroarch snes9x core and was able to get it to work. What you have to do though is load up a game then go into the options menu.  Enable light gun settings in the core options.  Then make sure on player 2 you remap your gun trigger and gun buttons before you change the controller type to superscope.  I realize this is counterintuitive.  The problem is if you change the controller type first then there is no way to remap the buttons.  After you have remapped those buttons on player 2 change the controller type to SuperScope.  My light gun works just fine then.  The problem that I have with this is I could not find a way to have retroarch remember a specific controller loadout for each game. when you exit the game and then try to start up another game that doesn't use the light gun you have to go back in and manually change the controller type back to joypad which is kind of annoying.  I wasn't going to do that so what I did is I installed another instance of retroarch.  I set that version to the light gun settings.   Then created another emulator for light guns in LaunchBox.  

Maybe there is an easier way for super Nintendo games. I didn't try every single core. I only tried the snes9x core and mesen-s.  But the mesen-s core didn't even load for me.  

Hopefully this helps somebody.  

Link to comment
Share on other sites

I was messing around more with this today.  The Mesen core for Nes works great.  I should preface this by saying that I did not want the cross-hairs to show up in the game.  There were no cross-hairs originally and it makes the games to easy.  There are no cross-hairs for the retroarch core and no option to add them that I could find.  If you want the cross-hairs, there is the option of that in the stand alone version of Mesen. 

When setting up the Aimtrak light gun for MAME I noticed that it tracked better near the edges of the screen if I removed all bezels and fit the game to the screen.  The same is true of the NES games.  There is the option in the Mesen core for a 16:9 ratio which fills the screen.  I remember reading somewhere that the gun didn't track well.  That is not my experience.  It tracks just fine.  I will say that it is more accurate at the center of the screen and towards the edges always tends towards center.  If you just adjust your aim slightly there are no issues. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...