Jump to content
LaunchBox Community Forums
azraelblack777

MAME Looks Like It's Loading a Game Then Crashes Back to Launchbox

Recommended Posts

Hey guys, so I have a quick question: I'm still newish to Launchbox but I've gotten the hang of things for the most part by watching the latest tutorial videos and stuff on Youtube for getting systems set up and everything. Anyway, I just got Mame .211 and the .211 romset. I directed Launchbox to the Mame64.exe file for the emulator portion. And then, I imported the games themselves using the Mame Full Library Importer or whatever that option is called. I left off the options checked, such as no fruit games and things like that. The way I have my games/emulators set up, I have a folder within the Launchbox folder that is called Emulators and that stores all of my different emulators themselves within their own individual folders. The games themselves for all of my consoles, including MAME, are in a folder inside the Launchbox folder called Games. Each system has its own individual folder, including MAME. I imported the games directly from that MAME folder from within the Games folder that I have inside the Launchbox folder. So, whenever I try to load a game for MAME in Launchbox, it opens up a screen, says that it's loading, and then crashes back out. I had done a little bit of research trying to find some answers, so I went into MAME itself to see if I could load a game. As far as I can tell, every single game is not working correctly. When I try to run a game inside MAME, it pops up saying that it's missing a ROM or CHD file. And this is for every single game that I've tried to load inside MAME. What could be causing this? Also, what should be inside the zip files for each individual game? I just saw a bunch of random files. What file format is the rom itself? Oh, and in MAME itself, I went into the directory settings and pointed MAME itself to the MAME folder within the Games folder, thereby creating the mame.ini file out in the main Mame folder where the mame64.exe program is. What could I be missing? Can anyone help? Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

I’m having the same issue. I did notice if you right click the game in LaunchBox ( not big box) there maybe more than one version and it might be trying to load the bad one over the good. I noticed this with 1942. The first would look like it’s gonna load then back out to LaunchBox but the second would open like it’s supposed to. Wish I knew why it choose the bad over the good. Ended up wiping it all out and starting over again for the 10th time. I use attractmode for pc also and I never get this issue with the front end and the rom itself and I wanna use LaunchBox so badly but I only care about mame not the others. Works great for consoles though.

Edited by Revnmaynard

Share this post


Link to post
Share on other sites

Where are you roms located ? Is it in the LaunchBox “games” folder or inside the “roms” folder of your mame emulator?

Share this post


Link to post
Share on other sites
5 hours ago, azraelblack777 said:

Hey guys, so I have a quick question: I'm still newish to Launchbox but I've gotten the hang of things for the most part by watching the latest tutorial videos and stuff on Youtube for getting systems set up and everything. Anyway, I just got Mame .211 and the .211 romset. I directed Launchbox to the Mame64.exe file for the emulator portion. And then, I imported the games themselves using the Mame Full Library Importer or whatever that option is called. I left off the options checked, such as no fruit games and things like that. The way I have my games/emulators set up, I have a folder within the Launchbox folder that is called Emulators and that stores all of my different emulators themselves within their own individual folders. The games themselves for all of my consoles, including MAME, are in a folder inside the Launchbox folder called Games. Each system has its own individual folder, including MAME. I imported the games directly from that MAME folder from within the Games folder that I have inside the Launchbox folder. So, whenever I try to load a game for MAME in Launchbox, it opens up a screen, says that it's loading, and then crashes back out. I had done a little bit of research trying to find some answers, so I went into MAME itself to see if I could load a game. As far as I can tell, every single game is not working correctly. When I try to run a game inside MAME, it pops up saying that it's missing a ROM or CHD file. And this is for every single game that I've tried to load inside MAME. What could be causing this? Also, what should be inside the zip files for each individual game? I just saw a bunch of random files. What file format is the rom itself? Oh, and in MAME itself, I went into the directory settings and pointed MAME itself to the MAME folder within the Games folder, thereby creating the mame.ini file out in the main Mame folder where the mame64.exe program is. What could I be missing? Can anyone help? Thanks!

 

1 hour ago, Revnmaynard said:

I’m having the same issue. I did notice if you right click the game in LaunchBox ( not big box) there maybe more than one version and it might be trying to load the bad one over the good. I noticed this with 1942. The first would look like it’s gonna load then back out to LaunchBox but the second would open like it’s supposed to. Wish I knew why it choose the bad over the good. Ended up wiping it all out and starting over again for the 10th time. I use attractmode for pc also and I never get this issue with the front end and the rom itself and I wanna use LaunchBox so badly but I only care about mame not the others. Works great for consoles though.

OK, a couple of things to clear up here first. @azraelblack777 if you have a full 0.211 romset and 0.211 version of the emulator and used the MAME fullset importer then all of the games imported will work. Launchbox uses the actual MAME metadata to know which games work and which dont and only imports the working games. If you left all the settings at default in the wizard then you should have around 2816 games imported.

image.png.5f94ce423c59c248858aa6a4cd4e007b.pngIf you are getting missing files when trying to load directly from MAME then either MAME does not know your rom location, or you have a bad romset. Can you provide some images of your rom folder, your MAME.ini with the rom path and your MAME emulator settings from Tools/Manage emulators.

@Revnmaynard For the example you give of 1942 all versions should work, and like i said above if using the MAME fullset importer only working games are imported. What MAME romset and emulator version are you using?

Share this post


Link to post
Share on other sites
4 hours ago, Revnmaynard said:

Where are you roms located ? Is it in the LaunchBox “games” folder or inside the “roms” folder of your mame emulator?

Originally, it wasn't in the ROMs folder of the MAME emulator originally but I changed it last night and will find out later if it's working. I'll update when I know.

Share this post


Link to post
Share on other sites
8 hours ago, neil9000 said:

 

OK, a couple of things to clear up here first. @azraelblack777 if you have a full 0.211 romset and 0.211 version of the emulator and used the MAME fullset importer then all of the games imported will work. Launchbox uses the actual MAME metadata to know which games work and which dont and only imports the working games. If you left all the settings at default in the wizard then you should have around 2816 games imported.

image.png.5f94ce423c59c248858aa6a4cd4e007b.pngIf you are getting missing files when trying to load directly from MAME then either MAME does not know your rom location, or you have a bad romset. Can you provide some images of your rom folder, your MAME.ini with the rom path and your MAME emulator settings from Tools/Manage emulators.

@Revnmaynard For the example you give of 1942 all versions should work, and like i said above if using the MAME fullset importer only working games are imported. What MAME romset and emulator version are you using?

Yes, when I import the games, it's right around 2816. Is there a way to tell if the romset is a bad romset? I guess I'm not sure what you mean by the mame.ini with the rom path? I'm okay with computers, but only to a certain extent lol. Thank you for your help so far :)

Share this post


Link to post
Share on other sites
4 minutes ago, azraelblack777 said:

Yes, when I import the games, it's right around 2816. Is there a way to tell if the romset is a bad romset? I guess I'm not sure what you mean by the mame.ini with the rom path? I'm okay with computers, but only to a certain extent lol. Thank you for your help so far :)

OK, by that statement then i assume you have not told MAME where your roms are. :) MAME needs to know the rom path to be able to load your games, you can either do this through the UI or by adding your rom path to the mame.ini which will be located in your MAME emulator folder along side the mame64.exe.

image.thumb.png.4d65c7599385544e0d3f8829c528d1f7.pngIf you open that in notepad or notepad++ you can add your rom path to the appropriate section, which i have highlighted here, then save the file.

image.thumb.png.b803497597f0dcba69454291d48ad31b.png

Share this post


Link to post
Share on other sites
22 minutes ago, neil9000 said:

OK, by that statement then i assume you have not told MAME where your roms are. :) MAME needs to know the rom path to be able to load your games, you can either do this through the UI or by adding your rom path to the mame.ini which will be located in your MAME emulator folder along side the mame64.exe.

image.thumb.png.4d65c7599385544e0d3f8829c528d1f7.pngIf you open that in notepad or notepad++ you can add your rom path to the appropriate section, which i have highlighted here, then save the file.

image.thumb.png.b803497597f0dcba69454291d48ad31b.png

I know that I had pointed it to the folder where my games currently are...I did that both in Launchbox and Mame and it still didn't work. I'll try again later this evening and see if I have any better luck. Is there any difference between using Mame64.exe vs the mameui.exe? Is there a difference between MAME .211 and MAME UI? I saw that ETA Prime in one of his tutorial videos was talking about using MAME UI.

Share this post


Link to post
Share on other sites
5 minutes ago, azraelblack777 said:

I know that I had pointed it to the folder where my games currently are...I did that both in Launchbox and Mame and it still didn't work. I'll try again later this evening and see if I have any better luck. Is there any difference between using Mame64.exe vs the mameui.exe? Is there a difference between MAME .211 and MAME UI? I saw that ETA Prime in one of his tutorial videos was talking about using MAME UI.

Which are you using, standard or UI?

Share this post


Link to post
Share on other sites
2 hours ago, neil9000 said:

Which are you using, standard or UI?

The first time I set it up and imported the games into Launchbox, I was using standard. I didn't even know about UI until last night. So I deleted all the games out of Launchbox, and started the process for getting it set up with UI just to see if that would be any different. Inside UI itself, it was still telling me that there were missing files for the games I was trying to run. I haven't imported the games into Launchbox again yet. And I can't recall...did you mention how we can tell if my Romset is bad or not? If there's a file that should be in each zip or something that's not there or something, I could always check that.

Share this post


Link to post
Share on other sites

Before you ever attempt to import something into Launchbox it is usually best to set the emulator up first and test the games there first, as well as your controls. This way it helps eliminate Launchbox being the issue and it is easier to identify it being a rom issue. 

Which version of Mame do you plan on sticking with?

Share this post


Link to post
Share on other sites
4 hours ago, Retro808 said:

Before you ever attempt to import something into Launchbox it is usually best to set the emulator up first and test the games there first, as well as your controls. This way it helps eliminate Launchbox being the issue and it is easier to identify it being a rom issue. 

Which version of Mame do you plan on sticking with?

So I'm thinking it might be the romset? I would prefer to just stick with MAME standard if possible...I just tested the roms in MAME UI though, since I have the roms currently in the Roms folder inside the MAME UI folder. I'll attach the error that I get when I try to run a game. Do I need to download a brand new rom set?

Error.png

Share this post


Link to post
Share on other sites
9 hours ago, neil9000 said:

Which are you using, standard or UI?

Any ideas about this kind of error popping up inside of MAME UI itself? The rom zip file is in the roms folder inside MAME UI and it's pointed that way as well.

Error.png

Share this post


Link to post
Share on other sites

If your rom path is set correctly which it should be since you have your roms in the \roms folder inside your Mame folder then the most likely cause of this is your rom set is either incomplete or incompatible with the version of Mame you are using.

All of those messages are saying it cannot find the file it is looking for in the 1941.zip file. Either you don't have a 1941.zip file or the file is missing the files it is looking for or the files are incorrect.

Share this post


Link to post
Share on other sites
4 hours ago, azraelblack777 said:

Any ideas about this kind of error popping up inside of MAME UI itself? The rom zip file is in the roms folder inside MAME UI and it's pointed that way as well.

Error.png

Open your 1941.zip and have a look at what is inside it, that message is saying it can not find any of the files it needs for that game inside of its zip file. Here is what mine looks like from my 0.211 split set.

image.thumb.png.83ff89f02452261041fd6764cef7ec30.png

Share this post


Link to post
Share on other sites
7 hours ago, neil9000 said:

Open your 1941.zip and have a look at what is inside it, that message is saying it can not find any of the files it needs for that game inside of its zip file. Here is what mine looks like from my 0.211 split set.

image.thumb.png.83ff89f02452261041fd6764cef7ec30.png

So I think I was totally stupid. I noticed last night that all of my zips are in individual subfolders. so basically, the 1941 zip file is inside of a subfolder called 1941. So the main file inside the roms folder itself is a subfolder, not a zip file. I need it to be all zip files in there correct? I think I just need to find a program that will let me mass pull out all the files inside of subfolders in a folder. Do you know any programs that would let me do that?

Share this post


Link to post
Share on other sites
1 minute ago, azraelblack777 said:

So I think I was totally stupid. I noticed last night that all of my zips are in individual subfolders. so basically, the 1941 zip file is inside of a subfolder called 1941. So the main file inside the roms folder itself is a subfolder, not a zip file. I need it to be all zip files in there correct? I think I just need to find a program that will let me mass pull out all the files inside of subfolders in a folder. Do you know any programs that would let me do that?

lol, yes your folder should just look like this.

image.thumb.png.06802665bd40188c59d61cf57f9bb7c6.pngJust go to the folder and type *.zip into the Windows search bar, when it has finished sorting click one the CTRL A to highlite them all and cut, go back and paste them all into the root folder then delete all the now empty folders.

image.thumb.png.5a8a192551c5c480b41f7d392a542491.png

Share this post


Link to post
Share on other sites
3 hours ago, neil9000 said:

lol, yes your folder should just look like this.

image.thumb.png.06802665bd40188c59d61cf57f9bb7c6.pngJust go to the folder and type *.zip into the Windows search bar, when it has finished sorting click one the CTRL A to highlite them all and cut, go back and paste them all into the root folder then delete all the now empty folders.

image.thumb.png.5a8a192551c5c480b41f7d392a542491.png

Oh thank God that'll be easy :) thank  you guys so much. I can't believe I didn't see this sooner. Sorry! I'll let you know if I get it up and running tonight.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...