Jump to content
LaunchBox Community Forums

Lag in COLORFUL BigBox Theme


Recommended Posts

Hello everyone,

I've been struggling with something for quite some time now. I experience stutter / lag  in COLORFUL BigBox Theme. I've uploaded 2 videos on YouTube showing what I mean. The first one shows BigBox with Critical Zone theme running smoothly, the second one shows the COLORFUL theme lagging when scrolling through platform categories. The same lag occurs when scrolling through platforms as well.

I've already posted about this issue a while back in @viking's COLORFUL theme thread, but a solution couldn't be found. I'm hoping that the videos I've linked make my problem clearer.

1. Critical Zone without lag:

2. COLORFUL with lag:

Here is what I've already tried to fix this problem without success:

  • setting up a separate Launchbox installation with very few platforms and games.
  • disabling all transition effects
  • force caching images
  • reducing image quality to medium
  • disabling all anti-virus software
  • unplugging all usb devices except mouse and keyboard
  • I don't use MSI Afterburner or any similar software

Here are my specs:

LaunchBox is installed on a Samsung SSD 860 QVO 2TB

CPU: Intel Core i7-8700K, 4300 MHz

Ram: 48,0 GB

GPU: MSI GTX 1080 Gaming X

OS: Windows 10, latest updates, drives up to date

 

I really love the COLORFUL theme and would like to use it more often, but as it stands it's just not practical for me, so I'm hoping someone out there can help me fix this issue.

Thanks in advance 😃
 

EDIT: I should also mention that the lag in COLORFUL occurs mainly when scrolling through the platform categories for the first time. Once I've scrolled through everything once, there is considerably less lag. But every time re restart BigBox, the lag returns.

Edited by SiriusVI
Link to post
Share on other sites
  • 2 weeks later...

This thread has been viewed a number of times now, isn't there anyone who might have a guess at what's causing this behavior with the colorful theme specifically?

Link to post
Share on other sites

just guess ahead 😅

do you mean the transition effect?

because if i remember colorful has like a few second when it does a transition to the next item(as in shows the video and info).

at first i guessed maybe your hdd is slow but you have an ssd so maybe its your input device?

what do you use as a controller?

Link to post
Share on other sites
3 hours ago, HappyGuy said:

just guess ahead 😅

do you mean the transition effect?

because if i remember colorful has like a few second when it does a transition to the next item(as in shows the video and info).

at first i guessed maybe your hdd is slow but you have an ssd so maybe its your input device?

what do you use as a controller?

The thing is that everything works fine with different themes. It's just Colorful. My input devices work fine.

Link to post
Share on other sites
Posted (edited)

Make sure you update your drivers at geforce.com/drivers, not the msi website (they usually slow with updates and theirs no difference in drivers).

Uninstall any of the MSI stuff you may have, download the geforce drivers from geforce.com, check the box to do a clean install.

I'm thinking it's possible that your display resolution is set at 30hz instead of 60hz, which would cause mouse lag and stuttering. You can check this better in the nvidia control panel and going to the page and make sure you set it to be your native display resolution @ 60hz. (looks like a tv in your case). 4k is 3840x2160 @ 60hz. I've had this happen to me once where it defaulted to 30hz.

On your TV, go to its picture settings, find the advanced options. Turn off trumotion or w/e they call it, turn off all the processing features nobody needs anymore. This varies by TV what they are called but most tvs have some fake motion processing crap on by default.

I have a 8700 running at stock speeds, 16gb ram, evga 970, evo 960 ssd with an OLED tv. Runs smooth as butter. The reason why nobody has a solution for you is because nobody else has this problem. 2Tb isn't enough to hold over 120K in computer games and whatever else you have. So did you move the video and images folders for the platforms to another drive by chance?

Have you benchmarked the computer recently and compared it to prior benchmarks? I would benchmark your ssd and compare your results with others online, SSDs drop in performance if they are heavily used. 

In the launchbox settings, did you set the video player to use VLC? Set it to use VLC, that's a must. You can try to enable the intel iGPU in the bios (update your bios firmware while you're at it). That way the deskop apps use the intel gpu which is more efficent and may help. my bios called is igpu multi monitor (nothing to do with monitors, terrible name. Basically enabled the intel gpu while using the nvidia gpu at the same time. Once you do that, you'll see the gpu in Device Manager, go to the intel website and download drivers utility to update the graphics driver for the intel gpu, as well as any chipset drivers / wifi /etc you may have.

Even if the steps don't fix the issue, you will benefit anyway, but maybe one of these will do the trick.

Edited by sevenalive
Link to post
Share on other sites
Posted (edited)
On 5/17/2021 at 1:34 AM, sevenalive said:

Make sure you update your drivers at geforce.com/drivers, not the msi website (they usually slow with updates and theirs no difference in drivers).

Uninstall any of the MSI stuff you may have, download the geforce drivers from geforce.com, check the box to do a clean install.

I'm thinking it's possible that your display resolution is set at 30hz instead of 60hz, which would cause mouse lag and stuttering. You can check this better in the nvidia control panel and going to the page and make sure you set it to be your native display resolution @ 60hz. (looks like a tv in your case). 4k is 3840x2160 @ 60hz. I've had this happen to me once where it defaulted to 30hz.

On your TV, go to its picture settings, find the advanced options. Turn off trumotion or w/e they call it, turn off all the processing features nobody needs anymore. This varies by TV what they are called but most tvs have some fake motion processing crap on by default.

I have a 8700 running at stock speeds, 16gb ram, evga 970, evo 960 ssd with an OLED tv. Runs smooth as butter. The reason why nobody has a solution for you is because nobody else has this problem. 2Tb isn't enough to hold over 120K in computer games and whatever else you have. So did you move the video and images folders for the platforms to another drive by chance?

Have you benchmarked the computer recently and compared it to prior benchmarks? I would benchmark your ssd and compare your results with others online, SSDs drop in performance if they are heavily used. 

In the launchbox settings, did you set the video player to use VLC? Set it to use VLC, that's a must. You can try to enable the intel iGPU in the bios (update your bios firmware while you're at it). That way the deskop apps use the intel gpu which is more efficent and may help. my bios called is igpu multi monitor (nothing to do with monitors, terrible name. Basically enabled the intel gpu while using the nvidia gpu at the same time. Once you do that, you'll see the gpu in Device Manager, go to the intel website and download drivers utility to update the graphics driver for the intel gpu, as well as any chipset drivers / wifi /etc you may have.

Even if the steps don't fix the issue, you will benefit anyway, but maybe one of these will do the trick.

Thanks for taking the time to reply. Let me go through your suggestions one by one. please keep in mind that the other Themes work fine, it's just Colorful that has this issue:

1. I do have the latest geforce drivers. I always get the latest updates from geforce experience. So I don't use the ones from the MSI homepage.

2. I do have some MSI apps related to the motherboard installed. I will try uninstalling those and get back to you.

3. My main display (smart TV) is at native 1080p 60hz. I do have two other monitors connected. DIsconnecting them does not solve the issue.

4. The Launchbox app with all images and videos is stored on a 2 TB SSD. All the games are stored on an external HDD. is this a problem?

5. I haven't benchmarked my SSD. I never had a problem with it. it reacts super quickly and has no issues running  themes other than Colorful.

6. I use VLC player.

7. I have never tried iGPU. I don't know anything about it. I might try this out.

8. All my drivers are up to date. I use the drivers form the MSI homepage for everything except for the GPU. Should I get different drivers? I was under the assumption that the MSI drivers would be the best ones for the hardware.

EDIT: uninstalling MSI software has not solved the issue.

EDIT 2: According to Intel, all my drivers are up to date

Edited by SiriusVI
Link to post
Share on other sites

One more thing I thought I should mention: Once I've scrolled through all the platform categories once, the lag disappears / is drastically reduced when I switch through them a second or third time. I've also noticed the mouse curser turning into the blue wheel indicating that something loading. I contacted the author of the colorful theme about this, because I had a theory that the theme will count all the games in a certain platform and that's what causes the lag. However, the author said that Colorful isn't counting anything. So I'm not sure.

What else could be "loading" while scrolling through platform categories for the first time?

Link to post
Share on other sites

Sorry for my late response, I'm just getting out of the Covid ....

I'm running out of ideas to help you. Really sorry. :/
At home, it works well locally and even on an unraid VM!

Hope someone can help you!
I have other views in development with less animation. Maybe it will work better for you!

Link to post
Share on other sites
1 hour ago, viking said:

Sorry for my late response, I'm just getting out of the Covid ....

I'm running out of ideas to help you. Really sorry. :/
At home, it works well locally and even on an unraid VM!

Hope someone can help you!
I have other views in development with less animation. Maybe it will work better for you!

Thanks for replying. Hope you're alright. Covid is a mess.

I've done some more testing and I found something else out:

I redownloaded Launchbox and set up a test version of Launchbox with Platforms with only one game per platform:
- SNES 
- Apple II
- GBA
- Arcade

When I launch Bog box with this setup, Colorful runs smoothly. So far so good.

Then I copied the platforms and parents from the Data Folder of my Main Launchbox setup over to the test setup. This setup has all my games listed. When I Launched Big Box again, the lag returns.

In conclusion, Colorful runs smoothly, when there are just a few games imported. As soon as the number of roms increases, the lag returns. There must a some kind of difference between colorful and other themes, that make it lag when the number of games gets too high.

If you want to test this, I can send you the contents of my data folder and you can try if you experience the same kind of lag that I experience.

Link to post
Share on other sites

You can try this :
For example this file > PlatformWheel1FiltersView.xaml    (make a bakup of this one)
And remove these part :

line 277

<ObjectAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.Visibility)" Storyboard.TargetName="TotalGamesCount">
                <DiscreteObjectKeyFrame KeyTime="0:0:0.0" Value="{x:Static Visibility.Collapsed}"/>
                <DiscreteObjectKeyFrame KeyTime="0:0:3.9" Value="{x:Static Visibility.Visible}"/>
            </ObjectAnimationUsingKeyFrames>
            <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.Opacity)" Storyboard.TargetName="TotalGamesCount">
                <EasingDoubleKeyFrame KeyTime="0:0:3.9" Value="0"/>
                <EasingDoubleKeyFrame KeyTime="0:0:4.8" Value="1"/>
            </DoubleAnimationUsingKeyFrames>
            <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="Y" Storyboard.TargetName="TotalGamesCountAnim">
                <EasingDoubleKeyFrame KeyTime="0:0:3.9" Value="{Binding Source={StaticResource ConvertTextSlide}, Converter={StaticResource DimensionW3840Converter}}"/>
                <EasingDoubleKeyFrame KeyTime="0:0:4.8" Value="0">
                    <EasingDoubleKeyFrame.EasingFunction>
                        <CubicEase EasingMode="EaseOut"/>
                    </EasingDoubleKeyFrame.EasingFunction>
                </EasingDoubleKeyFrame>
            </DoubleAnimationUsingKeyFrames>

line 724

<!-- TOTAL GAMES (data) -->
            <aoc:AutoscaleTextBlock Text="{Binding GamesCount}" x:Name="TotalGamesCount" TargetFontSize="80" TargetScreenHeight="2160" 
                                    FontFamily="LAUNCHBOX_ROOT_FOLDER/Themes/Colorful - Light/Colorful_fonts/Roboto-Bold.ttf#Roboto" FontWeight="Bold" 
                                    Grid.Column="1" Grid.Row="7" VerticalAlignment="Center" HorizontalAlignment="Center">
                <aoc:AutoscaleTextBlock.Foreground>
                    <MultiBinding Converter="{StaticResource FilterSelectionColorConverter}">
                        <Binding ElementName="SelectionSnoop" Path="UpdatedTimestamp" />
                        <Binding ElementName="SelectionSnoop" />
                        <Binding Source="{StaticResource DefaultPlatformColor}" />
                    </MultiBinding>
                </aoc:AutoscaleTextBlock.Foreground>
                <aoc:AutoscaleTextBlock.RenderTransform>
                    <TranslateTransform x:Name="TotalGamesCountAnim" Y="0"/>
                </aoc:AutoscaleTextBlock.RenderTransform>
            </aoc:AutoscaleTextBlock>

 

 

This will remove everything related to the game counter.
If it comes from there, we will have to isolate the problem !

Link to post
Share on other sites
1 hour ago, viking said:

You can try this :
For example this file > PlatformWheel1FiltersView.xaml    (make a bakup of this one)
And remove these part :

line 277


<ObjectAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.Visibility)" Storyboard.TargetName="TotalGamesCount">
                <DiscreteObjectKeyFrame KeyTime="0:0:0.0" Value="{x:Static Visibility.Collapsed}"/>
                <DiscreteObjectKeyFrame KeyTime="0:0:3.9" Value="{x:Static Visibility.Visible}"/>
            </ObjectAnimationUsingKeyFrames>
            <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.Opacity)" Storyboard.TargetName="TotalGamesCount">
                <EasingDoubleKeyFrame KeyTime="0:0:3.9" Value="0"/>
                <EasingDoubleKeyFrame KeyTime="0:0:4.8" Value="1"/>
            </DoubleAnimationUsingKeyFrames>
            <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="Y" Storyboard.TargetName="TotalGamesCountAnim">
                <EasingDoubleKeyFrame KeyTime="0:0:3.9" Value="{Binding Source={StaticResource ConvertTextSlide}, Converter={StaticResource DimensionW3840Converter}}"/>
                <EasingDoubleKeyFrame KeyTime="0:0:4.8" Value="0">
                    <EasingDoubleKeyFrame.EasingFunction>
                        <CubicEase EasingMode="EaseOut"/>
                    </EasingDoubleKeyFrame.EasingFunction>
                </EasingDoubleKeyFrame>
            </DoubleAnimationUsingKeyFrames>

line 724


<!-- TOTAL GAMES (data) -->
            <aoc:AutoscaleTextBlock Text="{Binding GamesCount}" x:Name="TotalGamesCount" TargetFontSize="80" TargetScreenHeight="2160" 
                                    FontFamily="LAUNCHBOX_ROOT_FOLDER/Themes/Colorful - Light/Colorful_fonts/Roboto-Bold.ttf#Roboto" FontWeight="Bold" 
                                    Grid.Column="1" Grid.Row="7" VerticalAlignment="Center" HorizontalAlignment="Center">
                <aoc:AutoscaleTextBlock.Foreground>
                    <MultiBinding Converter="{StaticResource FilterSelectionColorConverter}">
                        <Binding ElementName="SelectionSnoop" Path="UpdatedTimestamp" />
                        <Binding ElementName="SelectionSnoop" />
                        <Binding Source="{StaticResource DefaultPlatformColor}" />
                    </MultiBinding>
                </aoc:AutoscaleTextBlock.Foreground>
                <aoc:AutoscaleTextBlock.RenderTransform>
                    <TranslateTransform x:Name="TotalGamesCountAnim" Y="0"/>
                </aoc:AutoscaleTextBlock.RenderTransform>
            </aoc:AutoscaleTextBlock>

 

 

This will remove everything related to the game counter.
If it comes from there, we will have to isolate the problem !

Sadly, that didn't work. Now I'm completely out of ideas. I'm sure it has something to do with the large number of games in my collection, but I cannot figure out why other themes work and colorful does not.

I guess I'll just have to live without colorful (sadly...)

Thank you for all your effort.

Link to post
Share on other sites
Posted (edited)

I have thousands of games for various platforms, over 8000. That's not your issue, neither is storing them on a different drive. My specs are comparable to yours. Storing your games on a HDD shouldn't be causing this and I doubt it is. I have colorful 4k platform videos and downloaded the highest quality video snaps. I run my desktop at 4k and everything is super quick, especially video playback.

I noticed the setting to use VLC player is also a big box setting and appears to be separate than the one in launchbox, double check that.

Intel has a processor diagnostic tool, download that. it's more of a CPU stress test, will max out the cpu more than any benchmark I found. It will also tell you if you have a thermal load issue or calculation issues.

I would get crystaldiskmark anyway and bench your ssd. You should find benchmarks for your ssd with a google search to compare. Wouldn't hurt to do that anyway even if you think it's ok.

Enabling the intel iGPU would be a good thing to do, from efficiency and extracting more power from your machine.

 

In your video, you are not using the colorful platform videos. Have you tried downloading the colorful HD platform videos (would also make the theme look a lot better in your setup...) Mayeb it's the platform videos you are using. They could be encoded with a more cpu intensive encoding.

 

Edited by sevenalive
  • Like 1
  • Thanks 1
Link to post
Share on other sites
Posted (edited)
On 5/27/2021 at 7:46 AM, sevenalive said:

I have thousands of games for various platforms, over 8000. That's not your issue, neither is storing them on a different drive. My specs are comparable to yours. Storing your games on a HDD shouldn't be causing this and I doubt it is. I have colorful 4k platform videos and downloaded the highest quality video snaps. I run my desktop at 4k and everything is super quick, especially video playback.

I noticed the setting to use VLC player is also a big box setting and appears to be separate than the one in launchbox, double check that.

Intel has a processor diagnostic tool, download that. it's more of a CPU stress test, will max out the cpu more than any benchmark I found. It will also tell you if you have a thermal load issue or calculation issues.

I would get crystaldiskmark anyway and bench your ssd. You should find benchmarks for your ssd with a google search to compare. Wouldn't hurt to do that anyway even if you think it's ok.

Enabling the intel iGPU would be a good thing to do, from efficiency and extracting more power from your machine.

 

In your video, you are not using the colorful platform videos. Have you tried downloading the colorful HD platform videos (would also make the theme look a lot better in your setup...) Mayeb it's the platform videos you are using. They could be encoded with a more cpu intensive encoding.

 

Wow, thank you so much for your answer. Let me go through your points in order:

1. VLC player is set in LauchbBox as well as in BigBox. I Also tried switching to Windows Media Player, which didn't solve the problem.

2. I don't think that the CPU is the issue, since BigBox does  not stress my CPU all THAT much. But I downloaded the Intel CPU tool and launched it. The tool set that my CPU passed all the tests, as you can see here:

image.thumb.png.bacfd0696876d4a3c0f107b4d18137c3.png

3. I downloaded CrystalDiskMark and checked the result against other results online. I think the results are comparable? I've added a screenshot, so maybe you can confirm. The 2 results on the left are from a website, the the window on the right shows my benchmark.

image.thumb.png.0e9575c009df04d76ac4954dd840d648.png

4. I wil enable the iGPU then. However, I've read online that if you have a dedicated GPU you shouldn't really enable the iGPU. I'm actually not really sure how I would use the iGPU in combination with my regular GPU. All my displays are connected to the Nvidia GPU anyway. So how would I even use the iGPU?

5. I've tried both the the 4k as well as the HD versions of COLORFUL videos. I switched them out again, because @viking originally suggested that maybe my PC couldn't handle the 4K videos. What I do know now is that the videos are not the issue. All videos, COLORFUL or not, work with other themes. 

Anyway, thank you so much for taking the time to answer =).

Edited by SiriusVI
Link to post
Share on other sites
Posted (edited)

Thats a bit outdated info. Windows 10 (2020H2+) will actually use the iGPU to render your desktop and normal apps as it's more energy efficient than using the nvidia gpu.

When starting an application, Windows 10 will decide what GPU an application requires. So if gaming, Windows 10 will use a discrete graphics card. For web browsing or productivity it will switch to a power saving GPU. Another change is an option so users can assign a specific GPU to individual applications.

Also it depends, you can have your iGPU dedicated to hardware encoding, while you set the nvidia GPU for hardware decoding. For example with the steamlink, I gave the iGPU doing the encoding/decoding so it's not affecting performance on my 970 that runs the games. I can see similar benefits for twitch streaming and more.

There's really no downside to enabling it. IntelQuickSync only works on iGPUs (quick dedicated video encoding/decoding which would be useful for bigbox). I The iGPU is actually better at certain things than the nvidia gpu, simply because it's packaged right in the cpu and just faster to do. You can always change the bios setting back and disable it. Games and certain apps (like photoshop) will automatically choose the best GPU for their use. You will enable the iGPU, reboot to windows, then download the intel drivers, reboot again, then test. Applications and games (along with Windows helping) automatically choose the iGPU. I have mine enabled in my 8700 w/ my 970 for years and never had a reason or issue to disable it. As I said, I found it very useful for steamlink remote streaming without taking up some of my 970 gpu for streaming. I only have a HDMI cable plugged into the nvidia GPU, nothing on the motherboard GPU.

You mentioned earlier the resolution is running at 60hz. I assuming you verified that either on the display or with the NVidia control panel.

Since big box is based on Microsoft Xaml (WPF?), I think it would be more optimized for intel iGPU vs a nvidia GPU. I could always try disabling my iGPU and test to see if I get a slowdown like you, but it should be a quick test for you to do.

The random write speeds on your SSD are much lower than that bench, which is interesting (might be because of a lot of wear), but the read speeds matter more here. Since those are fine, I don't think the SSD is the issue. However my SSD is NVME and it's over 1500MB/s on reads, which does make a big difference on loading things.

I use colorfuldark with the 4k videos. Since you run 1080p, HD videos is what I would use. I also have Windows Defender as my AV. I didn't exlude the launchbox folder or disable real time protection, but you could try that. If you use a 3rd party AV, disable it and test (it could be that AV, many slow down a computer that it's really noticeable how much faster things are with it off)

 

 

Edited by sevenalive
  • Thanks 1
Link to post
Share on other sites
Posted (edited)
8 hours ago, sevenalive said:

Thats a bit outdated info. Windows 10 (2020H2+) will actually use the iGPU to render your desktop and normal apps as it's more energy efficient than using the nvidia gpu.

When starting an application, Windows 10 will decide what GPU an application requires. So if gaming, Windows 10 will use a discrete graphics card. For web browsing or productivity it will switch to a power saving GPU. Another change is an option so users can assign a specific GPU to individual applications.

Also it depends, you can have your iGPU dedicated to hardware encoding, while you set the nvidia GPU for hardware decoding. For example with the steamlink, I gave the iGPU doing the encoding/decoding so it's not affecting performance on my 970 that runs the games. I can see similar benefits for twitch streaming and more.

There's really no downside to enabling it. IntelQuickSync only works on iGPUs (quick dedicated video encoding/decoding which would be useful for bigbox). I The iGPU is actually better at certain things than the nvidia gpu, simply because it's packaged right in the cpu and just faster to do. You can always change the bios setting back and disable it. Games and certain apps (like photoshop) will automatically choose the best GPU for their use. You will enable the iGPU, reboot to windows, then download the intel drivers, reboot again, then test. Applications and games (along with Windows helping) automatically choose the iGPU. I have mine enabled in my 8700 w/ my 970 for years and never had a reason or issue to disable it. As I said, I found it very useful for steamlink remote streaming without taking up some of my 970 gpu for streaming. I only have a HDMI cable plugged into the nvidia GPU, nothing on the motherboard GPU.

You mentioned earlier the resolution is running at 60hz. I assuming you verified that either on the display or with the NVidia control panel.

Since big box is based on Microsoft Xaml (WPF?), I think it would be more optimized for intel iGPU vs a nvidia GPU. I could always try disabling my iGPU and test to see if I get a slowdown like you, but it should be a quick test for you to do.

The random write speeds on your SSD are much lower than that bench, which is interesting (might be because of a lot of wear), but the read speeds matter more here. Since those are fine, I don't think the SSD is the issue. However my SSD is NVME and it's over 1500MB/s on reads, which does make a big difference on loading things.

I use colorfuldark with the 4k videos. Since you run 1080p, HD videos is what I would use. I also have Windows Defender as my AV. I didn't exlude the launchbox folder or disable real time protection, but you could try that. If you use a 3rd party AV, disable it and test (it could be that AV, many slow down a computer that it's really noticeable how much faster things are with it off)

 

 

I enabled iGPU and told windows to start BigBox in energy saving mode which apparently means it's using the iGPU.

image.thumb.png.097c812f25dc9fdafa9dc83706fbd70a.png

Sadly that did not fix the lag in COLORFUL. I'm not sure Im doing it right, though. In my BIOS, "PEG" is still set as the default GPU windows will use.

2. I also already tried disabling Anti Virus Software and BigBox is already excluded from scans, real time detections and firewalls.


I've since tried every single BigBox theme available and the lag really ONLY occurs with COLORFUL. I mean BigBox in general runs pretty slowly when going to the options menu and back to the platform lists, bur once I'm at the platform lists, everything runs super snappy in every theme except for COLORFUL.

 

EDIT: yes, I verified that my TV is running at 60hz. The other two displays run at different refresh rates, but that's not the issue either, since I've tried disconnecting them and using only one display.

EDIT 2: I don't think the iGPU is working correctly. When I start BigBox, the iGPU isn't used, even though I set BigBox to run with the iGPU. Can you make sense of this?
image.thumb.png.94c5ef1ade7fc42084973784feabf29c.png
 

Edited by SiriusVI
Link to post
Share on other sites
Posted (edited)

You should see GPU 0 (Intel 630)  and GPU 1 (Your nvidia card), shouldn't need to force a setting.

I apologize but I dug further with my own system since I posted and I noticed windows was picking the nvidia gpu for videos. 

Have you tried disabling video playback in bigbox settings and seen if that makes a difference? What's interesting is you said you get lag going from the options menu to the platform lists. I don't have that lag. Are you running your display through a hdmi switch, VNC, or KVM? I know you already mentioned you just ran straight to the display. I only see lag when I use remote desktop (but it's not intended to run games / videos over remote desktop so that's not a issue)

Run big box with the task manager open to the perf tab for the nvidia gpu and just check the usage, should be 5-10% (mine was)

The nuke option at this point seems like the only option that will give you the definitive answer. All you need to do is make sure your win activation is backed up on your ms account (see activation settings panel). You would wipe out windows, completely on your drive. Make sure you install win10 with the media creation tool. Make sure your UEFI has the bios compatability off. So ultra fast boot is on, old CSM compat is disabled. Install windows 10. CSM compat being disabled is critical for best win10 perf. You should format your boot disk GPT and delete all the partitions so windows can setup the disk as new (Win10 slightly changed its partition structure with the May 2020 update to fix some flaws with recovery and win upgrades). You probably will have to use a boot menu or change the boot order / settings to allow a USB boot. then boot the windows 10 installer on your USB and install it from scratch. (I don't trust the Recovery > reset W10 option they have, not the same as a real format IMO).

Install everything from new installers / scratch. Use new appdata (no backups of app config, etc). Use new launchbox folder (can save Games, Images, Videos folder). Basically reset and setup your pc from scratch. Don't install any 3rd party AV's. Just Win10, update nvidia drivers, intel chipset drivers, install bigbox and setup again. Import your platforms, and install colorful. Lots of work, but personally I've wiped out my desktop so many times, I can install the apps, configure it, etc quickly. If you do all of that and it still has an issue, then I say it's likely it's your SSD than your GPU. You might want to bench your GPU just in case there's an issue there. Maybe your ssd is too old/too slow for Colorful I guess.

Edited by sevenalive
Link to post
Share on other sites
Posted (edited)
3 hours ago, sevenalive said:

You should see GPU 0 (Intel 630)  and GPU 1 (Your nvidia card), shouldn't need to force a setting.

I apologize but I dug further with my own system since I posted and I noticed windows was picking the nvidia gpu for videos. 

Have you tried disabling video playback in bigbox settings and seen if that makes a difference? What's interesting is you said you get lag going from the options menu to the platform lists. I don't have that lag. Are you running your display through a hdmi switch, VNC, or KVM? I know you already mentioned you just ran straight to the display. I only see lag when I use remote desktop (but it's not intended to run games / videos over remote desktop so that's not a issue)

Run big box with the task manager open to the perf tab for the nvidia gpu and just check the usage, should be 5-10% (mine was)

The nuke option at this point seems like the only option that will give you the definitive answer. All you need to do is make sure your win activation is backed up on your ms account (see activation settings panel). You would wipe out windows, completely on your drive. Make sure you install win10 with the media creation tool. Make sure your UEFI has the bios compatability off. So ultra fast boot is on, old CSM compat is disabled. Install windows 10. CSM compat being disabled is critical for best win10 perf. You should format your boot disk GPT and delete all the partitions so windows can setup the disk as new (Win10 slightly changed its partition structure with the May 2020 update to fix some flaws with recovery and win upgrades). You probably will have to use a boot menu or change the boot order / settings to allow a USB boot. then boot the windows 10 installer on your USB and install it from scratch. (I don't trust the Recovery > reset W10 option they have, not the same as a real format IMO).

Install everything from new installers / scratch. Use new appdata (no backups of app config, etc). Use new launchbox folder (can save Games, Images, Videos folder). Basically reset and setup your pc from scratch. Don't install any 3rd party AV's. Just Win10, update nvidia drivers, intel chipset drivers, install bigbox and setup again. Import your platforms, and install colorful. Lots of work, but personally I've wiped out my desktop so many times, I can install the apps, configure it, etc quickly. If you do all of that and it still has an issue, then I say it's likely it's your SSD than your GPU. You might want to bench your GPU just in case there's an issue there. Maybe your ssd is too old/too slow for Colorful I guess.

Tanks again for taking the time. I'll go through your suggestions:

1. I haven't tried disabling video playback. I will try that and report back.

2. I will make a video later showing you the lag I was talking about.

3. The HDMI cable runs through an Adapter. https://www.amazon.co.uk/Pass-Through-Emulator-splitters-Extenders-fit-Headless/dp/B07C87QFNF
This Adapter is crucial for my setup, since without it, my TV sometimes loses the signal to my PC which makes the GPU driver crash. It's a super weird issue, I won't get into. Took months to troubleshoot and eventually fix. But this is not the problem, since the Lag also occurs on my other two displays which are connected via displayport. And again, this only occurs with the COLORFUL theme.

4. My GPU usage during BigBox use is fairly low as well, at about 2-3%

5. I reinstalled Windows 10 a few months ago. It was a clean install with CSM disabled, just like you suggested.

6. I don't think it's my SSD. I already tried setting up a second Launchbox test install on a different SSD and also on a HDD. The results are the same. A fresh install does not Lag COLORFUL, but as soon as I copy my large collection into it, it starts lagging. That's why I think that the large game collection is the issue, however, as stated before, only in COLORFUL.

EDIT:
1. I've been trying to disable video playback, but I couldn't find the correct option to do so... I tried to navigate to Options --> Videos and remove the ticks on the three options there, but that didn't work. BigBox still plays the platform videos.

2. Here is the video showcasing the general laggyness of BigBox. Note, these lags happens on all the themes, not just on COLORFUL, but browsing through the platforms is smooth with all themes, except for COLORFUL:

https://www.youtube.com/watch?v=fB1hWGDjWrw

There is no sound in that video, but I just flipped through the options and back as quickly as possible (always pressing the buttons right after I entered a specific menu, just so you know that I didn't wait to click the buttons to leave the menus. This is literally how long it takes for me to navigate through bigbox.

EDIT 2:

Another thing we could try - if you'd be willing - is that I could send over my Data folder so you can test my Collection on your setup and tell me if you experience similar problems.

Edited by SiriusVI
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...