Jump to content
LaunchBox Community Forums

Marquee Example - [Theme Workshop]


faeran
 Share

Recommended Posts

Marquee Example - [Theme Workshop]

View File

Marquee Example was built during a Theme Workshop live stream. If you are interested in creating themes, subscribe to the Unbroken Software YouTube channel.

 

Marquee Example

There are 2 files that you can download to help learn about the new Games Marquee view that's available from LaunchBox 12.0, which can be used freely for any theme developer to use as a starting point to learn how to build their own fantastic Marquee screens.

  • Marquee Example - 1.0.zip - The contents can be used to load up into the COMMUNITY Theme Creator, and is free to add to any of your themes.
  • GameMarqueeView - With Comments.zip - This is the same as the default GameMarqueeView with added comments to help you understand how the view is built. You can use this file as a guide while watching the first part of the live stream video, for educational purposes.

 

Watch this theme being built:

 

Credits

COMMUNITY Theme Creator by @y2guru. Find it here: https://forums.launchbox-app.com/files/file/2115-community-theme-creator-for-bigbox/
Subscribe to catch future live stream: https://www.youtube.com/channel/UCSIht6UXIEXIgz4eXAEShxA


 

Link to comment
Share on other sites

I am testing the theme of putting videos on the marquee, and I have a strange behavior.

If I put a video in the platform marquee for example, and this is always played on monitor one, every time I change platform it plays perfectly, but if I configure the marquee as monitor two, when I change platform I have a delay of about 2/3 seconds before the video starts to play smoothly.

I'm testing with the latest Beta 12.2

Link to comment
Share on other sites

2 hours ago, Aiwer said:

I am testing the theme of putting videos on the marquee, and I have a strange behavior.

If I put a video in the platform marquee for example, and this is always played on monitor one, every time I change platform it plays perfectly, but if I configure the marquee as monitor two, when I change platform I have a delay of about 2/3 seconds before the video starts to play smoothly.

I'm testing with the latest Beta 12.2

Hi @Aiwer. The latest version of LaunchBox is currently 12.1, so I assume this is the version that you are on.

Are you using the COMMUNITY Theme Creator to create a platform marquee view or did you delve into the code and add a video to your platform marquee view?

Link to comment
Share on other sites

Hey All

I created a mame marquee view for my cabinet in the Community Theme Creator and am pretty happy with the way it looks. 

In theme creator I created 90% of the marquee using the game metadata images shown below and put them in the Images/Arcade/Arcade-Marquee folder think it might load faster if all those elements were 1 image. Then in the marquee view I added the Text release year,  scrolling highscores, custom badge if it was a top 100 game and a favorite badge.  I need to learn how to adjust the visibilty of the Highscore text scroll so it only shows if there is an active highscore but I am not too concerned now. I want to also play around and maybe show a video snap on the arcade screen shown or played in the background?  

Choplifter.png

In The Hunt.png

  • Like 1
  • Game On 1
Link to comment
Share on other sites

On 10/13/2021 at 4:53 PM, faeran said:

Hi @Aiwer. The latest version of LaunchBox is currently 12.1, so I assume this is the version that you are on.

Are you using the COMMUNITY Theme Creator to create a platform marquee view or did you delve into the code and add a video to your platform marquee view?

Hi @faeran

I'm using Community theme creator and as you say my version is 12.1

I attach the example of platform marquee view, when I put monitor one this work fine, but with monitor 2 I have 2 o 3 second of delay in video

Default_PlatformMarqueeView.txt

Link to comment
Share on other sites

On 10/15/2021 at 2:21 PM, Aiwer said:

Hi @faeran

I'm using Community theme creator and as you say my version is 12.1

I attach the example of platform marquee view, when I put monitor one this work fine, but with monitor 2 I have 2 o 3 second of delay in video

Default_PlatformMarqueeView.txt 2.39 kB · 1 download

The CTC doesn't yet have the new FlowVideo control, so by building it with the CTC you'll be using the old video control which does have problems when running in the marquee view.

You could get around this limitation by adding a User Source element and copy and paste the FlowVideo code into that.

 

  • Thanks 1
Link to comment
Share on other sites

Hi @faeran

 

Thanks for tips with Flowvideo, with this object work great, your are great man ;)

I have only a question, I'm using this code for play marquee video

 

 <!-- MARQUEE VIDEO -->
        <coverFlow:FlowVideo x:Name="MarqueeVideo" VideoType="Marquee" DataContext="{Binding SelectedPlatform}" PlayVideo="True" PlayAudio="False" FallbackToDefault="False">
            <coverFlow:FlowVideo.Style>
                <Style TargetType="{x:Type coverFlow:FlowVideo}">
                    <Setter Property="Visibility" Value="Visible"/>
                </Style>
            </coverFlow:FlowVideo.Style>
        </coverFlow:FlowVideo>
        <!-- MARQUEE VIDEO END -->

I only have a doubt if I want read videos from route "Themes\TestTheme\Media\Videos", how should I specify the source, I have tried several ways and I can't find the way.

I would be very grateful for any advice

Link to comment
Share on other sites

40 minutes ago, Aiwer said:

Hi @faeran

 

Thanks for tips with Flowvideo, with this object work great, your are great man ;)

I have only a question, I'm using this code for play marquee video

 

 <!-- MARQUEE VIDEO -->
        <coverFlow:FlowVideo x:Name="MarqueeVideo" VideoType="Marquee" DataContext="{Binding SelectedPlatform}" PlayVideo="True" PlayAudio="False" FallbackToDefault="False">
            <coverFlow:FlowVideo.Style>
                <Style TargetType="{x:Type coverFlow:FlowVideo}">
                    <Setter Property="Visibility" Value="Visible"/>
                </Style>
            </coverFlow:FlowVideo.Style>
        </coverFlow:FlowVideo>
        <!-- MARQUEE VIDEO END -->

I only have a doubt if I want read videos from route "Themes\TestTheme\Media\Videos", how should I specify the source, I have tried several ways and I can't find the way.

I would be very grateful for any advice

Should be able to reduce the code to this:

<coverFlow:FlowVideo DataContext="{Binding SelectedPlatform}" PlayVideo="True" PlayAudio="False" FallbackToDefault="False" /> 

If you are wanting to have theme specific platform videos, you can place them in the COMMUNITY Theme Creator files, within: My Theme Projects\TestTheme\BigBox Media Overrides\Videos\Platforms

If they are Playlist or Category videos, you should be able to add those folders as well (eg. BigBox Media Overrides\Videos\Playlists)

  • Thanks 1
Link to comment
Share on other sites

If I want to use another video folder, how should I do it?

The problem that I have is that in that route I have put some videos that shows the theme on the monitor, and I want to indicate another totally different route with the specific videos and with the format of the digital marquee.

Is there any way to indicate a folder within the theme as the data source of the videos?

Thank you very much for your time, it is really helping me a lot @faeran

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...