Jump to content
LaunchBox Community Forums

BigBox won't display marquees on monitor 2 for certain games (teknoparrot)


Monsterclip

Recommended Posts

Hi all,

BigBox won't display my marquee images for Teknoparrot games. It works for all other games / emulators. (actually it does work for Tekken 7 on TP, not sure why)

This is huge for my set up, since I have marquee images made for each game that shows the controls.

Here's a video of the problem. You can see it switching resolutions for the game, then the marquee goes black, and that's it. I'm not sure what it's showing there - my desktop isn't black.

https://drive.google.com/file/d/1tyN00itSXpfJN5N4uXsVKW276BEKpZij/view

A few things about my config:

BigBox: In marquees, I have

  • Ignore Theme Marquee Views - OFF
  • Stretch Marquee images to fill screen - ON
  • Screen Hardward Compat Mode: none

I've tried lots of variations on those settings, but I don't want to break all 300+ other games that show their marquees correctly.

System:

  • PC build - i7-3770k, gtx 1070 ti
  • monitor 1 is a 4k monitor. monitor 2 is at 720. Both set to display at 100% scaling

Games

  • DoA 5 Arcade (shown in the link) is set to run at 4k from Teknoparrot
  • Other games like Virtua Fighter 5 Rev C don't have any resolution settings, so they run at whatever their default is (definitely not 4k). That one has the same issue.

 

Any help would be great. Thanks!

Link to comment
Share on other sites

Try changing the position of your marquee monitor in Windows Display settings. BB can be finicky with marquees if the displays are set stacked (Marquee Monitor over top of Main Monitor). Usually it works best if they are left to right. Not sure how your set-up is by try altering them and see if it affects anything.

Even though you say it displays some. I have seen on my set-ups this exact issue and altering the arrangement helped. Might be due to resolution changes of some TP games causing hiccups with BB.

Link to comment
Share on other sites

Appreciate the assistance!

I tried a few layouts but nothing worked.

The first one is what I'm normally running. 

I tried more like a center alignment (image 2) and saw no change

I tried putting it on top, just to test, and that broke all marquees.

image.thumb.jpeg.ebf1c89a14c6b786afd65703c5f9c651.jpegimage.thumb.jpeg.3cb22ce15a43bbe1d014761aa78cb1c9.jpegimage.thumb.jpeg.be4a5f4bba2e9f79bffc6fd6772ad667.jpeg

Edited by Monsterclip
Link to comment
Share on other sites

I wonder if it is the 4K res causing the issue. If you change DOA5 to run in Windowed mode does it have any affect? Maybe try a lower resolution in full screen.

I just set DOA5 up on 2 cabinets with no marquee issues. I do not run 4K though. Just 1080p on the cabinets.

Link to comment
Share on other sites

Well, changing the game to run in Windowed mode fixes the marquee issue. The game runs tiny in the middle of monitor 1, but the marquee is there being shown correctly. 

I changed the game to run at 1080p and it still breaks. 

For science, I even changed my monitor to 1080p and ran the game at 1080p. This was a different result, where the marquee was showing on the right half side of the marquee while my desktop wallpaper was on the left side.

Link to comment
Share on other sites

I don’t have a solution but maybe my troubleshooting can help find a solution.

I am currently trying to fix this issue on my cabinet as well. From what I can tell the resolution of the Teknoparrot games is what is breaking my marquee location and shifting it offscreen or to my third monitor. 

A lot of Teknoparrot games change my resolution of my playfield screen to match the games native resolution and in turn that shifts all of my open windows around, split screens, etc. This also sometimes flips my playfield to my marquee position after I exit the game as it resets back to my preferred res (2560x1440).

I have been able to work around this in the past with Lossless Scaler but little to no success with Teknoparrot. Tekno sometimes launches secondary windows besides the main *.exe. ( I.e. Chaos Code is game.exe but look at the task manger and it opens a secondary app and the window title is something like ???•???)  I can only get lossless to work if the *.exe matches the window name… I think. 
 

I have also tried boardless gaming and internet scaler with no success. 

Link to comment
Share on other sites

I worked out a solution the works for me.  I use Lossless Scaler (Steam) to prevent my playfield from changing resolution and shifting my marquee window out of view, but this does not work with all windows. To help with this I found and edited some scripts. I have to run TeknoParrot as Admin to get Mario Kart DX to work properly. Due to this, I have to set the Lossless Scaler setting to run as admin (in app, not windows settings) and I added a part to launch the script to launch as admin as well.  This seems to work but it's a work around.  It waits 40sec then send the default scale hotkeys in Lossless. Whatever window that is on top after 40sec. will be forced scaled full screen.  You can adjust the Sleep time to work for you needs or for individual games if you make game specific ahk copies. I found the 40sec. sleep works for most of my games. Hope this solve your problems for now until a native fix is available. Also, you need to set the game in TeknoParrot to run windowed for this to work properly.

Hope this Helps! let me know how it goes.  b

*Edit - Set Lossless to Launch at startup and minimize

Scale Force.7z

Edited by SrfrBoyBobby
added note
Link to comment
Share on other sites

Hi SrfrBoyBobby,

I know you are responding to a previous comment and I do not even use marquees, but some of your remarks I recognize as problems I had to find solutions for myself.

4 hours ago, SrfrBoyBobby said:

I have to run TeknoParrot as Admin to get Mario Kart DX to work properly.

As far as I know you do not need to run TeknoParrot games as Admin. If I remember correctly you only needed to run Mario Kart DX as Admin for netplay. And I do not know if that's still a requirement. You can disable the UAC prompt for elevation in TeknoParrot\UserProfiles\MKDX.xml. Change:

<RequiresAdmin>true</RequiresAdmin>  to  <RequiresAdmin>false</RequiresAdmin>

4 hours ago, SrfrBoyBobby said:

Also, you need to set the game in TeknoParrot to run windowed for this to work properly.

I also run my TeknoParrot games windowed. But with an AutoHotKey script you can maximize the game window to fullscreen easily. It basically becomes a borderless fullscreen window.

This is an example for Super Street Fighter IV Arcade Edition:

#NoEnv
#SingleInstance
;#NoTrayIcon
SendMode Input
SetTitleMatchMode, 3

WinWait, OpenParrot - Super Street Fighter IV Arcade Edition (Export) - Nov  4 2010 14:01:12
Sleep 1000
WinSet, Style, -0xC40000, OpenParrot - Super Street Fighter IV Arcade Edition (Export) - Nov  4 2010 14:01:12
WinMaximize

So in TeknoParrot set up your game to run windowed and add an AutoHotKey script like this (but adjusted to your game) as an additional app to your game in LaunchBox.

*Edit*

To be clear, the script waits for the game window to open, strips the window decoration (border) and then stretches the game window to your monitor resolution. I believe this will solve the problem of your games changing monitor resolutions all the time.

Edited by Your Friendly A.I Overlord
Link to comment
Share on other sites

Thanks I’ll check that out. Star Wars battle pod was giving me some issues where it kept popping out of maximized (F11). Next issue I have is Luigis Mansion runs full screen no matter what I do. The windowed option makes no difference and I have mucked around in the config files in LM with no results. Maybe this script will do it.
 

Thanks! 

Link to comment
Share on other sites

2 hours ago, SrfrBoyBobby said:

Thanks I’ll check that out.

I simplified the script somewhat. Now you only have to put in the name of the game's executable.

#NoEnv
#SingleInstance
#NoTrayIcon
SendMode Input
SetTitleMatchMode, 3

WinWait, ahk_exe game.exe ; change to the name of the executable of your game.
WinGetTitle, WinTitle
Sleep 1000
WinSet, Style, -0xC40000, %WinTitle%
WinMaximize

 

2 hours ago, SrfrBoyBobby said:

Star Wars battle pod was giving me some issues where it kept popping out of maximized (F11).

Sorry. I do not have that game.

2 hours ago, SrfrBoyBobby said:

Next issue I have is Luigis Mansion runs full screen no matter what I do. The windowed option makes no difference and I have mucked around in the config files in LM with no results.

For me neither. But it doesn't give me issues. But keep in mind the following:

- Sometimes you can set a custom resolution for a game in TeknoParrot. (Mario Kart DX)

- Sometimes scaling issues can be fixed by right clicking the game's executable > Properties > Compatibility > tick "Override High DPI Scaling"  and select "Application".

- User resolution patched TeknoParrot games can be finicky. I myself only want the original .exe's. But you can try both.

- Sometimes a script can't make a game go fullscreen properly. (At least I can't.) Below a screenshot for Mario Kart DX when you maximize the game window to 2160p with a script.

467937426_Schermopname(135).thumb.jpg.c5855f0a30be0529c00e7fe0819566bc.jpg

Edited by Your Friendly A.I Overlord
Link to comment
Share on other sites

Thanks for the script.  Will try it and see how that goes.  The tips are great, and I have gone through that check list with no change with Luigi. Quite a few of the TP games use very specific resolutions but most of them I can get going. I just have to learn to accept the ones that don't - lol

Edited by SrfrBoyBobby
Link to comment
Share on other sites

On 8/30/2022 at 2:48 AM, Monsterclip said:

Well, changing the game to run in Windowed mode fixes the marquee issue. The game runs tiny in the middle of monitor 1, but the marquee is there being shown correctly. 

I changed the game to run at 1080p and it still breaks. 

For science, I even changed my monitor to 1080p and ran the game at 1080p. This was a different result, where the marquee was showing on the right half side of the marquee while my desktop wallpaper was on the left side.

 

did you happen to try each side of your screen? it looks like you might have only tried top and the right hand side. give the left hand side a shot if you not yet. I too was only working with one side and the top, though I tried bottom too, it wasn't until I put it on the right hand side it worked for me. Maybe in your case you need the left hand side? your situation sounds super similar with stuff rendering at a much smaller resolution than the screen with the marquee displaying also. the thread I made to help troubleshoot this and what was the final solution for me is here:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...