Jump to content
LaunchBox Community Forums

Recommended Posts

@eatkinola cache is not refresing on this theme, i had to do it manually inside "MinimalX/Plugins/Ao.Bigbox.Themer.v3_9_2". I don't know if this is because the changes i made or if it's something related to the plugin (i have no idea about programming).

By the way this is one of the best themes, i've been using this and flux for a long time and i'm amazed how customizable and well documented are your themes, so easy to change everything.

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, qu1r0s said:

@eatkinola cache is not refresing on this theme, i had to do it manually inside "MinimalX/Plugins/Ao.Bigbox.Themer.v3_9_2". I don't know if this is because the changes i made or if it's something related to the plugin (i have no idea about programming).

That's currently the only way to do it. There are two ways I could help automate this: (1) have it automatically delete the cache for a theme when you switch to that theme, or (2) create a system menu item for doing this. I kinda like option 1 as it'd quietly do it's thing in the background; the cache would not be deleted when starting BB, only when actually changing to that theme in BB.

5 hours ago, qu1r0s said:

By the way this is one of the best themes, i've been using this and flux for a long time and i'm amazed how customizable and well documented are your themes, so easy to change everything.

Awesome, thanks! I try to keep things documented partly so I can remember how they work later. I do need to document the cache thing better.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, eatkinola said:

That's currently the only way to do it. There are two ways I could help automate this: (1) have it automatically delete the cache for a theme when you switch to that theme, or (2) create a system menu item for doing this. I kinda like option 1 as it'd quietly do it's thing in the background; the cache would not be deleted when starting BB, only when actually changing to that theme in BB.

Awesome, thanks! I try to keep things documented partly so I can remember how they work later. I do need to document the cache thing better.

No problem, i just thought it was me because i'm doing some changes on the theme for my own use.

Is there any way to change the progress thing for other information or simply delete it? I think is hardcoded...but i have to ask 😅1582174250_SuperfamicomMinimalX.thumb.png.c57e90c0785a4e77643be58dd738b466.png

Share this post


Link to post
Share on other sites
6 minutes ago, qu1r0s said:

Is there any way to change the progress thing for other information or simply delete it? I think is hardcoded...but i have to ask 😅

Yea the format of this text is hardcoded. You can however remove this Progress line entirely. Look for this in AOStyles.xaml:

    <!-- FILT/GAME: METADATA TABLES (SIDEBAR) -->
    <FontFamily x:Key="AOMetadataTableFontFamily_TAG">Calibri</FontFamily>
    <FontWeight x:Key="AOMetadataTableFontWeight_TAG">Bold</FontWeight>
    <SolidColorBrush x:Key="AOMetadataTableFontColor" Color="#CCFFFFFF" />
    <Style x:Key="AOMetadataTableSide" TargetType="aop:AbstractMetadataTable">
        <Setter Property="TagFontFamily" Value="{DynamicResource AOMetadataTableFontFamily_TAG}" />
        <Setter Property="TagFontWeight" Value="{StaticResource AOMetadataTableFontWeight_TAG}" />
        <Setter Property="Foreground" Value="{StaticResource AOMetadataTableFontColor}" />
    </Style>
    <Style x:Key="AOMetadataTableSide_PLAT" TargetType="aop:PlatformMetadataTable" BasedOn="{StaticResource AOMetadataTableSide}">
        <Setter Property="FieldOrder" Value="PlatformGamesCompleted,PlatformStarRatingsAvg,PlatformReleaseYear" />
        <Setter Property="ColumnBalance" Value="-0.15" />
    </Style>
    <Style x:Key="AOMetadataTableSide_GAME" TargetType="aop:GameMetadataTable" BasedOn="{StaticResource AOMetadataTableSide}">
        <Setter Property="FieldOrder" Value="GamePlatform,GameProgress,GameReleaseYear" />
        <Setter Property="ColumnBalance" Value="-0.15" />
    </Style>

For AOMetadataTableSide_GAME, edit "FieldOrder" to remove "GameProgress". Available options for fields are:

Spoiler

        /**
         * Field name enumeration for this control.
         */
        public enum FieldNames {
            None,
            GameAgeRating,
            GameDeveloper,
            GameGenres,
            GamePlatform,
            GamePlayModes,
            GameProgress,
            GameRegion,
            GameReleaseYear,
            GameStarRating,
            PlatformControllers,
            PlatformCpu,
            PlatformDeveloper,
            PlatformDisplay,
            PlatformGraphics,
            PlatformManufacturer,
            PlatformMedia,
            PlatformMemory,
            PlatformReleaseYear,     // note: calculated maybe
            PlatformSound,
            PlatformGamesCompleted,  // note: calculated field
            PlatformLastPlayedDate,  // note: calculated field
            PlatformLastPlayedGame,  // note: calculated field
            PlatformLastPlayedGada,  // note: calculated field
            PlatformMostPlayedGame,  // note: calculated field
            PlatformStarRatingsAvg   // note: calculated field
        }

Your theme mods look nice!

  • Thanks 1

Share this post


Link to post
Share on other sites

Wow.  Thanks for this Theme.  Just installed it and will be using it.  Wish it could be installed via Big Box though :)

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, Richakev said:

Wow.  Thanks for this Theme.  Just installed it and will be using it.  Wish it could be installed via Big Box though :)

Cool, hope you like it. I just submitted it for the BB theme downloader; hopefully it makes the cut.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, serlisboa said:

Can anyone help me to appear the wheel in the game roulette in the MinimalX theme.

You need to go into BigBox settings and change the game and platform views to wheel view #4, which will display platform/game clear logos in the wheel. You can map a keyboard shortcut to quickly cycle through views, or you can go into BigBox settings each time.

Share this post


Link to post
Share on other sites
4 minutes ago, eatkinola said:

You need to go into BigBox settings and change the game and platform views to wheel view #4, which will display platform/game clear logos in the wheel. You can map a keyboard shortcut to quickly cycle through views, or you can go into BigBox settings each time.

OK

I'm at work and when I get home I will make the settings given.

Thank you.

 

Share this post


Link to post
Share on other sites

I want to set up auto-videos for non-platform playlists and to display games similar to the last two example screenshots show on the download page. However, even after reading the PDFs, I'm struggling to get either feature working. I turned on METADATASLIDETOGGLE and AOSELECTORSIDETOGGLE in the AOStyles XAML and couldn't replicate the two screenshots in any view setting. Meanwhile, playlists are still not display a video when highlighted, which should be the default according to the theme description on the download page.

Thanks in advance to anyone with some help or advice on this!

Share this post


Link to post
Share on other sites
On 4/12/2020 at 12:33 PM, huh123 said:

However, even after reading the PDFs, I'm struggling to get either feature working. I turned on METADATASLIDETOGGLE and AOSELECTORSIDETOGGLE in the AOStyles XAML and couldn't replicate the two screenshots in any view setting.

I see what you mean -- you should be able to get it working with these three settings in Styles.xaml:

    <System:String x:Key="AOMetadataSideToggle">AOMetadataFadeSide_ON</System:String>
    <System:String x:Key="AOSelectorSideToggle">AOSelectorFadeSide_ON</System:String>
    <System:String x:Key="AOMetadataOtopToggle">AOMetadataFadeTop_TEMP</System:String>

AOMetadataOtopToggle must be set to _TEMP. This is a bug -- you shouldn't have to set it to _TEMP, but doing so should make it work like you expect.

On 4/12/2020 at 12:33 PM, huh123 said:

Meanwhile, playlists are still not display a video when highlighted, which should be the default according to the theme description on the download page.

For this feature to work, you have to use use Big Box settings > Options > Videos > (check) Use Random Game Videos for Missing Platform Videos. This feature respects that setting.

Share this post


Link to post
Share on other sites

  Hey, thank you so much for responding!

12 hours ago, eatkinola said:

I see what you mean -- you should be able to get it working with these three settings in Styles.xaml:

    <System:String x:Key="AOMetadataSideToggle">AOMetadataFadeSide_ON</System:String>
    <System:String x:Key="AOSelectorSideToggle">AOSelectorFadeSide_ON</System:String>
    <System:String x:Key="AOMetadataOtopToggle">AOMetadataFadeTop_TEMP</System:String>

AOMetadataOtopToggle must be set to _TEMP. This is a bug -- you shouldn't have to set it to _TEMP, but doing so should make it work like you expect.

 

I added those settings in AOstyles.xaml and still am not getting it to work. Is it a specific view I need to choose as well? For reference, I'm trying to replicate the style in the last screenshot (displaying Baten Kaitos Origins), where boxart/metadata is shown on a left column and the video plays in the much-larger chunk of the screen remaining. The best I can get is the the text/metadata all in the front, overlaying video in the background.

12 hours ago, eatkinola said:

For this feature to work, you have to use use Big Box settings > Options > Videos > (check) Use Random Game Videos for Missing Platform Videos. This feature respects that setting.

This I'm even more confused on. I have those settings and they work for my regular platform playlists. However, I have one playlist that displays with the platforms, it has multiple games with video, and...still nothing.

Share this post


Link to post
Share on other sites
On 4/14/2020 at 9:03 AM, huh123 said:

I added those settings in AOstyles.xaml and still am not getting it to work. Is it a specific view I need to choose as well? For reference, I'm trying to replicate the style in the last screenshot (displaying Baten Kaitos Origins), where boxart/metadata is shown on a left column and the video plays in the much-larger chunk of the screen remaining. The best I can get is the the text/metadata all in the front, overlaying video in the background.

Please post a screenshot of what it looks like currently on your setup.

On 4/14/2020 at 9:03 AM, huh123 said:

This I'm even more confused on. I have those settings and they work for my regular platform playlists. However, I have one playlist that displays with the platforms, it has multiple games with video, and...still nothing.

Sound like it works on your setup with certain situations but not others. For the playlist that displays with the platforms ... would you please describe what you mean or perhaps post screenshots or a video. I like screenshots; they usually help me understand the issue better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...