Jump to content
LaunchBox Community Forums

MAME has been destroyed with updates??? Now using latest 0.192 version


dudechester
 Share

Recommended Posts

The Mame collection was and has been working great for a long time.

Today I launched up to play some games, and saw there is quite a big update to MAME version, and since it's been a while, I updated to 0.192

Now it's completely broken. Games suddenly have files which are not found all over the place. Nearly all the Street fighter games are no longer working.

Each game is asking for different files which are supposedly missing, but these games used to work before this mame update...

Disaster... Anyone have any idea what's going on please?

Link to comment
Share on other sites

Yes, you haven't updated your roms to match the emulator version. MAME is very picky with its files and new files get added all the time when better dumps are found and such, the Streetfighter error is probably a qsound error as that was changed a few versions back. You have a few options here, update your roms to 0.192, download a new 0.192 romset, or revert to the version of MAME that was working for you previously. 

  • Like 1
Link to comment
Share on other sites

It is always recommended that you match your romset with the correct version of MAME for it to avoid these issues, if you want the latest and greatest version of the emulator (which is updated every month fyi) then you need to keep your romset in check as well otherwise you will have issues like this where games are no longer compatible with the emulator. 

Here is a great tutorial Critical Cid did on how to update your romset.

 

  • Thanks 1
Link to comment
Share on other sites

What Mame are you using? Command line or MameUI?

If MameUI in addition to what @neil9000 mentioned another issue specific to MameUI is it now reads the config files from the main folder instead of the Ini folder. You can copy the config files in the Ini folder and paste them in the root (main) folder you have the mame exe file. I had the same issue. Since getting this to work I ditched MameUI and just use the command line version. 

Link to comment
Share on other sites

We could technically use any version since we are launching through launchbox, and the UI doesn't actually ever get to see the light of day :D But yes I realised these issues through using the Mame 64bit main version.

Won't want to update often if this trouble happens every time. Occasionally I updated the Mame version, but have never had games stop working in the past. It only seems this one, and relative to some of the files Neil mentions.

Link to comment
Share on other sites

  • 2 weeks later...

Cheers Retro808,

I had the same issue with files missing for all my games.  However my roms worked when launched via mameui directly, not through Launchbox (thus proving roms and mame matched).

If you hadn't have said about moving the ini files i'd never would have worked that out.

Top banana

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...